Jump to content

Blender was detected an removed because it was detected as ransomware.


Recommended Posts

I installed malware bytes about a week ago and I was able to use blender fine but when I tried to import an image, blender suddenly closed and wouldn't reopen. Malware bytes quarantined it for being ransomware and I'm not sure why.

Link to post
Share on other sites
2 hours ago, oats said:

I installed malware bytes about a week ago and I was able to use blender fine but when I tried to import an image, blender suddenly closed and wouldn't reopen. Malware bytes quarantined it for being ransomware and I'm not sure why.

Please update to the current version released today and restart the computer and test again.

 

Link to post
Share on other sites
1 hour ago, reverted said:

I'm all up to date.

There is a known issue which causes MS Office  and Others to be blocked incorrectly due to an issue with non-default settings.  To fix the issue, open Malwarebytes and go to settings by clicking the small gear icon in the upper right, then go to the Security tab and under the Exploit Protection section make sure that the option to block penetration testing attacks is set to off, then click the Advanced settings button and click on the Restore Defaults button and wait around 30 seconds to allow the protection to reset itself, then test to see if the problem is fixed.

The images below should help if needed:

Advanced.png.8e1e1e0c1a63e191cd8ce7afead3432f.png

Defaults.png.31cc5ece3df1c4e7055fc95a72477ace.png

Please let us know if that fixes the issue or not.

Thanks

Edited by Porthos
Link to post
Share on other sites
2 minutes ago, reverted said:

Thanks for the help. I don't see this option in the latest version. 4.2.3.

Then do the advanced settings and restore defaults.

 

2020-11-17_14h16_04.png

Link to post
Share on other sites
Just now, reverted said:

Thanks for the help. It appears to be fixed now.

If you have further issues we are here to help. Be safe.

  • Thanks 1
Link to post
Share on other sites

I'm back to this again as I'm still having the issue. This time was worse as I was forced to reboot. I'm trying to work here. The issue isn't strictly blender but when I try to use an AddOn (plugin) called Hard Ops. I installed the latest version a week ago and whenever I try to use any of the tools, Blender crashes and I get the ransomware warning from Malwarebytes. It's a legit, paid for plugin, download from the official source and I don't see others having the same issue. 

Link to post
Share on other sites
1 hour ago, reverted said:

I'm back to this again as I'm still having the issue. This time was worse as I was forced to reboot. I'm trying to work here. The issue isn't strictly blender but when I try to use an AddOn (plugin) called Hard Ops. I installed the latest version a week ago and whenever I try to use any of the tools, Blender crashes and I get the ransomware warning from Malwarebytes. It's a legit, paid for plugin, download from the official source and I don't see others having the same issue. 

Please do the following Uninstall and reinstall using the Malwarebytes Support Tool

Please have lots of patience with the tool.  The first phase is a cleanup and does require a Windows Restart.
After the Restart, it may take 2 - 3 - 4 minutes till the Support tool screen shows up.   Please be patient and have faith.  Wait for it, whatever it takes.
The 2nd phase is where it offers to do a new Install.

 Let me know if that clears up the issue or not.

  • Thanks 1
Link to post
Share on other sites
2 minutes ago, reverted said:

Should I remove it before using the support tool?

Wont matter as the clean install will put everything back to default anyway.

  • Thanks 1
Link to post
Share on other sites
Just now, reverted said:

PorthosThanks for all your help. I've rebooted and re-installed and it now appears to be finally fixed. Thanks again.

Glad to assist. Please keep us informed if you encounter any more issues.

  • Thanks 1
Link to post
Share on other sites
1 hour ago, reverted said:

I'm back to this again as I'm still having the issue. This time was worse as I was forced to reboot. I'm trying to work here. The issue isn't strictly blender but when I try to use an AddOn (plugin) called Hard Ops. I installed the latest version a week ago and whenever I try to use any of the tools, Blender crashes and I get the ransomware warning from Malwarebytes. It's a legit, paid for plugin, download from the official source and I don't see others having the same issue. 

It must be the blender addons triggering it then. When I used 'images as planes' (the addon that comes with blender) to import an image my blender crashes.

Link to post
Share on other sites

oats, it started happening for me after the latest Malwarebytes update. I had installed an addon the week before with no issues. Hard Ops was updated recently so I was installing it after the Malwarebytes update. Glad Prthos was able to fix the issue for me. Hopefully it fixes your issue too.

Link to post
Share on other sites

MB just started doing this to me as, I was able to run Blender 2.90.1 no issues a few days ago using Hard Ops now MB just shits the bed, and after following the directions above it has not fixed anything FYI. The screenshot is the 4th time in the past hour.

 

mb_fail.PNG

Link to post
Share on other sites
  • Staff

Guys, this is an FP of the Ransomware Protection. We need the logs so our Research team can assess and make any necessary adjustments. In the meantime, you can add an exclusion as mentioned.

Can you please collect and upload as an attachment the diagnostic data using our MBST?

  • Download and run the Malwarebytes Support Tool
  • Accept the EULA and click Advanced tab on the left (not Start Repair)
  • Click the Gather Logs button, and once it completes, attach the zip file it creates on your desktop to your next reply

 

Link to post
Share on other sites
  • tetonbob changed the title to Blender was detected an removed because it was detected as ransomware.

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.