Jump to content

Recommended Posts

Hi,

I had to run some fixes yesterday which included reinstalling .NET framework. Any updates to .NET invariably breaks the sound (Windows 10). 

Now, there's a setting somewhere I previously discovered by accident when trying to connect to my tv that turns the sound back on (it was a sub-menu of something) but I cannot find it for love nor money. I've been six hours looking for it today but I'm ready to launch it out the actual window. 

 Does anyone know where I can find this setting - there's like several 'adapters' or something like that, one being a Soundblaster one that if I just click on it, the sound is fixed. 

Link to post
Share on other sites

Greetings,

If you right-click on the sound icon in the notification area/tray near the system clock and select Open Sound settings, you should see a drop-down menu at the top of the settings window labelled Choose your output device, and changing that to the appropriate sound card/output device should correct the issue, at least that's what I'm thinking based on your description of it.

I hope this helps, but let us know if it doesn't as others may have additional potential solutions.

Link to post
Share on other sites

Hi, thank you for the reply.

No, it isn't that. It's accessed via the Search box and is a sub-menu from something found from there. Like I say I discovered it by accident trying to watch video on my tv and couldn't figure out how to connect my tv so I was rummaging around through various menus. It appears in a random place, however, and it's in something like 'adapters' or something like that and there's a list of, I think, 3 completely unconnected 'adapters'.

I've spent all day going through menu after menu and I just can't find it or remember what it is called. Absolutely doing my head in because it's a one-click fix.

It isn't a driver issue or anything like that.

Link to post
Share on other sites

OK, it sounds similar to the setting I described, but I think I know what you're referring to.  Does it look more like an old-school Windows menu with the gray background and all, rather than the more 'modern' settings interface?  If so, it may be accessible by right-clicking the sound icon and selecting Open Volume mixer, then clicking the small down arrow under the Device column which should be the first one on the left, then selecting the appropriate device.

Both that, as well as the settings item I described in my first post can control what Windows uses as a source/output for sound for the system, and I've had my share of troubles with it as well (a common issue with most systems supporting analog output as well as digital/HDMI and the like, especially when motherboards and discrete GPUs have their own HD Audio outputs/devices).

Link to post
Share on other sites

Oh, and if that isn't it either, try once again right-clicking the sound icon in the tray and selecting Sounds this time, then select the Playback tab and try right-clicking the output device you want to use and selecting it as the default device and that might do it.

Link to post
Share on other sites

Again, thank you for the replies. 

No, it isn't any of these things. Everything is configured correctly to Soundblaster in every sound setting. The sound is there - it's just very, very quiet and barely audible at full volume (obviously I've checked all the volume levels etc.)

First time this happened to me I spent a week installing / uninstalling adapters, sound cards, drivers, opening help tickets, etc, etc. and just couldn't get it to work and had given up trying to get sound on my computer. Then I was trying to get a video to play on my tv and was using the Search box looking for 'Connect to a Wireless display' or 'Bluetooth' or something and in a sub-menu somewhere I found this 'Adapters'- type list of around 3 or so seemingly unconnected options, one being 'Soundblaster' - one click and everything was working.

Next time this happened it took me 2 minutes to fix and I stupidly didn't write it down because I was absolutely certain I would remember it if it happened again. Yeah, that was optimistic.

Link to post
Share on other sites

OK, what about the Communications tab?  There's an option there to lower the sound volume when the mic is in use, and if the mic is always on for some reason, that might be it.  Or it could be an issue with the wrong output/connection type being selected for the sound card.

If it's still a no-go, one of the options in this article may prove helpful to you, though I know you've already tried most, if not all of it (I'm hoping there's at least one we've missed in there).

Link to post
Share on other sites

Again, thank you for the reply and your time.

I went through everything (some things for about the twentieth time today lol) but it's none of these things. 

It's definitely accessed from a menu that is launched from the Search box. It isn't in a pop-up box or tab but rather it comes up in another sub-menu somewhere that is accessed from a link on one of the pages. Very frustrating not being able to find it.

Link to post
Share on other sites

Every setting, option and program is accessible from search in the START menu, so unfortunately it could be anything.  That said, maybe it was something under the Control Panel, like an applet for the driver itself?  If it's Creative/Soundblaster, it could be something like their SBX app, and I do recall that SBX has an option to select the output device, and if it isn't set correctly you won't have any sound, so maybe check there.  It's a drop-down menu on like the last tab I *think* (sorry, it's been a bit since I had a system with Creative/SBX on it, but I distinctly remember going through that once or twice).

Link to post
Share on other sites

Thanks again.

I've been through every Creative / Soundblaster app on my computer many times (umpteen restarts / testing different things).

I've also drilled down through every Control Panel option and every Settings option several times. Always possible I've missed something but I'm beginning to wonder if the thing I'm talking about has been removed by M$ - I distinctly remember it only being 2 or 3 clicks in and I'm sure I initially searched for wireless or bluetooth & other devices or something like that under Settings. 

Link to post
Share on other sites

The only thing I can think of that sounds like that would be Control Panel > Hardware and Sound > Manage audio devices, but that's the same thing I already mentioned in one of my above posts.  What's the exact model/maker of your PC?  Maybe I can figure out exactly what hardware/software you should be working with for the device and get to the solution that way.

Link to post
Share on other sites

Here's an example from my system; I had to set the HD Audio speakers as my default since my HDMI connected monitor has no speakers and I'm using wired speakers connected to the built in sound card/chip:

sound.png.6d1030bf21e419d08e49a384c3ff8a55.png

Link to post
Share on other sites

By the way, if you click on a device in the above menu and click the Configure button, it gives you a wizard to select the appropriate speaker configuration, and if it's set to use a surround sound configuration (such as 5.1, quad channel or 7.1 etc.) that isn't present/supported, you could end up with the sound muted/not working, so maybe that's a possibility (assuming you didn't try that already).

Link to post
Share on other sites

Please download the following tool and run it. Then allow it to update the programs it finds.

 

Patch My PC Home Updater
https://patchmypc.com/home-updater

After the updates have been done and the computer restarted please run the items below.

 

Please download Farbar Recovery Scan Tool and save it to your desktop.

Note: You need to run the version compatible with your system.
You can check here if you're not sure if your computer is 32-bit or 64-bit

  • Double-click to run it. When the tool opens click Yes to disclaimer.
  • Press the Scan button.
  • It will make a log (FRST.txt) in the same directory the tool is run. Please attach it to your reply.
  • The first time the tool is run, it also makes another log (Addition.txt). Please attach it to your reply as well.

 

 

Please download HWiNFO the Professional System Information and Diagnostics program.
HWiNFO Portable for Windows

Unzip the program to its own folder such as C:\HWiNFO
Go to the new folder and locate the file C:\HWiNFO\HWiNFO64.exe and double-click to run it.
Click the RUN button.
Ignore the update, click close.
Click on Save Report and choose HTML and click Next, then Finish
By default, it will create a new report named COMPUTER.HTM in the same folder as the program. C:\HWiNFO
Please zip that file and attach it to your next reply

 

Thanks

 

Link to post
Share on other sites
9 hours ago, exile360 said:

What's the exact model/maker of your PC?

It's a custom build. Few years old now right enough but does what I need.

I very much appreciate all your suggestions - I've been through them all (see below). 

7 hours ago, AdvancedSetup said:

Please download the following tool and run it. Then allow it to update the programs it finds.

Ok, I did all that. 

I've no idea how but somehow this fixed the sound!!! It's working!

Brilliant. Thank you everyone!!!!

DESKTOP-3HG61PL.zip FRST.txt Addition.txt

  • Like 1
Link to post
Share on other sites

That's great news @ForumName

I would recommend you go to Control Panel, Programs, Programs and Features and uninstall the following software.

Bonjour

 

What exactly is mDNSResponder.exe? (Bonjour)

https://www.groovypost.com/howto/howto/what-is-mdnsresponder-exe-and-why-is-it-running/

MDNSResponder, also known as Bonjour, is Apple’s native zero-configuration networking process for Mac that was ported over to Windows and associated with MDNSNSP.DLL.  On a Mac or iOS device, this program is used for networking nearly everything.  On Windows, this process is only necessary for sharing libraries via iTunes and other Mac applications like the Apple TV that were ported to Windows.  Bonjour allows different computers running iTunes to communicate with each other regardless of network configuration, this is because it enables automatic network discovery.

What Is mDNSResponder.exe / Bonjour and How Can I Uninstall or Remove It?
https://www.howtogeek.com/howto/6456/what-is-mdnsresponder.exe-bonjour-and-how-can-i-uninstall-or-remove-it/

 

 

 

You appear to have another computer on your network using the same name. It might be a virtual computer, some other computer, or even old cache on the router.

I would recommend renaming one of your computers to a different name.

Application errors:
==================
Error: (10/06/2020 09:55:13 AM) (Source: Bonjour Service) (EventID: 100) (User: )
Description: Local Hostname DESKTOP-3HG61PL.local already in use; will try DESKTOP-3HG61PL-2.local instead

 

 

Both Firefox and Google Chrome have some type of Policy Restriction on them. If it's on purpose no harm, if not then you may want to consider removing the restriction.

FF HKLM\SOFTWARE\Policies\Mozilla\Firefox: Restriction <==== ATTENTION
CHR HKLM\SOFTWARE\Policies\Google: Restriction <==== ATTENTION
CHR HKU\S-1-5-21-371172249-3598810782-1006532483-1001\SOFTWARE\Policies\Google: Restriction <==== ATTENTION

The following link has extensive information on cleaning up Google Chrome

Review the Registry for Firefox
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Mozilla

 

Again though if these are valid blocks or restrictions then leave them in place.

 

For reference to help better protect your data and privacy

 

Take care and very glad your sound is working again now.

 

 

  • Thanks 1
Link to post
Share on other sites

It likely updated one of the drivers and/or the associated software, restoring the default settings for the sound card/output in the process.  I'm glad it's finally fixed, and hopefully you won't encounter it again down the road, but at least now we know one possible way to fix it.

  • Like 1
Link to post
Share on other sites
2 hours ago, AdvancedSetup said:

I would recommend you go to Control Panel, Programs, Programs and Features and uninstall the following software.

Bonjour

Didn't even know that crap was on my computer! Thanks.

2 hours ago, AdvancedSetup said:

You appear to have another computer on your network using the same name

Yeah, I'll need to look into that. As far as I can see there's only one computer on my network. I wonder if it's related to Acronis?

2 hours ago, AdvancedSetup said:

Both Firefox and Google Chrome have some type of Policy Restriction on them

I don't have FF on my computer. No idea why that's there but I'm guessing it's Bitdefender doing it. I'll need to investigate some more.

Again, thanks for the help all!

  • Like 1
Link to post
Share on other sites

Unfortunately there was another update to .NET which borked the sound again. 

I've worked through every M$ (https://support.microsoft.com/en-gb/help/4520288/windows-10-fix-sound-problems) and umpteen other pages from the search results.

I've worked through all the suggestions on this page.

I've run the software suggestions above which previously seemed to fix the sound but they didn't work this time. 😕

Addition.txt DESKTOP-3HG61PL.zip FRST.txt

Link to post
Share on other sites

It's an older (AMD FX) based system, so it's quite possible that these issues stem from a lack of full testing/support from MS, and that could be why this issue keeps occurring.  Hopefully we can get it working again though.

You said you went through all the suggestions, but I'd like to see if maybe we can track down some newer software/drivers for your hardware, get it all installed fresh, then see if maybe that doesn't fix it.  You're using the PCIe Creative/Soundblaster card as your primary audio device, right?  HWInfo shows it as the Recon3D which is End of Life/End of Support according to Creative's website, so the latest driver for it is this one (that's the last released driver package direct from Creative's support site for the Recon3D PCIe located here).  If that isn't the version you have installed already, go ahead and download and install it to see if that helps.

I think part of the issue might be that you have 3 sound devices in the system; one on your motherboard (Realtek HD Audio), one built into your GPU for HDMI audio (NVIDIA), and of course your PCIe Creative Recon3D card.  If Windows isn't configured to use the right one, you won't get audio.  If the outputs on the sound card aren't set correctly (they can usually be changed manually to use each port for either input or output), that could also cause problems.  But given the fact that the issue returned when you updated .NET, that would seem to indicate that the root cause might be some kind of application compatibility issue, like if your Creative software suite that controls the card uses .NET and it doesn't play well with Microsoft's latest .NET patch, then maybe that's the reason for the issue.  In that case, it might actually be worth a shot to uninstall Creative's drivers/software from Programs and Features, reboot the system, then let Windows install the latest driver it has for the hardware from Windows Update, assuming they have a driver for it.

If not, then your only option might be to pull the card and try using the onboard audio, assuming the onboard audio works.

What do you see when you click the audio icon in the tray?  Does it look like this?:

volume.png.6e6e88ccaf0cdbc38b317bac9cccc0a8.png

If you click Mixer at the bottom, what do you see and what does the title bar at the top of it say for the name of your audio device?:

mixer.png.6cf794bd944c3521eef85b731472d63b.png

Next, if you right-click the Windows sound icon in the tray and select Open Sound settings, what does it say in the box/drop-down menu under Choose your output device?:

821288520_Soundsettings.thumb.png.6af6d6fbf20507d2da12a6d96ac3065b.png

Next, click on the Sound Control Panel link on the right in the sound settings window shown above and it should look something like this:

Sound.png.de45362946cbc3219622b27f7fea8ee3.png

Be sure that your device is listed, that it's set as the default as indicated by the green checkmark and the words Default Device listed beneath it.  Also, right-click in the Sound box shown above and be sure that both Show Disabled Devices and Show Disconnected Devices are checked (they should both have a checkmark next to them on the left when you right-click), and if they aren't, then right-click then click on each one to enable them/show them and make sure that the device you want to use is both enabled and set as the default device.

If all of that is good (I know you've been through all of this a bunch of times already, sorry), then click on your device in the above dialog to highlight it and click the Configure button on the lower left.  Once the Speaker Setup window opens, go through the wizard making sure that it matches your actual speaker configuration/setup.  You can also test the audio here by clicking the Test button to see what happens.  It should at least show an animation of sound waves coming out of the speakers shown in the image:

601216408_Speakersetup.png.284d21c6511569a04421c4efff81ca1d.png

Next, click the Next button and make sure that your front right and left speakers are checked under Full-range speakers, then click Finish to close out the wizard.

Now, back to the Sound dialog again, with your audio device still highlighted, click the Properties button on the lower right and you should see something like this:

Properties.png.93d24e4deaaccdde63244a22f0eb6385.png

Check the Levels tab and make sure that it isn't muted and that the volume is turned up in the slider(s) for your device.  You can also visit the Enhancements tab and try enabling any available enhancements to see if that helps, and also try checking the box next to Disable all sound effects to see if that helps.  You should also visit the Advanced tab and try changing the options there to see if that helps, especially the Exclusive Mode options which should be enabled by default, though you can try disabling them to see if that makes any difference.

Next, try playing a song or video with the Sound Mixer open so that you can see whether or not it shows the green bars going up and down indicating the presence of active audio output:

Bars.png.82aed1c0a1fef689f4a980ddbfce6d0d.png

Again, I know you've probably been through all of these options/dialogs multiple times; I'm just hoping that maybe some option got changed back to a default setting in the process of updating and maybe you can get it working again by changing back the right setting.  Windows won't output sound through two devices at once by default, so if the wrong device is set as default you won't have any sound, and there are a lot of places where the volume/output can be controlled from, any of which could cause the audio to be muted completely.  It's wishful thinking on my part, but I'm hoping this isn't some driver/.NET problem with no solution (i.e. a Microsoft/Creative bug which it would be up to their developers to fix; something very unlikely to happen since the device is out of support/end of life).

If none of that helps, I would suggest trying to uninstall the .NET update, restarting the system and seeing if your sound comes back or doing a System Restore to the point before the update was installed (by default Windows creates a restore point any time Windows Updates are being installed).

  • Like 1
Link to post
Share on other sites
31 minutes ago, exile360 said:

HWInfo shows it as the Recon3D which is End of Life/End of Support according to Creative's website,

No, it's an Audigy FX (driver here) - I've reinstalled the latest release anyway (what was installed) but still the same. The only reason I installed a soundcard in the first place was because I was having the same issue using windows inbuilt sound.

34 minutes ago, exile360 said:

it might actually be worth a shot to uninstall Creative's drivers/software from Programs and Features, reboot the system, then let Windows install the latest driver it has for the hardware from Windows Update, assuming they have a driver for it.

Yeah, I did all that earlier. Several times, trying various things.

41 minutes ago, exile360 said:

If you click Mixer at the bottom, what do you see and what does the title bar at the top of it say for the name of your audio device?:

Sorry, I don't know how to edit a screenshot on this (Windows 10 is fairly new to me - God, I miss Windows 7!) - it says Creative Soundblaster Audigy FX is the speakers.

44 minutes ago, exile360 said:

Next, if you right-click the Windows sound icon in the tray and select Open Sound settings, what does it say in the box/drop-down menu under Choose your output device?:

Creative Audigy FX

Quote

Be sure that your device is listed, that it's set as the default as indicated by the green checkmark and the words Default Device listed beneath it.  ...  You can also test the audio here by clicking the Test button to see what happens.  It should at least show an animation of sound waves coming out of the speakers shown in the image:

Yeah, I've done all this multiple times today (including just then) - still not working.

Quote

Now, back to the Sound dialog again, with your audio device still highlighted, click the Properties button on the lower right and you should see something like this:

I only have four tabs when I click Properties with Sound Blaster Audigy (default) - General, Levels, Advanced & Spatial Sound (other tabs are there if I click on another one) so I'm limited on some of your suggestions.

Quote

Next, try playing a song or video with the Sound Mixer open so that you can see whether or not it shows the green bars going up and down indicating the presence of active audio output

Yes, there's active audio, as in the green bars are showing as if it's playing but they are diminished insofar as they peak at 40% ish. Sound is barely audible at full blast. Normally I can't stay in the same room at full blast.

I don't think I can get away with uninstalling .NET as it is required and will just reinstall itself anyway. 😕

Pretty sure M$ removed the easy way I had found to get sound working during one of their so called 'updates'. 

Again, thank you for your very detailed suggestions and the time it took you to prepare all that. I very much appreciate it.

 

Link to post
Share on other sites

OK, what about the Communications tab for the Sound dialog; what is yours set to?:

Communications.png.db7494671665be55cccad125be4f3dd6.png

My theory is that maybe the device's input/mic/whatever may be active due to some program that uses a mic and Windows may be automatically reducing the volume because of it.  If so, setting it to Do nothing, clicking Apply, then restarting the system should bring the sound back.

Also, be sure to check the Levels tab to make sure the sliders are all set to max and that it's not muted or anything:

Levels.png.47e0203dba170138e662cdd53173f26e.png

There's also one other thing which I've encountered myself which I believe may be unique to Creative devices/drivers.  I've found that whenever I have their device installed, if I don't specifically enable Creative's enhancements for sound, the volume at max is way lower than it otherwise would be.  I've seen this on multiple systems on Windows 7, Vista and 10 (and I think I even experienced it on XP, though it's been so long I can't recall precisely).  If there is any sort of Creative software installed on the system I'd be curious to see what it looks like and what options it has.  For example, on my current system (which has the typical Realtek HD Audio onboard), if I don't specifically enable the Volume Leveler feature in Acer's Dolby Audio applet/control panel, my volume will be way lower than normal.

I have one more idea for you to try.  Connect your speakers to the onboard audio (the built in Realtek audio) and install the latest Realtek drivers/software if you haven't already, then access Realtek's software (not the native Windows controls) and see if one of the options there enables proper sound output.  In fact, you might try that anyway even if you continue using the Creative card as it may be that Realtek's software is interfacing with Windows' native audio APIs/functions, causing it to affect the audio output of all devices, including your Creative card.  You should be able to find it under C:\Program Files\Realtek and it should be called RAVCpl64.exe; double-click it to open it and see if playing with any of its options fix the audio.

Link to post
Share on other sites

There's also the Ear Protection option which, if enabled, automatically lowers/limits the max volume for the device:

305387526_EarProtection.png.b57c39f70a98a6c1851c44dcfc0e5602.png

Again, that's in Realtek's control panel, but if it is active it could be affecting the output of your Creative device as well, and if Creative's software has any similar feature, that could also be the reason.  Also, if you have any sort of EQ software that came with the device to control how it sounds (like for different types of music, movies, games etc.), that too may have an option affecting the level of output which would be similar to the issue I described in my last post about that 'Volume Leveler' feature.

Link to post
Share on other sites

Yes, unfortunately the update from Microsoft last night hit my system too. Not the same sound issues but other issues. Waiting to see how many others have issues from the latest round of updates.

October 13, 2020—KB4579311 (OS Build 19041.572)
https://support.microsoft.com/en-us/help/4579311/windows-10-update-kb4579311

October 13, 2020-KB4578968 Cumulative Update for .NET Framework 3.5 and 4.8 for Windows 10 , version 20H2
https://support.microsoft.com/en-us/help/4578968/kb4578968-cumulative-update-for-net-framework

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.