Jump to content

Recommended Posts

Hi, since turning on real time protection in Malwarebytes for Mac about a week ago, every couple of days I get crashes in RTProtectionDaemon. Info is below. As you can see I am on the latest of Malwarebytes and macOS Catalina.

I am seriously considering turning this off, but before I do, is there a fix for this now or imminent, or is it a known problem that's being researched? I can wait if this is something actively being addressed, but if it's off the radar I wold just as soon not have this affecting my system. Thanks!

Process:               RTProtectionDaemon [65046]
Path:                  /Library/Application Support/Malwarebytes/*/Engine.bundle/Contents/PlugIns/RTProtectionDaemon.app/Contents/MacOS/RTProtectionDaemon
Identifier:            RTProtectionDaemon
Version:               4.5 (4.5.14.3726)
Code Type:             X86-64 (Native)
Parent Process:        launchd [1]
Responsible:           RTProtectionDaemon [65046]
User ID:               0

Date/Time:             2020-10-02 08:14:25.714 -0400
OS Version:            Mac OS X 10.15.7 (19H2)
Report Version:        12
Bridge OS Version:     4.6 (17P6610)
Anonymous UUID:        AE4B0726-8112-455B-A328-661A3EF39EC5

Sleep/Wake UUID:       FB5E26CD-9EE6-49AB-9286-802D134FF35A

Time Awake Since Boot: 320000 seconds
Time Since Wake:       110 seconds

System Integrity Protection: enabled

Link to post
Share on other sites

Greetings,

I'm not aware of a known issue with the protection crashing, however the first thing I would suggest is uninstalling the software, restarting the system, then reinstalling the software (assuming you haven't tried that already) to see if that resolves the issue.

Link to post
Share on other sites

HI and thanks @exile360, I uninstalled via the Help menu, restarted, and reinstalled as you suggested as I had not tried that. I'll watch it and see if I get any more crashes in the next few days. Thanks!!

Link to post
Share on other sites
  • Staff

Hi @Don0819,

 

Yes, I believe beta build have couple of improvements for Catalina and beta Big Sur.

Please try the beta build and let us know if there was any change with crash.

 

  • Like 1
  • Thanks 1
Link to post
Share on other sites

Good luck, I hope it goes well, but please let us know if you do run into any further issues.

Thanks

And thanks for the assist @adas; I'm obviously far more familiar with the Windows version so I could only recommend basic troubleshooting steps so I too am glad you stepped in with another potential solution.

  • Like 2
Link to post
Share on other sites
  • Staff
On 10/3/2020 at 12:25 PM, Don0819 said:

Thanks @adas, is it possible the beta improves something in the area that crashed for me?

The most recent beta does actually add a bug fix for RTProtectionDaemon crashes. I suspect this will solve your problem, though of course it's also possible it won't.

  • Like 2
Link to post
Share on other sites
3 minutes ago, PaulPaulsen said:

No. That was a previous version.

I thought you were a Windows user?

Link to post
Share on other sites

FYI @adasand @treed, I got the RTProtectionDaemon crash (info below), so it's still not totally fixed in the beta I downloaded. From the time, it seems that was likely when I opened the lid of the laptop in the morning, so it was I assume, hibernating. Yet the Energy settings are set to "Prevent computer form sleeping when the display is off", and "Enable Power Nap". Hard disks are not put to sleep. It did it's nightly scan the night before, so nothing obvious that it was doing on the surface.

Any next steps, or info you want?

 

Process:               RTProtectionDaemon [1616]
Path:                  /Library/Application Support/Malwarebytes/*/Engine.bundle/Contents/PlugIns/RTProtectionDaemon.app/Contents/MacOS/RTProtectionDaemon
Identifier:            RTProtectionDaemon
Version:               4.6 (4.6.10.3823)
Code Type:             X86-64 (Native)
Parent Process:        launchd [1]
Responsible:           RTProtectionDaemon [1616]
User ID:               0

Date/Time:             2020-10-12 06:27:46.393 -0400
OS Version:            Mac OS X 10.15.7 (19H2)
Report Version:        12
Bridge OS Version:     4.6 (17P6610)
Anonymous UUID:        AE4B0726-8112-455B-A328-661A3EF39EC5

Sleep/Wake UUID:       334E66C9-94D5-4558-90D1-94AA544B8BE4

Time Awake Since Boot: 360000 seconds
Time Since Wake:       790 seconds

System Integrity Protection: enabled

Crashed Thread:        2  Dispatch queue: Rtp.SysExt.Logic

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x00007fd83108e898
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Segmentation fault: 11
Termination Reason:    Namespace SIGNAL, Code 0xb
Terminating Process:   exc handler [1616]
 

Link to post
Share on other sites

I checked this morning, there were TWO more crashes last night - I took an image capture this time so you could see it. Are there any ideas? I can't have a program that regularly crashes running on my system, so I am going to turn off all the real time tuff for now until/unless there is an idea or an update to try. I turned on beta programs so I should get the next version when it comes out.

Link to post
Share on other sites
  • Staff

Hi @Don0819,

Thank you  for the feedback.

We would like to gather additional information as troubleshooting logs and for that, provide us a system report created with the help of below article  (please don't post the zip file here).
 
Instead,  log a support ticket with help of below link and attach the zip file with the email. After  submitting a support ticket, please provide here the support ticket number.
Link to post
Share on other sites

Thanks @adas, I ran the program to generate the zip file. I was thinking, I already cleared out the crash logs in the Console app, does the utility look for this info, ie will there be no evidence of a crash? If so I'll turn on the real time stuff again and let it crash, and then send the zip file. I guess I am asking did I mess up the data gathering by clearing the console crash log info. Thanks!

Link to post
Share on other sites

Never mind @adas, I turned on the real time services and I got a crash within 30 minutes! I ran the diagnostic program and just sent a support request through the link you gave, attaching the zip file. We'll see what happens!

Link to post
Share on other sites

@adasdo you want my support ticket number? FYI I did get a confirming email, it asked me to send the support tool file that's reduced, then they can look at it. I assume this is just a generic reply email that you expedited for me and I can ignore that?

Link to post
Share on other sites
  • 2 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.