Jump to content

Malwarebytes Anti-Exploit 1.13.1.257 - vastly improved startup behaviour


Recommended Posts

My Windows XP SP3 system runs on an 18 year-old PC.  I was unable to use a later version of MBAE than 1.12.1.109 for the reason that the mbae-svc.exe process belonging to version 1.13 was very inclined to time-out and it was then impossible to get MBAE running without a restart.  Imagine my joy when having persuaded myself against my better judgement to install MBAE 1.13.1.257, the system startup and the initial logon went as smoothly as a well-oiled precision mechanism.  I can now enjoy MBAE's latest protection once again on my ancient XP.

I have held back from writing this for several days since the usual penalty for making such an announcement is for MBAE to punish me for my haste in commenting.  Five days after installing the latest MBAE, the excellent startup behaviour remains.

I would go as far as to say that the system also runs more smoothly and responsively than before.  That is a subjective comment.  The improvement in startup is a fact.

I think it only right and proper to comment on this and to thank the devs for the wonderful improvement which I assume was done intentionally.

Edited by hake
Link to post
Share on other sites

I recall one of the staff commenting on one of your previous threads that he would look into the issue with XP startup, so I'm guessing they must have done so and rectified it.  I'm glad to hear that it's working well now, and I'll be sure to make a note of it for my report to the team :).

  • Thanks 1
Link to post
Share on other sites

The benefits of the improvement also seem to extend to Windows 7, 8.1 and 10.  This adds further gloss to an already brilliant product.

Link to post
Share on other sites

The conscientious devs have probably achieved a very worthwhile improvement to quality and reliability and I will be very pleased if it can also enhance other MB products.

Link to post
Share on other sites

Yes, they always integrate the improvements to MBAE into MB once they prove stable in the standalone MBAE beta so it's just a matter of time as long as no major issues are discovered with it.

Link to post
Share on other sites

Apart from the startup problem with Windows XP, I cannot recall personally encountering any bugs in MBAE and I have been using it since 2013.  MB Anti-Ransomware seems to have caused a problem with MBAE a bit more than a year ago but the errors in MBARW were fixed.

Link to post
Share on other sites

Yes, I recall that issue with the two betas.  I seem to recall that it was due to some of the shared components they used which resulted in a problem but they got it resolved pretty quickly.  They seem to be making a lot of improvements to their Anti-Exploit tech these days which is always exciting to see as it is one of Malwarebytes' most proactive protection components by far.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.