Jump to content

Recommended Posts

Windows7 - Dell all in one - using Edge as browser -- all working fine until I put that update on. Now can't access web and is extremely slow. I did a sys restore. If all runs ok, should I put the update on again or am I safe not doing so? Thanks.

Link to post
Share on other sites

I do not know if were going to access it with the current forum issues but ,

Can you please collect and upload as an attachment the diagnostic data using our MBST?

  • Download and run the Malwarebytes Support Tool
  • Accept the EULA and click Advanced tab on the left (not Start Repair)
  • Click the Gather Logs button, and once it completes, attach the zip file it creates on your desktop to your next reply
Link to post
Share on other sites

Thanks. For your info, I updated on my win10 laptop just fine. My very old desktop win7 however did not like it. The sys restore has made it run fine again. When I can access the desktop, I will follow thru with diagnostic - but if forum has issues, it can certainly wait.

Link to post
Share on other sites
24 minutes ago, Dublin70 said:

cannot be run on standard account as "admin" - would not open. For those who try this method - don't. Works fine on admin.

Any tools we ask you to run need to be directly run from an Admin account.

Link to post
Share on other sites
Just now, Dublin70 said:

As I found out. Perhaps a quick note on your download area - Must be run on admin account. For we stupeedos...:-)

95% of home users do not use a standard account. I personally have never subscribed to that philosophy myself.

Link to post
Share on other sites

So what are my choices - I like the VPN as I no longer have windows security updates on win7 pc. This vpn is paid for not free btw. I have used mwb for a loooong time and really like it and the support you offer - hmmm.

Link to post
Share on other sites
3 minutes ago, Dublin70 said:

the philosophy that admin accounts are more likely to be attacked.?

That is UAC is for. It was introduced in Vista.

Yours is on.

Quote

UAC Settings
==================================
EnableLUA:                      On
Consent Prompt Behavior Admin:  On

 

Link to post
Share on other sites
29 minutes ago, Dublin70 said:

So if mine is on, then system is safe from malware?

No computer is 100% safe from anything.

A supported OS would also help.

 

30 minutes ago, Dublin70 said:

The system is running smoothly now and if I update mwb, I am afraid it will have issues again.

If you are going to continue to use the Avast VPN, I have a feeling that disabling web protection might solve the issue buy that is not ideal.

 

Link to post
Share on other sites

I realize there is no such thing as 100% of most anything. The system uses Edge browser which as of now, user has not installed mwb browser protection. I think Edge was on system when we did the mwb update. Supposedly Edge has many security features -

my main concern is if I don't update mwb to latest version, that will get me hacked.

Link to post
Share on other sites

There is a risk.  Nearly all major updates to Malwarebytes include at least some enhancement to Malwarebytes' detection and protection capabilities, often enhancements which were developed as a direct response to one or more current/prominent threats.  This means that over time, as the application becomes further out of date it will become less and less effective against many current threats due to older versions being unable to parse new types of signatures and to use newly developed heuristics and other technologies which are developed over time to improve its efficacy against threats and security vulnerabilities.

Link to post
Share on other sites

So my choices are - use vpn don't update mwb or don't use vpn - update mwb. hmmm. It hasn't presented a problem on my win10 laptop. I will have to think about it. Thanks very much for all of your help.

Link to post
Share on other sites

There is another option as mentioned previously; update Malwarebytes but keep Web Protection disabled, install Malwarebytes Browser Guard if you haven't done so already and await a future fix for this issue, assuming there is anything the Developers can do about it.  You still lose out on some of the protection provided by Web Protection since it shields the entire system, not just the web browser, however the browser is by far the most at-risk of all web facing applications as far as malware is concerned.

That is what I would do if I were you and I was determined to keep Avast VPN, and this is coming from a former Malwarebytes QA and Product Manager; one who worked directly with the Developers on many of the same protections, features and capabilities that exist in Malwarebytes today.

Edited by exile360
Link to post
Share on other sites

You're welcome, I just hope that the Developers are able to correct this incompatibility and that it happens soon so that you don't have to be concerned with any compromises (and afterwards you should keep Malwarebytes Browser Guard as it adds protection on top of the Web Protection in Malwarebytes Premium when used in tandem with it).

Link to post
Share on other sites

Last evening I logged onto admin account. I opened MWB and it said - version 4.2.082 and it had been updated that day. Everything seems to be running smoothly and we have the latest version -- the only thing I wonder about is the browser guard. It has not been offered on Edge as far as I can tell. Do you know about that? Thanks again.

Link to post
Share on other sites
11 minutes ago, Dublin70 said:

It has not been offered on Edge as far as I can tell. Do you know about that? Thanks again.

If you get the Chrome based Edge you can use the browser guard for Chrome. Just have to enable extensions from other stores.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.