Jump to content

Cannot Download Photos


Recommended Posts

Hi - since FF updated to v80, I cannot download photos with Malwarebytes Browser Guard installed. Works fine without it there so it's not another add-on etc. Every time I try, it shows up as 'cancelled' in the download area, and I have to 'retry' it to get it to download.

I deleted and reinstalled the Browser Guard, same thing. Weirdly, even if I disable all four options on the Browser Guard I still cannot download the photos, I have to uninstall it to get this basic functionality back for FireFox.

Any ideas? I'd love to keep it installed but I do need to download photos routinely.

Thanks! 🙂

Link to post

Thank you @general714 for this post. I'm having the same problem on my Mac computer with Firefox v80. Need to refresh every time. Also I can't download documents from the Credit Union. This is what I'm getting:

 

Canceled.png

Completed.png

Link to post

Just a 'me too' - with a couple of workrounds and a possible explanation.

I'm definitely now suspecting that this is a bug in Firefox v80.
It looks as if they may have set the default download protection too high?

@Popeye Where you see that circular arrow in the download manager click on it again to retry the download.
That has just worked for me with an image that hadn't downloaded/saved.

Second workround is to copy the image and then paste it into your image viewer/editor.

I haven't had a problem with PDFs.

I had first noticed this when trying to 'save-as' some images yesterday, doesn't matter what format they just wont 'save-as'.
I hadn't associated it with MBG though. (I thought it was because I was tethering 3G+ through a provider which has some strange default parental blocks set).

 I updated Firefox to v80 earlier yesterday.

Looking a bit deeper:
In Options>General>Aplications it used to have a list of all possible download filetypes and how to handle the download.
Mine is now only showing 5 types, none of them image formats.
image.png.44f7d73df898f21aff2d069b70f09f6f.png

 

 

Edited by nukecad
Link to post

After the canceled hitting the circular arrow works fine for photos "Save Image As" as a work around. Still can't download documents though even hitting the circular arrow.

Disable Malwarebytes, everything works perfect, no problems.

I have no problems with Chrome and Malwarebytes Browser Guard.

Link to post

I'm not having a problem with documents, just images.

Maybe a difference between Mac and Windows?

9 minutes ago, Popeye said:

I have no problems with Chrome and Malwarebytes Browser Guard.

Which to me also points to something being changed in the Firefox update.

I have to go out for a couple of hours, I'll do some more 'playing' later.

Edited by nukecad
Link to post
1 hour ago, nukecad said:

I'm definitely now suspecting that this is a bug in Firefox v80.

Definitely a bug with Malwarebytes Browser Guard as Firefox works fine without Malwarebytes messing it up. Would appreciate an update to fix it...

Link to post
54 minutes ago, nukecad said:

Maybe a difference between Mac and Windows?

Seems like I see many posts with browser guard and Mac having issues of some kind.

Link to post

If it helps Malwarebytes Bug Team I'm also getting this on my Mac after hitting the circular arrow and before download complete with Save Image As:

"Show in Finder"

 

Show in finder.png

Edited by Popeye
Link to post
1 hour ago, general714 said:

Definitely a bug with Malwarebytes Browser Guard as Firefox works fine without Malwarebytes messing it up. Would appreciate an update to fix it...

It's one of those things.

Mozilla change something and then everyone else has to adjust their apps to what mozilla have changed.

Not realy a bug by either party, just a bit of a catch-up lag.

Link to post
1 hour ago, nukecad said:

Mozilla change something and then everyone else has to adjust their apps to what mozilla have changed.

I'll just disable Malwarebytes Browser Guard on Firefox if I need to download or Save Image As. Then enable it after the download. We'll wait for a fix. :)

Link to post

I can confirm that disabling MBG allows the images to download as normal here.

Watching it in action with MBG enabled and downloading a large image it does seem to be downloading the image to 99.99% then says 'cancelled', but as soon as you click the retry arrow it immediately completes.

I guess there is some kind of clash between MBG and whatever it is that mozilla have changed, we'll just have to wait for the MBG team to adjust for the change.

Also odd that it's not affecting downloads of PDFs for me on Windows but is for you on Mac, that may be a pointer to what has been changed.

Edited by nukecad
Link to post
39 minutes ago, adas said:

I am having the same issue and turning off the "scam protection" for all sites have helped to resolve it for me.

Tried that, doesn't work for me - need to disable the MB Browser Guard completely.

Link to post
2 hours ago, general714 said:

Tried that, doesn't work for me - need to disable the MB Browser Guard completely.

Same here with the "Save Image As" on photos. , need to disable MB Browser Guard.

But Good News, turning off "Scams" I can now download documents from my Credit Union and other websites.

EDIT: I was turning of "Scams" on individual websites and not "Apply To All Websites"

After turning off "Scam" to all websites I rebooted the Mac. That fixed the problem. Now I can "Save Image As" and download documents from websites. Thank you @adas

 

Screen Shot 2020-08-30 at 11.00.00 AM.png

Screen Shot 2020-08-30 at 11.00.43 AM.png

Edited by Popeye
Link to post
1 hour ago, Popeye said:

Same here with the "Save Image As" on photos. , need to disable MB Browser Guard.

But Good News, turning off "Scams" I can now download documents from my Credit Union and other websites.

EDIT: I was turning of "Scams" on individual websites and not "Apply To All Websites"

After turning off "Scam" to all websites I rebooted the Mac. That fixed the problem. Now I can "Save Image As" and download documents from websites. Thank you @adas

 

Screen Shot 2020-08-30 at 11.00.00 AM.png

Screen Shot 2020-08-30 at 11.00.43 AM.png

Sorry, I don't see that Malwarebytes menu in Firefox 80 in Windows 10 > Tools > Add-ons. Where does it hide? Thanks.

Link to post
1 minute ago, runbei said:

Sorry, I don't see that Malwarebytes menu in Firefox 80 in Windows 10 > Tools > Add-ons. Where does it hide? Thanks.

I can confirm, it's not there for me neither. "Settings" is not where to be found. Not even in Firefox MBG's Add-Ons page.

 

No Settings.PNG

Link to post

Make sure Browser Guard is enabled. Open Firefox browser. In the Tool Bar upper right, left click the Malwarebytes Icon. Click the gear wheel. Disable "Scams"

 

Screen Shot 2020-08-30 at 12.55.17 PM.png

Edited by Popeye
Link to post

Thanks! Yep - that worked.

I discovered a separate issue with MalwareBytes and Firefox 80. I'm watching a course on editing video in Premiere Pro, and MalwareBytes prevents turning off closed captions. Pretty sure turning off Scam protection fixed it, too.

Link to post

Well I updated Firefox to V80.0.1 and turned on the "Scams" so all 4 protection buttons are enabled on MB Browser Guard.

Results now:

I can download documents on all websites, which I couldn't do with the previous version of Firefox.

I still cannot "Save Image As" for pics.

I'll turn off "Scams" again where everything works and wait for another update.

Link to post
On 8/30/2020 at 6:02 PM, Popeye said:

Make sure Browser Guard is enabled. Open Firefox browser. In the Tool Bar upper right, left click the Malwarebytes Icon. Click the gear wheel. Disable "Scams"

Thanks for this workaround, Popeye, much appreciated. As you say, we'll just have to wait for updates to get it fixed but the workaround is great.

Link to post

The underlying problem was isolated and fixed, and is currently being tested.  A patch release is planned for Wednesday. 

Link to post
7 minutes ago, gonzo said:

The underlying problem was isolated and fixed, and is currently being tested.  A patch release is planned for Wednesday.

Sounds good. Thank you @gonzo

Link to post

The patch release has been pushed back to Thursday.  Testing is still in progress.  Sorry for the delay.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.