Jump to content

Multiple MB Apps in Full Disk Access


Recommended Posts

I noticed in my System Preferences > Security & Privacy > Privacy > Full Disk Access, I have not only Malwarebytes Protection, but two additional app plug-ins from Malwarebytes, which have appeared since very first installing the app on my new MacBook Air (2020). I understand the need and reason for the MB Protection in this section, but I'm wondering why these other app plug-ins appearing? I've tried reinstalling the app multiple times, with and without FileVault enabled, verified the MBAM plist files are appearing normally in /Library/LaunchAgents and /Library/LaunchDaemons, verified the app is up to date, and I don't have any other anti-malware related apps installed that may be tweaking the permissions.

I just want to be sure these extra plug-ins appearing won't affect the performance or functionality of Malwarebytes.

Screen Shot 2020-08-04 at 6.48.19 PM.png

Link to post
Share on other sites

All three need are legitimate components of the current 4.5 version and should have full disk access enabled for full functionality. I'm not seeing any performance hits in doing so.

Link to post
Share on other sites

Interesting, am I missing something? Why do I only have 0ne and not Three? I'm running V4.5.14

 

Screen Shot 2020-08-05 at 8.44.02 PM.png

Edited by Popeye
Link to post
Share on other sites

12 minutes ago, Popeye said:

Interesting, am I missing something? Why do I only have 0ne and not Three? I'm running V4.5.14

 

Screen Shot 2020-08-05 at 8.44.02 PM.png

Yep, I'm on the latest too and only have one on two Macs...not three.  I'm also not seeing it update hourly as it's set to do.  Last protection update check often is hours behind the actual time.  Don't recall this issue before either.

Link to post
Share on other sites

3 hours ago, alvarnell said:

Perhaps it depends on what version of macOS you are running, whether only one or all three show up?

 

3 hours ago, GuruGuy said:

Both of my Macs are Catalina 10.15.6

I too am on macOS 10.15.6 and MWB 4.5.14 (clean installation of MWB) and I only have Malwarebytes Protection (also indicated in Italian). I think it depends more on the Mac than on the version of macOS (in fact mine is from 2012). In fact, my sister who has a MacBook Air 2020 and macOS 10.15.6 has all three voices for MWB 4.5.14

Link to post
Share on other sites

8 hours ago, GuruGuy said:

Yep, I'm on the latest too and only have one on two Macs...not three.  I'm also not seeing it update hourly as it's set to do.  Last protection update check often is hours behind the actual time.  Don't recall this issue before either.

Yeah it would be nice to hear from the developer on this thread and the one I started a week ago with the issue with the new version.  Also, just checked my Auto Update Last Protection Update Check and it's showing over six hours ago...so another issue.

Link to post
Share on other sites

Greetings,

I have taken note of this thread and will be reporting it to the Product team in my weekly report, so the Developers and QA teams will be made aware of it.  Thank you for bringing this to our attention.

It is also possible that they are already aware of it, however we won't know until a staff member is available to respond.

I will also report the issue with updates, however you might be better off creating a new thread about it as that may be an issue which a member of Support/the staff can help you in fixing.

Link to post
Share on other sites

3 minutes ago, exile360 said:

Greetings,

I have taken note of this thread and will be reporting it to the Product team in my weekly report, so the Developers and QA teams will be made aware of it.  Thank you for bringing this to our attention.

It is also possible that they are already aware of it, however we won't know until a staff member is available to respond.

I will also report the issue with updates, however you might be better off creating a new thread about it as that may be an issue which a member of Support/the staff can help you in fixing.

Ant the other thread about the new version weirdness too.  And then of course someone (Treed or staff) will come back here to update the forum, correct.  Treed reads this forum so not sure why it would need to be reported, but anyway...

Link to post
Share on other sites

I always report issues for the various products to the Product team as I am contracted to do so.  It's simply another data point for them to help inform their decisions and awareness of issues.  Keep in mind that my report goes out to a large number of the Malwarebytes staff, so while it often includes issues some or all of them may already be aware of, it also often contains at least some information at least some of them might not have been aware of.  They of course get reporting from their Support staff and QA as well.

Link to post
Share on other sites

1 minute ago, exile360 said:

I always report issues for the various products to the Product team as I am contracted to do so.  It's simply another data point for them to help inform their decisions and awareness of issues.  Keep in mind that my report goes out to a large number of the Malwarebytes staff, so while it often includes issues some or all of them may already be aware of, it also often contains at least some information at least some of them might not have been aware of.  They of course get reporting from their Support staff and QA as well.

So we'll wait and see if someone posts a follow-up.  Thanks

Link to post
Share on other sites

  • Staff
On 8/5/2020 at 7:22 PM, Rando3000 said:

I noticed in my System Preferences > Security & Privacy > Privacy > Full Disk Access, I have not only Malwarebytes Protection, but two additional app plug-ins from Malwarebytes, which have appeared since very first installing the app on my new MacBook Air (2020). I understand the need and reason for the MB Protection in this section, but I'm wondering why these other app plug-ins appearing?

I can't reproduce this here. As everyone else here has said, you should only see the Malwarebytes Protection one. Is it possible that you manually added those other two at some point in the past, then unchecked them later? Neither the agent (Malwarebytes Agent, which is responsible for things like the menu bar icon and checking for updates) nor the frontend app (Malwarebytes, which is the app you interact with) should do anything that would trigger them being added to that list.

Link to post
Share on other sites

As I wrote above in post # 8 my sister who has a MacBook Air 2020 and macOS 10.15.6 has all three voices for MWB 4.5.14.

The situation happened right away, without any interaction on my part, that I installed Malwarebytes, since macOS 10.15.5 and MWB 4.4.x when he bought his Mac in June 2020.

I attach screenshots of my sister's situation

1945454699_Immagine07-08-20alle17_33.jpg.f43f0b8fddfe271fcef293380e7133fd.jpg

Everything was added automatically. I didn't have to change anything

Link to post
Share on other sites

@MAXBAR1 - Ahh gotcha. I also have a MacBook Air (2020) and mine shipped with 10.15.5, and the plug-ins continued to appear in 10.15.6. And same situation for me - I did not manually add the plug-ins and/or do anything different to alter the installation.

@treed - Thank you for the response! I am 100% sure I did not manually add the plug-ins. I should mention that I do work in technical support with computers, and I am very aware of the areas of the computer I should and shouldn't be accessing routinely; in other words, I am not the kind of person who opens the /Library, finds items I don't recognize or think I know what they do, and start throwing things to the trash (especially with software I haven't developed). I love the app and how it operates, so I would definitely not want to change any part of it's functionality. 

Additionally, this may or may not help with uncovering the reason behind these appearing but when performing a secondary click on any of the list items > select Show in Finder > I receive the following file path: Mac HD/Library/Application Support/Malwarebytes/MBAM/Engine.Bundle/Contents/Plugins/

Link to post
Share on other sites

The location indicated by the Finder is correct and I'm certain that @treed is aware. But having them there should not have anything to do with whatever is causing them to show up as requiring full disk access. There must be some other reason for them to be appearing there for a few and not others.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.