Jump to content

(redirected) Error with update and installation


Recommended Posts

Hello,

I described issues I was experiencing installing/updating malwarebytes through an internet connection (link: https://forums.malwarebytes.com/topic/262195-error-with-update-and-installation/?tab=comments#comment-1397313FRST.txtAddition.txt) and was asked to go here. I don't have logs from the malwarebytes support tool as it was unable to gather logs, but I ran a Farbar scan and have the logs (which are attached). 

The essential issue is that, when I tried to update to the newest version of Malwarebytes, I encountered an error where it said it was unable to connect to the internet. Fiddling with firewalls and windows defender and exclusions did not seem to help. I then tried uninstalling and reinstalling malwarebytes and found that the installation software also gave an error related to being unable to connect to the internet. With some help from the forums, I was able to reinstall the program using a manual installation file, but the update error is still present.


Kind regards, and thank you for your help,

John Shinholser

Link to post
Share on other sites

  • Root Admin

Hello @zamnath

I don't see an immediate reason for having such an issue but we'll go ahead and run a generic clean up and see if that helps or not.

 

Please download the attached fixlist.txt file and save it to the Desktop or location where you ran FRST from.
NOTE. It's important that both files, FRST or FRST64, and fixlist.txt are in the same location or the fix will not work.

Please make sure you disable any real time antivirus or security software before running this script. Once completed make sure you re-enable it.

NOTICE: This script was written specifically for this user, for use on this particular machine. Running this on another machine may cause damage to your operating system that cannot be undone.

Run FRST or FRST64 and press the Fix button just once and wait.
If the tool needs a restart please make sure you let the system restart normally and let the tool complete its run after restart.
The tool will make a log on the Desktop (Fixlog.txt) or wherever you ran FRST from. Please attach or post it to your next reply.

Note: If the tool warned you about an outdated version please download and run the updated version.

NOTE-1:  This fix will run a scan to check that all Microsoft operating system files are valid and not corrupt and attempt to correct any invalid files. It will also run a disk check on the restart to ensure disk integrity. Depending on the speed of your computer this fix may take 30 minutes or more.

NOTE-2: As part of this fix all temporary files will be removed. If you have any open web pages that have not been bookmarked please make sure you bookmark them now as all open applications will be automatically closed. Also, make sure you know the passwords for all websites as cookies will also be removed. The use of an external password manager is highly recommended instead of using your browser to store passwords.

The following directories are emptied:

  • Windows Temp
  • Users Temp folders
  • Edge, IE, FF, Chrome and Opera caches, HTML5 storages, Cookies and History
  • Recently opened files cache
  • Flash Player cache
  • Java cache
  • Steam HTML cache
  • Explorer thumbnail and icon cache
  • BITS transfer queue (qmgr*.dat files)
  • Recycle Bin

Important: items are permanently deleted. They are not moved to quarantine. If you have any questions or concerns please ask before running this fix.

The system will be rebooted after the fix has run.

fixlist.txt

Thanks

 

Link to post
Share on other sites

  • Root Admin

Please note the following date and time for this error. It may be temporary and caused by us cleaning the computer.

Application errors:
==================
Error: (07/31/2020 01:49:46 AM) (Source: VSS) (EventID: 8193) (User: )
Description: Volume Shadow Copy Service error: Unexpected error calling routine QueryFullProcessImageNameW.  hr = 0x80070006, The handle is invalid.
.

 

Please restart the computer. Then open your Event Logs and see if this error is reported again or not with a newer time stamp. Check in the Application section

 

https://www.isunshare.com/windows-10/6-ways-to-open-event-viewer-in-windows-10.html

 

Link to post
Share on other sites

I encountered the following error: 

Volume Shadow Copy Service information: The COM Server with CLSID {4e14fba2-2e22-11d1-9964-00c04fbbb345} and name CEventSystem cannot be started. [0x8007045b, A system shutdown is in progress.

This occured at 10:38 EST (so around the time I restarted my computer). Beyond that, no errors after the one you linked. Some warning and information stuff, but no warnings.

Link to post
Share on other sites

  • Root Admin

Okay, that's fine. Thanks

 

Let me have you run a different scanner to double-check. I don't expect it to find anything, but no harm in checking.

I would suggest a free scan with the ESET Online Scanner

Go to https://download.eset.com/com/eset/tools/online_scanner/latest/esetonlinescanner.exe

  • It will start a download of "esetonlinescanner.exe"
  • Save the file to your system, such as the Downloads folder, or else to the Desktop.
  • Go to the saved file, and double click it to get it started. 
  • When presented with the initial ESET options, click on "Computer Scan".
  • Next, when prompted by Windows, allow it to start by clicking Yes 
  • When prompted for scan type, Click on Full scan 
  • Look at & tick  ( select )   the radio selection "Enable ESET to detect and quarantine potentially unwanted applications"   and click on Start scan button.
  • Have patience.  The entire process may take an hour or more. There is an initial update download.
  • There is a progress window display.
  • You should ignore all prompts to get the ESET antivirus software program.   ( e.g.  their standard program).   You do not need to buy or get or install anything else.
  • When the scan is completed, if something was found, it will show a screen with the number of detected items.  If so, click the button marked “View detected results”.
  • Click The blue “Save scan log” to save the log.
  • If something was removed and you know it is a false finding, you may click on the blue ”Restore cleaned files”  ( in blue, at bottom).
  • Press Continue when all done.  You should click to off the offer for “periodic scanning”.

 

 

Link to post
Share on other sites

Seems like esetonline didn't detect anything. I could share the scanlog if you'd like? 

That said, I noticed a weird warning surrounding my ethernet connection and was wondering if it might be connected to my issues in some manner. I've attached a picture of the error for reference:

MoreInternetIssues.png.d1c3170fdde43916e729d9eaa233cb9e.png

Link to post
Share on other sites

  • Root Admin

No, don't need the log if it said nothing found.

 

Yes, if DNS cannot be queried then it will not be able to locate at least some sites.

You might want to consider using Google Public DNS or similar 3rd party DNS server.

https://developers.google.com/speed/public-dns

8.8.8.8
8.8.4.4

 

 

Link to post
Share on other sites

  • Root Admin

That is the Title of your topic here and part of what you said in your first post.

On 7/28/2020 at 12:23 PM, zamnath said:

The essential issue is that, when I tried to update to the newest version of Malwarebytes, I encountered an error where it said it was unable to connect to the internet.

 

My question is. Are you still having this issue now or were  you able to install and update Malwarebytes now without an issue?

Thanks

 

Link to post
Share on other sites

  • Root Admin

If you're having DNS issues then I'd suggest at least temporarily trying the Google PUblic DNS to see if it makes any difference for you.

https://developers.google.com/speed/public-dns/docs/using

Then open Malwarebytes and go to Settings, General or About and check for updates and let me know if there are any issues.

 

Link to post
Share on other sites

  • Root Admin

Okay, let's try the following please.

Please use the MBST tool to uninstall Malwarebytes, but after removal and reboot please DO NOT accept the offer to reinstall it. Decline the installation by the tool.

Uninstall and reinstall Malwarebytes using the Malwarebytes Support Tool

 

Then after the reboot go ahead and download the full offline installation and use that to install Malwarebytes.

MB4 Offline Installer
https://downloads.malwarebytes.com/file/mb4_offline

After the installation please check for updates and activate. Then restart the computer and wait about 10 minutes and then check for updates again and let me know if it still gets an error or not.

Thanks

 

 

Link to post
Share on other sites

  • 4 weeks later...
  • Root Admin

Due to the lack of feedback, this topic is closed to prevent others from posting here.

If you need this topic reopened, please send a Private Message to any one of the moderating team members. Please include a link to this topic with your request.

This applies only to the originator of this topic. Other members who need assistance please start your own topic in a new thread.

Tips to help protect from infection

Thanks

 

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.