Jump to content

PC became very slow

Recommended Posts

Hello, my PC has become very slow recently, to startup, to use, to browse the internet. It used to be fine until the last month or so. This forum helped before so thought I'd try. Uninstalled torrent software and Malwarebytes caught some threats and quarantined them, which makes me think there's an infection.

Dell XPS laptop i7 processor 



Link to post
Share on other sites

  • Root Admin

Hello @konriar

Please see the following topic for a known issue for some users with your version of Windows 10


Please turn off the Ransomware Protection module. Then let us know if that corrects the performance issue for you or not

Thank you


Link to post
Share on other sites


There is a new beta available that corrects the issues with your version of Windows.

You can opt in to receive beta updates by launching Malwarebytes 4, going to Settings > General > Beta updates and then toggle the switch so the setting is enabled.

After you've opted in to the beta updates, manually check for updates from that same screen: Settings > General > Application Updates and then click the Check for Updates button. 

I suggest restarting your computer after the beta is installed.

Edited by AdvancedSetup
corrected typo
Link to post
Share on other sites

< pardon my intrusion>

Hi @konriar  

adding a few other tidbits, since you made mention of "machine startup".

Change the Start time for the scheduled Scan  from 2 AM  to some later time during the day.   ( something like perhaps the lunch-time )

Look at the section 'To edit an existing scan" in this knowledge base article 



2 - 

Settings >> General tab >>  scroll to Manual scan performance impact

Click the radio-choice  for  "Manual scans take less priority   ( less performance impact )


Malwarebytes for Windows Version   with the Component  1.0.990  is the latest Release version   ( since this last Wednesday afternoon   I I R C ).

If you opted into the Beta,  and do not want to get more future betas, you can go back  and un-tick the choice for Beta.  ( under Settings > General ).



Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.