Jump to content

Problem with the installer commencing with version 0.9.19.56 - 1.1.330


Recommended Posts

If an installation is attempted when MBARW is already auto-updating, a message box will pop up informing the user that a sytem restart is necessary.  The trouble is that the user is not allowed to prevent that restart, only delay it for a short time. If another possibly critical operation is proceeding at the same time, then that is the user's bad luck.

The moral of this tale appears to be not to manually update MBARW including and after version 0.9.19.56 - 1.1.330.

Link to post
Share on other sites

I guess that the apparent lack of an option to wait until the next system start will be in the code.  I was simply unable to cancel the restart.  MBAE can also require a restart in a similar way but it has not caused a similar difficulty to MBARW, as far as I am aware.  I am now on my guard.

The incident happened while I was running Windows 10 2004 installer to update from version 1909 (OUCH!) so I was extremely stupid to try to update MBARW at that time.  The devil makes work for idle mouse clicking fingers.

Edited by hake
Link to post
Share on other sites

Yikes, yeah, it's definitely best not to have any installers going during a major OS update like that, but I'm bad about restless fingers as well (one reason I NEED a multi-core CPU and lots of RAM :P).

Did the OS update end up installing OK and is MBARW up and running properly now?

Link to post
Share on other sites
  • Staff

Just wanted to add that, as this latest release is a Component Update package, there was really no need to run the installer again. The machine will pick up the CU automatically. Typically within 15 minutes of the time the service starts.

Link to post
Share on other sites
21 minutes ago, tetonbob said:

Just wanted to add that, as this latest release is a Component Update package, there was really no need to run the installer again. The machine will pick up the CU automatically. Typically within 15 minutes of the time the service starts.

Are CUs not metered out gradually/randomly as full builds/packages are?

Link to post
Share on other sites
On 6/12/2020 at 1:36 PM, exile360 said:

Yikes, yeah, it's definitely best not to have any installers going during a major OS update like that, but I'm bad about restless fingers as well (one reason I NEED a multi-core CPU and lots of RAM :P).

Did the OS update end up installing OK and is MBARW up and running properly now?

I looked on in helpless horror :blink: as the system restarted.  There was no way to stop it in the short time available to act.  Fortunately I always backup the system BEFORE installing a feature update.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.