Jump to content

Doubleclick virus from "Checking your browser.." process


Recommended Posts

Hello all,

(I posted this also in the help section, but I want to raise this to Malwarebytes as well, so I'm double posting. Sorry for the confusion and if you don't like this, please remove one. Mainly I want to address this to the developers of Malwarebytes, because I'm not sure what the community can do against this). 

I have a repeating problem with a virus/malware that makes a single click on my mouse turn into a double click totally randomly. This is extremely annoying, for example when you tick a box, it automatically unticks it. Or when you try to drag a group of icons or files it stutters and you're selecting only partially or even nothing at all. Sometimes it happens rarely, sometimes all the time. And it has nothing to do with my wireless mouse, battery, or any other hardware issue. 

I'm quite certain that specific sites are somehow either causing this virus or making it worse. There are websites that gives a message like "Checking your browser before continuing..." A few examples are:

https://www.scidev.net/asia-pacific/disease/news/oral-polio-drops-linked-to-paralysis-in-india.html

https://torrentz2.eu

And I've seen it on many porn sites, sites related to downloading ebooks, but also regular sites that don't look suspicious at first hand. I'm quite convinced the "Checking your browser..." process installs a line of code somewhere on my pc and then activates itself after restarting the computer. 

I can remember from years ago that Malwarebytes DID catch this process as malware and removed them. But lately it doesn't and I keep hitting these sites even if I try to avoid porn sites! This situation is intolerable, and I would like to ask the community and Malwarebytes itself to investigate. 

To add to this: I was able to kill this virus for several years by just formatting my C: drive regularly and starting over with a fresh install. I had this problem both on Windows 7 and Windows 10, and since I switched to SSD and Windows 10 I had this trick of formatting the 3 partitions (one for recovery, and the others for boot info) and wiping it with zero's. This worked for a long time, but now it doesn't anymore. 

And furthermore, I have tried lots of anti-malwareprograms, including running them in Safe boots: Malwarebytes (Premium), Roguekiller, ZHPCleaner, Rkill, FRST64 and TDSSKiller. None of them showed a positive malware hit. 

I'm also wondering if viruses/malware can 'hide' themselves in the partitions that are created on the C: drive to for boot sections and recovery. Does Malwarebytes catch this? Or is this not a valid idea? 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.