Jump to content
exile360

Wordpad & MS Word security warning on images

Recommended Posts

I found an oddity with Windows 10 and no solution found on the web (so far).  Apparently this is the same warning displayed when a file is being opened from a network share, however this occurs with any file, including one which is local and both owned as well as created by the current user/account as long as the document includes an image of a certain type (or possibly types as it likely occurs for some other image types as well, though not all as some images in a document with many were not blocked):

Blocked.png.ff8832fb2ce68f406e5632dca9731cc7.png

Here's the RTF file including an embedded 'evil' image that Word/Wordpad both think needs to be blocked (even though I am both the author/creator and owner of the file, so it's not like it came from another machine):

Blocked.rar

I've found no solution so far and the web didn't offer anything useful either (only a reply about network shares on MS' official forums, which doesn't apply here, and some discussions elsewhere with no final resolution for this specific scenario).  I'm sure there's some kind of good reason for this, like perhaps the possibility of certain image types containing embedded exploit code of some kind, however there should be a way to override it and at least authorize a specific document/image as 'safe' so that I don't have to dismiss this modal dialog each and every time I open such a document.

I miss Windows 7 :( 

Incidentally, I've also noticed that the Details Pane is now on the right side rather than the bottom (where it's been since its inception in Vista) and it cannot be moved unless Explorer is replaced/patched by a tool such as OldNewExplorer (I'd rather not use such utilities if I can avoid it, though I did already install Classic Shell and Classic Start Menu because I couldn't actually find anything easily).

If anyone has a solution, please post (and no, removing the image or replacing it with a different type of image is not a solution, though it may work as a workaround).

Thanks

Share this post


Link to post
Share on other sites

@exile360 What version of word are you on. My old 2007 had no issue or warning. 

Are using any other Windows settings for security than default?

Share this post


Link to post
Share on other sites

It should be the latest; it's the free trial of Office365 that came with the machine and it should be fully patched as I've installed all available OS/software updates from MS.  It happens with Wordpad too, so whatever the issue is, it impacts more than just Word.

It may be some setting, but I haven't messed with much so I'm not sure what it would be.  I did see a ton of file association change messages after installing a major Win10 version update/upgrade, but I looked it up and it's a common issue (apparently the generic handler app for unassociated filetypes sometimes displays this issue).  The .RTF file is associated properly with Word though (as it should be if Word is installed; otherwise it would be Wordpad).

Share this post


Link to post
Share on other sites

By the way, an older version of Word likely wouldn't display this issue.  I suspect it is specific to Windows 10 and MS' newer versions of their applications (it likely wouldn't happen with OpenOffice either).

Share this post


Link to post
Share on other sites
23 minutes ago, exile360 said:

It happens with Wordpad too

Confirmed.

 

2020-05-05_00h15_47.png

Share this post


Link to post
Share on other sites

It did open in the online version of word of course I had to move it one drive.

 

2020-05-05_00h24_28.png

Share this post


Link to post
Share on other sites

Yep, I bet it's some exploit shielding thing similar to how MB/MBAE block VB scripting and whatnot in Word and other apps.  It is rather annoying though, especially since I know the image is safe since I'm the one who put it there.

I wish this were more like the normal file/document blocking implemented in older Windows versions for files that come from another machine where it writes hidden metadata to the file via ADS (Alternate Data Streams) because then I could just use the properties dialog to remove it, or better still, I could use my right-click>send to function for a handy CLI tool from Sysinternals that removes it automatically from any file(s) and/or folder.

Share this post


Link to post
Share on other sites

I only got the block notification in WordPad but not in Word 2016 Pro Plus

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.