Jump to content

Visual feedback showing that database update is working would be nice.


Recommended Posts

I got a notification saying that I need to update my virus definitions, so I opened the app, and lo and behold, there was a big blue button on the dashboard under the "critical issues" section, prompting me to update the malware database. I clicked on it, and it did that little thing that touch screen buttons do when clicked on... and nothing else. I waited for a while, clicked the button again, restarted the app, restarted my phone, tried again, and still got nothing more than a ripple.

While I was looking for solutions to the issue on the forums, I saw that the update had completed.

Could you work on having the Android app show some kind of indication that the database update is being worked on, within a time frame that doesn't make it seem like it's not responding?

Thank you for your consideration,


(Moto G5 Plus, Android 8.1.0, App version Database updated Feb. 15, 2020.)

Link to post
Share on other sites


Unfortunately I suspect that it was simply taking a while to download the database updates and that was the reason for the delay.  That said, I agree that some kind of progress or status indicator showing that it is in the process of successfully checking for and downloading an update and notifying you once complete would be a good idea (it sounds like it already does the second part so adding in the first part should resolve it if I understand your description of the issue accurately; please let us know if I do not).

Anyway, thank you for your feedback/suggestion; I will be sure to inform the Malwarebytes Product team so that they may consider this change for a future release, though of course the ultimate decision as to whether or not to actually implement it is entirely up to them, however I will see to it that your request is heard.

If you have any further feedback, ideas, suggestions or other ways that you believe Malwarebytes could improve their software and services please don't hesitate to let us know.


Link to post
Share on other sites

Thank you for the response, exile360. I believe I got a notification for when it completed -- I only kind of remember it, but the notification settings I had support that conclusion. So yes, you understood my description correctly.

Considering how long it actually took for the download to complete after the reboot, I'd say that it's a fairly reasonable amount of time for such a download to complete -- not so much for a download to start, though, as until then that's what it felt like I was waiting for.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.