Jump to content
aoc

Real-Time Protection turned off and won't switch back on

Recommended Posts

Hi,

Malwarebytes is reporting my real-time protection is switched off.  On opening, the Malware & PUP protection and the Ransomware protection are both off and will not switch back on.  A blue circle keeps circling instead of them switching on.  I use Malwarebytes 4.0.4 premium, fully updated on Windows 10. I tried restarting the computer, but there is no change.

What can I do to fix this?

Thanks in advance.

Share this post


Link to post
Share on other sites

***This is an automated reply***

Hi,

Thanks for posting in the Malwarebytes for Windows Help forum.

 

If you are having technical issues with our Windows product, please do the following: 

Spoiler

If you haven’t already done so, please run the Malwarebytes Support Tool and then attach the logs in your next reply:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  1. Download Malwarebytes Support Tool
  2. Once the file is downloaded, open your Downloads folder/location of the downloaded file
  3. Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  4. Place a checkmark next to Accept License Agreement and click Next
  5. You will be presented with a page stating, "Get Started!"
  6. Click the Advanced tab on the left column

    mbst_get_started.jpg
     
  7. Click the Gather Logs button

    mbst_advanced_gather_logs.jpg
     
  8. A progress bar will appear and the program will proceed with getting logs from your computer

    mbst_getting_logs.jpg
     
  9. Upon completion, a file named mbst-grab-results.zip will be found on your Desktop. Click OK

    mbst_log_saved_desktop.jpg
     
  10. Please attach the file in your next reply. Before submitting your reply, be sure to enable "Notify me of replies" like so:

     notify me.jpeg  

Click "Reveal Hidden Contents" below for details on how to attach a file:
 

Spoiler

To save attachments, please click the link as shown below. You can click and drag the files to this bar or you can click the choose files, then browse to where your files are located, select them and click the Open button.

mb_attach.jpg.220985d559e943927cbe3c078b
 

One of our experts will be able to assist you shortly.

 

If you are having licensing issues, please do the following: 

Spoiler

For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/hc/en-us/requests/new to get help

If you need help looking up your license details, please head here: https://support.malwarebytes.com/hc/en-us/articles/360038523934

 

 

Thanks in advance for your patience.

-The Malwarebytes Forum Team

 

Share this post


Link to post
Share on other sites

Greetings,

Please do the following so that we may troubleshoot and hopefully fix the issue:

  1. Download and run the Malwarebytes Support Tool
  2. Accept the EULA and click Advanced tab on the left (not Start Repair)
  3. Click the Gather Logs button, and once it completes, attach the zip file it creates on your desktop to your next reply

Thanks

Share this post


Link to post
Share on other sites

Thanks, I see that you are running Avast AV.  It is possible that a conflict is causing these issues.  Please try adding the items listed in this support article to Avast's trusted/exclusions list(s), especially for any of its real-time protection components and then restart your system and see if that helps at all.

If it does not, then please try temporarily removing Avast from your system and restarting to see if Malwarebytes is able to start all of its protection normally then just to rule it out as a possible cause.  You may use the tool and instructions provided on this page if required as that is Avast's official clean uninstall tool.

Please let us know how it goes and if the issue still persists or not.

Thanks

Share this post


Link to post
Share on other sites

Hi,

Thanks for the input.  I will try this and let you know what happens.  As info, I have been running Avast and Malwarebytes together for several years without problem.  I realise there may have been an update that has caused a conflict though.

I'll let you know as soon as I've tried.

Thanks

Share this post


Link to post
Share on other sites

You're welcome, yes, for many years Avast has generally worked well alongside Malwarebytes, however there have been some incidents of conflicts recently so that was the first item I wanted to check as a possible cause.  If it turns out that it is the cause then we should be able to provide some sort of workaround for you to keep both applications installed and active, but I just want to make sure whether or not it is the cause first to decide the next step.

Take as much time as you need, we'll be here once you're ready with your results.

Thanks

Share this post


Link to post
Share on other sites

Many thanks! It worked... I added in all the exceptions for Malwarebytes to Avast, then restarted my computer - it's all back to normal.

I really appreciate your rapid response and the clear instructions.

Share this post


Link to post
Share on other sites
1 minute ago, aoc said:

I added in all the exceptions for Malwarebytes to Avast, then restarted my computer - it's all back to normal.

Also suggest turning fast start off. https://www.computerhope.com/issues/ch001762.htm

The computer does not actually shut down with it on and that is why it worked. You did a restart.

 

Edited by Porthos

Share this post


Link to post
Share on other sites

Excellent, I'm glad that it worked :)!

Yes, and as Porthos suggests above, disabling fast startup in Windows 10 is also a good idea as it has been known to occasionally cause issues with Malwarebytes and other applications.  You can learn more here as well as here along with the link Porthos provided above.

Anyway, if there is anything else we might assist you with please let us know.

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.