Jump to content
InfamousGeezer

BSODs when connected to a VPN

Recommended Posts

I'm trying hard to troubleshoot my problem.  At first I thought that its the PureVPN application at fault.  I've been on to their support and tried there suggestions.  I am now thinking that there's a possibility that either Malwarebytes or BitDefender on PC could be causing the BSODs.  So I'd like to try any suggestions you have for me.  

If I am NOT connected to VPN my system runs superb with no issues.  So that led me to think that perhaps the data / internet traffic is possibly being monitored and protected by either Malwarebytes or BitDefender and as a safety system the BSOD triggers to prevent either my data being lost or preventing a malicious attack from occurring?

When connected to the VPN the BSODs occur within an hour of being connected.  Each time a BSOD occurs I get a various error codes.  The most common error code I recieve is Bad Pool Caller. 

PC system information attached.

System Information.txt

Share this post


Link to post
Share on other sites

***This is an automated reply***

Hi,

Thanks for posting in the Malwarebytes for Windows Help forum.

 

If you are having technical issues with our Windows product, please do the following: 

Spoiler

If you haven’t already done so, please run the Malwarebytes Support Tool and then attach the logs in your next reply:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  1. Download Malwarebytes Support Tool
  2. Once the file is downloaded, open your Downloads folder/location of the downloaded file
  3. Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  4. Place a checkmark next to Accept License Agreement and click Next
  5. You will be presented with a page stating, "Get Started!"
  6. Click the Advanced tab on the left column

    mbst_get_started.jpg
     
  7. Click the Gather Logs button

    mbst_advanced_gather_logs.jpg
     
  8. A progress bar will appear and the program will proceed with getting logs from your computer

    mbst_getting_logs.jpg
     
  9. Upon completion, a file named mbst-grab-results.zip will be found on your Desktop. Click OK

    mbst_log_saved_desktop.jpg
     
  10. Please attach the file in your next reply. Before submitting your reply, be sure to enable "Notify me of replies" like so:

     notify me.jpeg  

Click "Reveal Hidden Contents" below for details on how to attach a file:
 

Spoiler

To save attachments, please click the link as shown below. You can click and drag the files to this bar or you can click the choose files, then browse to where your files are located, select them and click the Open button.

mb_attach.jpg.220985d559e943927cbe3c078b
 

One of our experts will be able to assist you shortly.

 

If you are having licensing issues, please do the following: 

Spoiler

For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/hc/en-us/requests/new to get help

If you need help looking up your license details, please head here: https://support.malwarebytes.com/hc/en-us/articles/360038523934

 

 

Thanks in advance for your patience.

-The Malwarebytes Forum Team

 

Share this post


Link to post
Share on other sites

Greetings,

I'm sorry to hear you're having trouble but we will do our best to assist.  First, please do the following so that we may take a look at your current Malwarebytes installation and some basic info about your system:

  1. Download and run the Malwarebytes Support Tool
  2. Accept the EULA and click Advanced tab on the left (not Start Repair)
  3. Click the Gather Logs button, and once it completes, attach the zip file it creates on your desktop to your next reply

Additionally, I would suggest opening Malwarebytes and navigating to settings by clicking the small gear icon in the upper right area of the main Malwarebytes UI, then clicking the Check for updates button at the top of the General tab.  Allow Malwarebytes to download and install any available updates and reboot the system if prompted to do so.  I'm hopeful that a recent update to Malwarebytes may correct the issue if it is indeed the cause.

Thanks

Share this post


Link to post
Share on other sites

Thanks.  Your logs show that you should have the following memory dump files on your system.  Please copy them to a convenient location such as your desktop and then ZIP and attach them to your next reply, or if they are too large, please upload them to a service such as WeTransfer.com and then use the option to send the file as a link and post the link to the download here in your next reply:

C:\WINDOWS\Minidump\020720-5609-01.dmp
C:\WINDOWS\Minidump\020820-5531-01.dmp
C:\WINDOWS\Minidump\020820-5312-01.dmp
C:\WINDOWS\Minidump\020820-5328-01.dmp
C:\WINDOWS\Minidump\020920-5468-01.dmp
C:\WINDOWS\MEMORY.DMP

Thanks

Share this post


Link to post
Share on other sites

Excellent, thank you very much.  I will get the attention of a member of the Malwarebytes staff to analyze your crash dumps and to work with the Developers on investigating and hopefully mitigating this issue.  They will let you know if they require any additional information, thank you for your assistance and I hope this issue is resolved quickly.

@LiquidTension would you mind please taking a look at the logs and crash dumps provided?

Thanks

Share this post


Link to post
Share on other sites

By the way, to work around the issue you can probably disable the Web Protection component in Malwarebytes by right-clicking the Malwarebytes tray icon and clicking where it says Web Protection: On then clicking Yes to the User Account Control prompt.  Additionally, you may disable the notifications about a component of protection being disabled if you wish until this issue has been resolved.  To do so, open Malwarebytes and navigate to settings by clicking the small gear icon in the upper right area of the main Malwarebytes UI, then under the Notifications tab disable the option Alert me if any Real-Time Protection modules are turned off so that Malwarebytes will not alert you every time it starts up that Web Protection is disabled (assuming that does eliminate the BSOD's; if it doesn't, then you should try disabling each of the other protection components one at a time until you discover the culprit, though the Malwarebytes staff should be able to identify the cause by analyzing the logs and crash dumps you provided).

Share this post


Link to post
Share on other sites
17 minutes ago, InfamousGeezer said:

There has been no BSODs with Web Protection turned off. 

Could you run the following batch file as Administrator and provide the generated output (saved to the Desktop) please?

-----

If your testing indicates that Web Protection is likely the culprit, it would be useful to generate some additional troubleshooting data.

  • Open Malwarebytes > Settings > Enable the Event log data setting.
  • Enable Web Protection.
  • Wait for the issue to occur.
  • Once the issue has occurred:
    • Rerun the batch file from earlier and attach the file.
    • Run the Malwarebytes Support Tool and gather logs.
    • Make a note of any significant events/actions that took place prior to the issue occurring.
Edited by Porthos

Share this post


Link to post
Share on other sites

The first time I used the batch file.  It created the ipconfig_result.txt file I have attached.  I tried it again after the BSOD happened.  It never created a file.  If it did create a file it possibly over writed the previous ipconfig_result.txt file.  It just occurred to me I can take a look at the date of the file.

I think both files / logs were produced after the BSOD.

The only actions performed on the computer was watching a video in VLC while a few browser tabs were open in the background when the BSOD happened.  I was connected to the VPN with web protection enabled.

 

 

ipconfig_result.txt mbst-grab-results.zip

Share this post


Link to post
Share on other sites

Thank you for the report. We've seen a similar BSOD on another machine with BitDefender Total Security installed.

For troubleshooting purposes, would you be able to temporarily uninstall BitDefender Total Security, reboot the machine and check if the BSOD persists with Malwarebytes Web Protection enabled?

Share this post


Link to post
Share on other sites

Thanks for confirming. We're currently investigating this issue further.

As this involves Web Protection, configuring mutual exclusions will unlikely have any impact. I would therefore recommend one of the following approaches to mitigate the issue for the time being:

  • Leave BitDefender Total Security uninstalled.
  • Reinstall BitDefender Total Security and leave Web Protection disabled.
  • Revert to an earlier version of Malwarebytes (allowing you to reinstall BitDefender Total Security and keep Web Protection enabled): https://malwarebytes.box.com/s/z6cravnwptrzx5tyjw36jq6zt6c7apsx

Share this post


Link to post
Share on other sites
10 hours ago, LiquidTension said:

I opted for this.  I uninstalled the current version of Malwarebytes and installed the one linked above.  BSODs still happen.  I have attached a screenshot of the current version of Malwarebytes I am running. 

Would Malwarebytes automatically update to the most recent version by default?

I will list the BSODs error code I recieve.

- Kernel security check failure

- System thread exception not handled

- Bad pool caller

- Kmode exception not handled

- Driver IRQL not less or equal

- System service exception

- Attempted write to read only memory

The computer works fine as long as I do not connect to my VPN.  I will run both Malwarebytes & BitDefender with web protection turned off for the time being.

screenshot 1.png

Share this post


Link to post
Share on other sites

It may take time for the program to update to the latest version on its own as updates are metered out to users over time.  You can override this by opening Malwarebytes and going to settings and clicking the Check for updates button under the General tab and it will force the check for any new program versions and component updates along with signature/database updates.

Share this post


Link to post
Share on other sites
17 hours ago, InfamousGeezer said:

Just to clarify BSODs still occurred using the old version of Malwarebytes linked to me.

Try checking for updates, new version is 4.0.4.49 CU 1.0.823

Share this post


Link to post
Share on other sites

Using it now.  I'm not going to enable web protection until a solution comes up.  I considered trying a different VPN provider using their week / month free trial and seeing if the problem still persists.  If I do decide to try this.  I'll keep you posted.

Untitled.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.