Jump to content
bdg2

MalwareBytes 4 messing with IPv6 ping

Recommended Posts

What follows is worth a test  as an alternate way to set the DNS server address  choice  for TCP/IP v6  &  TCP/IPv4

and that is to select "Obtain DNS server address automatically".   This can resolve the situation with Ping.

 

Click Win-key  and use the search box:
Search for Control Panel, and click the top result to open.
Click on Network and Internet.
Click on Network and Sharing Center.
Click on Change Adapter Settings.

Right-click the Wi-Fi or Ethernet adapter that you're using to connect to the internet, and select the Properties option.

Select the Internet Protocol Version 4 (TCP/IPv4) option.
Click the Properties button.
Click the "Obtain DNS server address automatically"
Click OK

If the Internet Protocol Version 6 (TCP/IPv6) stack is enabled in the network adapter properties, select the option.
Click the Properties button.
Click the "Obtain DNS server address automatically"
Click OK

Click Close

Share this post


Link to post
Share on other sites

notes ^^^^    That should apply to all Windows versions.    This was tested on MB beta  4.1.1.76    Component package 1.0.946   / win 10  build 2004  ( May 2020  )

Share this post


Link to post
Share on other sites
1 hour ago, Maurice Naggar said:

What follows is worth a test  as an alternate way to set the DNS server address  choice  for TCP/IP v6  &  TCP/IPv4

and that is to select "Obtain DNS server address automatically".   This can resolve the situation with Ping.

 

Click Win-key  and use the search box:
Search for Control Panel, and click the top result to open.
Click on Network and Internet.
Click on Network and Sharing Center.
Click on Change Adapter Settings.

Right-click the Wi-Fi or Ethernet adapter that you're using to connect to the internet, and select the Properties option.

Select the Internet Protocol Version 4 (TCP/IPv4) option.
Click the Properties button.
Click the "Obtain DNS server address automatically"
Click OK

If the Internet Protocol Version 6 (TCP/IPv6) stack is enabled in the network adapter properties, select the option.
Click the Properties button.
Click the "Obtain DNS server address automatically"
Click OK

Click Close

I already have everything set to DHCP/AUTO (IP & DNS for IPv4 & IPv6)

Care to explain, why the ping will be blocked by MWB Web Protection, when it is not set to "Obtain DNS server address automatically? This sounds interesting.

Share this post


Link to post
Share on other sites

I would only say this.   If it were "web protection"  I would expect a message-window of a block with IP address cited in that message-box.

I have not seen that.   My MB 4.1.1.71   currently has all real-time protections on.   and the "obtain DNS server automatically".

Ping works on my rig.    WIFI connection by the way.

 

Prior to this for a short time, I had had Cloudfare set as the DNS server.   Wile web browsers worked ;   Ping was not succeeding.

Why that was so I have no idea.

Share this post


Link to post
Share on other sites
3 minutes ago, Maurice Naggar said:

I would only say this.   If it were "web protection"  I would expect a message-window of a block with IP address cited in that message-box.

I have not seen that.   My MB 4.1.1.71   currently has all real-time protections on.   and the "obtain DNS server automatically".

Ping works on my rig.    WIFI connection by the way.

 

Prior to this for a short time, I had had Cloudfare set as the DNS server.   Wile web browsers worked ;   Ping was not succeeding.

Why that was so I have no idea.

If I disable Web Protection, the ping directly works. I maybe have to mention, if I for example ping google.com (with Web Protection enabled), the ping command directly shows the IPv6 address of google.com, but the ping fails. So to me it doesn't look like a DNS problem at first glance, but I am not a specialist.

 

Share this post


Link to post
Share on other sites

Bit of a mystery.   I would swear that pinging google.com  was good  earlier on both IPv6 & IPv4

Now IPv4 works   but IPv6 fails when you specify google,com   /   but works when you ping 172.217.1.142

IPv6 fails when you specify yahoo.com   /   but works when you ping  72.30.35.10

Share this post


Link to post
Share on other sites
2 hours ago, Maurice Naggar said:

Bit of a mystery.   I would swear that pinging google.com  was good  earlier on both IPv6 & IPv4

Now IPv4 works   but IPv6 fails when you specify google,com   /   but works when you ping 172.217.1.142

IPv6 fails when you specify yahoo.com   /   but works when you ping  72.30.35.10

What's the mystery?

IPv4 works. MWB breaks IPv6 pings.

What's mysterious about that?

The real mystery is why they seem totally unable to fix it.

Share this post


Link to post
Share on other sites
11 minutes ago, Maurice Naggar said:

You may consider using TCPING.exe https://www.elifulkerson.com/projects/tcping.php
You may consider using NMAP which comes with a utility called NPING
https://nmap.org/download.html

 

Why?

Anyway I don't see how they help if, say, I use a web page that has a script that pings test sites.

Your first link is blocked by MWB anyway.

Share this post


Link to post
Share on other sites

I'm uninstalling MWB 4.

It was a mistake to try it before the final V4 version just the same as it was with version 3 before. None of V3 releases I tried were acceptable until the final one before V4 was released.

I'm fed up with being stuck on a clunky version that makes my PC freeze for several seconds at intervals while a bug with IPv6 in later versions is ignored.

I keep getting told to try beta versions that refuse to install on my PCs.

Share this post


Link to post
Share on other sites
1 hour ago, bdg2 said:

I keep getting told to try beta versions that refuse to install on my PCs.

What happens when you try to install them?  How are you trying to install them exactly?  I have not heard of anyone else having any issues with getting any of the betas installed so this issue may indicate further issues beyond the IPv6 issue.

Share this post


Link to post
Share on other sites

Because of the problems I am running version 4.0.4.49 as advised. But this version is constantly nagging with "New version available" although "Automatically download and install updates" and "Notify me when a new version is availabe" is DISABLED. Why is this happening? This notifcation also draws over games and all applications.

 

 

mwb1.jpg.707d3ccab27ea98526713406304e4e92.jpg

mwb2.jpg.9860398532d11efba570612a573d39db.jpg

Share this post


Link to post
Share on other sites
Posted (edited)

Malwarebytes must have downloaded the new build prior to the two update settings being disabled.

Perform a clean uninstall/reinstall of Malwarebytes, then immediately disable those two options and it should no longer prompt you to upgrade.

  1. Download and run the Malwarebytes Support Tool
  2. Accept the EULA and click Advanced tab on the left (not Start Repair)
  3. Click the Clean button, and allow it to restart your system and then reinstall Malwarebytes

Edited by exile360

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, rahe said:

I am running version 4.0.4.49 as advised. But this version is constantly nagging with "New version available" although "Automatically download and install updates" and "Notify me when a new version is availabe" is DISABLED. Why is this happening?

You must have not disabled it fast enough and it triggered it. You have to be quick to toggle it off.

See if you can find a MBsetup file in this folder. It is hidden by default. If yes, Exit Malwarebytes from the system tray and proceed to delete the file.

C:\ProgramData\Malwarebytes\MBAMService\instlrupdate

Edited by Porthos

Share this post


Link to post
Share on other sites
On 6/13/2020 at 10:03 AM, Maurice Naggar said:

...

Prior to this for a short time, I had had Cloudfare set as the DNS server.   Wile web browsers worked ;   Ping was not succeeding.

Why that was so I have no idea.

That's interesting, I do have my ipv6 networking configured for DHCP but my router is utilizing cloudflare as the DNS resolver and that's the what is being sent to my devices. I do know the 1.1.1.1 has caused some network shennanigans (not so much at home but at work) but it would be weird if the IPV6 DNS address was causing issues as well.  That said did try to change from cloudflare to google's ipv6 dns and the issue persists.

DNS Servers . . . . . . . . . . . : 2001:4860:4860::8888
                                    2001:4860:4860::8844
                                    1.1.1.1
                                    1.0.0.1
                                    8.8.8.8

This particular DNS config ping still randomly cuts out. Between 7 and 21 is where I turned on Web Protection

$ ping google.com
PING google.com(dfw28s04-in-x0e.1e100.net (2607:f8b0:4000:815::200e)) 56 data bytes
64 bytes from dfw28s04-in-x0e.1e100.net (2607:f8b0:4000:815::200e): icmp_seq=1 ttl=115 time=10.1 ms
64 bytes from dfw28s04-in-x0e.1e100.net (2607:f8b0:4000:815::200e): icmp_seq=2 ttl=115 time=9.99 ms
64 bytes from dfw28s04-in-x0e.1e100.net (2607:f8b0:4000:815::200e): icmp_seq=3 ttl=115 time=9.82 ms
64 bytes from dfw28s04-in-x0e.1e100.net (2607:f8b0:4000:815::200e): icmp_seq=4 ttl=115 time=20.9 ms
64 bytes from dfw28s04-in-x0e.1e100.net (2607:f8b0:4000:815::200e): icmp_seq=5 ttl=115 time=9.79 ms
64 bytes from dfw28s04-in-x0e.1e100.net (2607:f8b0:4000:815::200e): icmp_seq=6 ttl=115 time=12.2 ms
64 bytes from dfw28s04-in-x0e.1e100.net (2607:f8b0:4000:815::200e): icmp_seq=7 ttl=115 time=9.59 ms
64 bytes from dfw28s04-in-x0e.1e100.net (2607:f8b0:4000:815::200e): icmp_seq=21 ttl=115 time=9.75 ms
64 bytes from dfw28s04-in-x0e.1e100.net (2607:f8b0:4000:815::200e): icmp_seq=22 ttl=115 time=9.87 ms
64 bytes from dfw28s04-in-x0e.1e100.net (2607:f8b0:4000:815::200e): icmp_seq=23 ttl=115 time=10.4 ms
64 bytes from dfw28s04-in-x0e.1e100.net (2607:f8b0:4000:815::200e): icmp_seq=24 ttl=115 time=10.0 ms
^C
--- google.com ping statistics ---
24 packets transmitted, 11 received, 54.1667% packet loss, time 23031ms
rtt min/avg/max/mdev = 9.594/11.123/20.862/3.151 ms

So Maurice ipv6 ping works just fine for you on the current stable version of mbam?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.