Thank you for the report. We have a defect filed for this issue and hope to have a fix available in the future. Regarding workarounds, you also have the option of reverting to an earlier component package version, which will allow you to keep Web Protection enabled. You can download this from here: Once installed, you will need to disable the two update options found in Settings -> General -> Application updates to pre