Jump to content


Recommended Posts

Hey guys!

I got a problem with BSOD with DPC_WATCHDOG_VIOLATION code since like half a year or more. It used to be thrown like once per couple of days, now it's almost everyday. I tried anything I could with my knowledge but nothing helped. WinDbg says randomly the problem is with either nvlddmkm or unknown_module. Last time it was ntkrnlmp.exe which was something new but still couldn't get the solution for that. Previously there were some situations where PC freezed for like minute and then unfreezed without any BSOD but audio driver crashed and I had no sound (until just restarting it in device manager). Once I was checking minidumps with WhoCrashed program which said it's a problem with ntoskrnl.exe. Ah, before BSOD whole system freezes for like 30 seconds to minute. I couldn't find any relation between BSODs - they appears in random moments for me.

I was also searching for solution by FAILURE_BUCKET_ID which is ZEROED_STACK_0x133, 0x133_ISR_nvlddmkm!unknown_function and once it was 0x133_ISR_nt!KeAccumulateTicks but also couldn't find anything that helped

I have like 16 minidumps and one memory dump of 1.3GB size. Sharing those 16 minidumps in attachments as zip. If memory dmp will be useful I can upload it somewhere too

Some informations about the software:

  • OS - Windows 10 64bit (Installed by myself)
  • OS is not OEM
  • PC is almost 3,5 years old (bought 2016-10-03)
  • Age of OS installation might be like 2 years but that's just guessing. I was reinstalling the system once

And hardware:

  • CPU - Intel Core i5-6600K, 3.5GHz, 6 MB
  • GPU - Zotac GeForce GTX1070 AMP Edition 8GB GDDR5 (256 bit)
  • MotherBoard - Gigabyte GA-Z170-GAMING K3
  • Power supply - Thermaltake Smart SE 530W
  • This is a desktop PC

Tried to attach zip from SysnativeBSOD but it goes into a loop with "waiting for SystemInfo - Specified service does not exist as installed service" error

Thanks for any help in advance!


Link to post
Share on other sites

  • 2 weeks later...


I'm sorry that no one has responded to your topic yet.  If you are still seeking assistance I'll do my best to help.  I'm not knowledgeable when it comes to reading crash reports and BSOD's, however I am aware of some issues with overclocking and the error you describe, and from the sound of it, this could be related to your graphics card since those are NVIDIA filenames listed by WinDbg.  If you are overclocking your GPU, please restore it to default clocks.

If that doesn't help, try shutting down the system, turning off the power, unplugging it from the wall and turn the switch on the power supply to the off position, then open your computer case and remove your graphics card and check it for dust, hair and any other debris that might have collected in the fan(s) and air flow channels on the card, and if it is badly clogged up, try cleaning it carefully using canned air if you have any along with a tool to dig debris out of the fans and other spots you can easily reach (again, carefully, without damaging the card) such as a Q-tip, pen, or screwdriver; just don't pry into anything or use any real force so that you avoid damaging your card.

You should also check your temperatures with a tool such as HWiNFO to see what kinds of temps your components are running at.

With the system being a few years old then it may require a new application of thermal paste for the CPU and/or GPU if either component is overheating (you want your GPU in the low 80's C or lower and your CPU well under 100C, ideally low 70's C or lower though it can run up to 100+ C without throttling/crashing from heat), however if you are not familiar with doing so then I wouldn't advise attempting it, but if you are then it might help.  You could also take the system to a PC repair shop or knowledgeable friend or family member if they are familiar with building and repairing PC's.

Please disregard if someone else has more knowledge about analyzing crashes and can offer better advice, these are just a few ideas I would likely try if it were my system.

Link to post
Share on other sites

Hey exile360, thanks for the answer!

I'm still interested in any help as bsods still throw, last one at Sunday though. About overclocking - If I remember correctly, I didn't do any overclocking on GPU nor on CPU however will check in BIOS and restore to defaults to be sure.

About cleaning the PC - I did it few months ago after BSOD case appeared. Cleaned precisely as far as I could with canned air (didn't put new thermalpaste though as forgot to buy one) and unfortunately it didn't help. However looking on HWiNFO and temperatures look quite good:

- CPU ~34C (don't know what's "Core n Distance to TjMax" but it shows about 66C for all 4 cores)

- Motherboard - ~38C

- VRM - ~45C

- GPU - ~45C

Btw. it's funny as I'm playing games quite often and the BSOD rarely throws during gaming. It appears more often during normal work like browsing the web, coding, watching movies etc.

Also got a BSOD during writing this post, GPU was exactly 45C then. Bsod says now:

MODULE_NAME: Unknown_Module
IMAGE_NAME:  Unknown_Image
STACK_COMMAND:  .thread ; .cxr ; kb

This PROCESS_NAME interested me as it used to be as System


Link to post
Share on other sites

Interesting, your description of when/how the BSOD's occur would make it seem more likely that it is related to your internet connection somehow.  If you are using Malwarebytes Premium, try disabling Web Protection for a while and see if the BSOD's go away.  There is an issue being tracked which can cause BSOD's and other issues on some systems that the Developers are looking into and working on.

Examples of this issue can be found here as well as here.  It might also be a good idea to update your network drivers.

Bad RAM or poorly seated RAM is another possibility as far as hardware goes, so you might remove all your RAM sticks and securely replace them back into their DIMM slots to ensure that they are installed securely and maybe give memtest86 or the memory diagnostic in Windows a try to see if there are any errors.

Link to post
Share on other sites

Tracking down bad RAM can often take more than a handful of passes unfortunately, but that's seldom the issue anyway frankly so it's probably best to move on to trying other avenues, at least until that becomes a last resort if nothing else fixes it.  I think it's a good idea to start with the drivers, and yes, since you already reseated the RAM for testing that should eliminate a bad DIMM connection from the list of possibilities so that's good (it's just too bad it didn't fix it obviously, but hopefully updating the driver will).

Anyway, please let us know how it goes and if updating the driver resolves it or not, and if you have any trouble locating the latest driver we should be able to help as well if needed but it shouldn't be too difficult to find it on the vendor's website (i.e. Intel, Realtek, Broadcom or whoever the vendor of the network card/chip might be) and of course there are likely drivers available on Gigabyte's site as well, thought whether they are actually the latest for that particular chip/card I don't know, so it's probably best to check each vendor's site to see who has the latest.

Link to post
Share on other sites

Hi. . .

Apologies for the late reply. 

You have had your share of BSODs - 14 of them going back to August 2019. You even had one on New Year's Day that had the same bugcheck (0x133 - DPC_WATCHDOG_VIOLATION ) as the four BSODs that I've processed that occurred recently. Same goes for your very first BSOD last August - 0x133 bugcheck.

"WATCHDOG" in Windows usually refers to video, but not always.

I'm seeing a lot of "Unknown_Image" and "Unknown_Module" listings in the dumps, which should be driver names, not UNKNOWN whatever. 

This is usually a problem related to RAM or the hard drive. Keep in mind when I mention RAM that it could be RAM itself or some other underlying issue (like heat) or perhaps other unknown hardware failure (like PSU; motherboard) that is affecting RAM's ability to properly hold kernel code. Bottom line is that your BSODs could be affected by RAM for many reasons.

I'd like you to run hardware diagnostics for RAM and your hard drive.

RAM - run memtest86 one stick at a time; alternate the slots so you'll be testing each RAM stick in each slot by itself. I know this may seem long and daunting, but it is the most prudent way to test RAM. I believe that memtest86 free version allows 4 passes, so do all 4 passes.

Hard Drive - if an SSD, check the SSD manufacturer's site for a firmware upgrade. This is uber-important to do.

Diagnostic test - Run SeaTools for DOS, LONG test on ALL internal drives - https://www.sysnative.com/forums/threads/hard-drive-hdd-diagnostics-sea-tools-for-dos-ssd-test.4072/

Also, apologies about the Sysnative app that I wrote - if you have a huge number of WERCON (Windows Error Reporting) entries, the "waiting for systeminfo" message will repeat and repeat for a very long time (hours, even days!). It is generated by the Windows app msinfo32 so there is nothing that I can do about it (i.e., I cannot fix the Microsoft Windows source code). It rarely occurs.

Even though the Sysnative app did not finish, there should still be a Sysnative folder located in Documents with about 25-30 files in it. If you can, please zip it up and attach to your next post. Thank you.

I DO NOT find your BSODs to be a driver issue, however, please make sure that your NVIDIA driver is up to date - https://www.sysnative.com/drivers/driver.php?id=nvlddmkm.sys

Good luck with the testing.

Regards. . .




BugCheck 133, {1, 1e00, fffff80364a52378, 0}
Probably caused by : Unknown_Image ( ANALYSIS_INCONCLUSIVE )
BugCheck 133, {1, 1e00, fffff801b3667378, 0}
Probably caused by : nvlddmkm.sys ( nvlddmkm+11a648 )
BugCheck 133, {1, 1e00, fffff80204ee0378, 0}
Probably caused by : ntkrnlmp.exe ( nt!KeAccumulateTicks+103631 )
BugCheck 133, {1, 1e00, fffff801818fc378, 0}
Probably caused by : nvlddmkm.sys ( nvlddmkm+3caf61 )


Link to post
Share on other sites

Sry, accidentialy pressed tab and space instantly - seems I can't edit nor delete my post so will write it again:

Hey guys

Thanks @jcgriff2 for the steps to find an error! Actually I did the steps @exile360 told me to do i.e. installing drivers for both my net adapters (MOBO integrated and internal TP-LINK). I installed both of them and didn't get any BSOD since 20th of February. It's quite long for this if taking into account that I was getting at least one each day. I don't know if it's necessary now to make memtest86 in this case. However if you feel like it would make us sure BSOD won't throw again I can do that. About SSD - I have like old version ? of Goodram Iridium Pro - no firmware updates, at least didn't find any. About Nvidia driver - last time I reinstalled the drivers so they should be at least one of newer versions.

Wanted to reply with that earlier but I also wanted to take more time to see if any BSOD won't be thrown.

About Sysnative - I would upload the files but it seems I don't have any files related to it.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.