Jump to content

Occasional dropping of wireless connection - is Malwarebytes the cause?

Recommended Posts

I recently bought a refurbished ThinkPad T450s with a pretty vanilla installation of Windows 10 Pro x64 (my first foray into this OS after 8 years of W7 on a Lenovo G560 that was reluctant to upgrade to W10). Things went better than I'd hoped when it came to transferring my files across and reinstalling what programs I needed, especially after cloning the small SSD to a new 1TB Crucial MX500. I've updated what drivers I felt necessary and also to the latest BIOS, and Windows Update has upgraded the OS to v.1909. I've transferred my MB Premium from the old laptop and it's running nicely alongside Windows Defender. The only niggle I have is the occasional dropping of the Wi-Fi connection, which rarely occured with the old Lenovo - if I go into the WiFi connection from the System Tray, I find that Automatically Connect is unselected and if I re-select it, the connection is restored. I downloaded a more up-to-date driver from the Lenovo site today, but that didn't help. I've no reason to suspect Malwarebytes except that there has been some discussion here about the loss of Wi-Fi being associated with recent versions of MB4. I'm running version 4.0.49, component version 1.0.810 and attach the MBST results in case they help. Otherwise, Malwarebytes 4 is running completely trouble free - and I've no evidence that the problem is Malwarebytes is causing the error.


Link to post
Share on other sites

  • Staff

***This is an automated reply***


Thanks for posting in the Malwarebytes for Windows Help forum.


If you are having technical issues with our Windows product, please do the following: 


If you haven’t already done so, please run the Malwarebytes Support Tool and then attach the logs in your next reply:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  1. Download Malwarebytes Support Tool
  2. Once the file is downloaded, open your Downloads folder/location of the downloaded file
  3. Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  4. Place a checkmark next to Accept License Agreement and click Next
  5. You will be presented with a page stating, "Get Started!"
  6. Click the Advanced tab on the left column

  7. Click the Gather Logs button

  8. A progress bar will appear and the program will proceed with getting logs from your computer

  9. Upon completion, a file named mbst-grab-results.zip will be found on your Desktop. Click OK

  10. Please attach the file in your next reply. Before submitting your reply, be sure to enable "Notify me of replies" like so:

     notify me.jpeg  

Click "Reveal Hidden Contents" below for details on how to attach a file:


To save attachments, please click the link as shown below. You can click and drag the files to this bar or you can click the choose files, then browse to where your files are located, select them and click the Open button.


One of our experts will be able to assist you shortly.


If you are having licensing issues, please do the following: 


For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/hc/en-us/requests/new to get help

If you need help looking up your license details, please head here: https://support.malwarebytes.com/hc/en-us/articles/360038523934



Thanks in advance for your patience.

-The Malwarebytes Forum Team


Link to post
Share on other sites

  • Root Admin

Not sure if Malwarebytes is the reason but the Event Logs show that both your Volume Shadow Copy service as well as Malwarebytes keep having issues or errors.

I would recommend you run the following tool to see if it can find anything wrong or not with VSS and if so fix it.


Please download and run the following  Volume Shadow Copy Service (VSS), Diagnostic Tool, from Acronis

Acronis VSS Doctor

Free tool for diagnosing and repairing Volume Shadow Copy Service issues. Download link on the bottom of the page.
Download - Acronis VSS Doctor

In many cases, it can correct the issues on its own. If not, then it will give details on what may be causing the issues. Please save the report in text format and post back that log on your next reply.

You can also try the tool from Macrium Reflect if the Acronis tool did not work.

Macrium Reflect Volume Shadow Copy Service (VSS) Repair Tool

Once you've run the repair tool you need to restart your computer.
Then check your Event Logs to see if the error was corrected. You can post new logs from FRST which will also show the Event Log entries 

If you don't have System Restore enabled then please take this time to enable it. If possible choose 10% of your C drive to store Restore Points.

System Restore disabled or greyed out? Turn On System Restore in Windows 10



Once that is completed and any issues with VSS have been fixed please try a clean removal and reinstall of Malwarebytes. Then enable Beta updates as well within the program.



Thank you


Link to post
Share on other sites

Win 10 190* can be erratic with wifi depending mainly on which manufactuters card  and which driver you have.

Qualcom wifi cards/drivers seem to give it the most problems. (Not showing any networks, not connecting at start up, etc).

I wrote myself a quick one line batch file that uses netsh to connect to my home wifi when windows occasionally doesn't. It lives next to the system tray and a double click quickly makes the connection. (Plus if I'm not at home it can't find that network name and so then looks for others).

Edited by nukecad
Link to post
Share on other sites

Thanks @Porthos, @AdvancedSetup & @nukecad for your interest and help. I ran the two VSS tools and the log for VSS Doctor is attached. I don't quite understand what it means about not having enough space on the System Reserved partition and if I should do anything about it. I rebooted the computer and re-ran the MBST - results attached.

Thanks for the advice - I must be getting the hang of this stuff at last because among the first things I did when I set up Windows 10 were (1) Disable Fast Startup (2) Enable System Restore on C drive and (3) set the allocated space for System Restore at 10%.

I have already got Beta updates enabled but I'm going to run the Malwarebytes uninstall/reinstall tool next and see how things progress

AcronisVSSDoctorReport_2020-02-04-19-29-36.txt mbst-grab-results.zip

Link to post
Share on other sites

Yes, just carried out the clean uninstall/reinstall - should I submit new logs now that's done?  I've been pretty religious about checking for and installing Windows Updates and I ran a computer audit with Belarc today that confirmed everything was up to date.

Link to post
Share on other sites

Perhaps too early to be certain, but I used the ThinkPad for quite a while yesterday during which time I had no instances of the WiFi dropouts with Web Protection disabled in Malwarebytes Premium. I'll leave WP disabled until the next Beta version is released and then try turning it on again after I've installed it - if I get any further instances of WiFi dropping in the interim, I'll re-post here.
Otherwise, Malwarebytes Premium appears to be running well with fast scans and no errors.

Despite the VSS errors discussed earlier in this thread, all backups run with Casper 10.1 (I've used Casper for 20 years or more) have completed successfully with no errors shown in that application's logs. That includes both bootable disk copies and system images. System Restore also appears to operate correctly, as does Tweaking.com's Registry Backup (although who knows with System Restore whether it's going to work the next time?)


Link to post
Share on other sites

  • Staff

Hi @TempLost,

Is this machine in an IPv6-enabled environment?
Could you run the following batch file as Administrator and provide the generated output (saved to the Desktop) please?


If your testing indicates that Web Protection is likely the culprit, it would be useful to generate some additional troubleshooting data.

  • Open Malwarebytes > Settings > Enable the Event log data setting.
  • Enable Web Protection.
  • Wait for the issue to occur.
  • Once the issue has occurred:
    • Rerun the batch file from earlier and attach the file.
    • Run the Malwarebytes Support Tool and gather logs.
    • Make a note of any significant events/actions that took place prior to the issue occurring.
Link to post
Share on other sites

Well, I've been running a few days now with all 4 protection modules activated and haven't experienced any dropouts. The only changes I have made that I could suspect might be responsibleffor the improvement is that I let the Lenovo driver update service update 3 or 4 drivers. My policy had been to rely on Windows Update for drivers rather than Lenovo unless I could identify a specific need for the latter but perhaps not the right policy here?

Link to post
Share on other sites

  • 3 weeks later...

Just an update:--

I still got a few incidents of my wireless connection dropping out since my last post and did some more work trying different drivers for the Intel(R) Dual Band Wireless-AC 7265 on the ThinkPad T450s. I had been running the recommended driver installed from Windows 10 Update, but then tried the tool on the Lenovo site which recommended another driver, which didn't improve the dropouts. I then went to the the Intel site and their tool recommended yet another driver, version Since installing that driver, I've not had any more episodes of dropouts, so I suspect that the fault lay elsewhere than with Malwarebytes - so thanks for all the help here and apologies for the wild goose chase!

Link to post
Share on other sites

  • 1 month later...

A further update:-

I spooke too soon and the incidents of dropped wireless signal reappeared but I haven't had the opportunity to do any further testing. I was pretty sure that I was wrong in suspecting that Malwarebytes might be the cause and came across this link on the Lenovo site with some suggestions for resolving the problem - https://support.lenovo.com/gb/en/solutions/ht502846

Method 7, Disabling 802.11n Mode from 11n/ac to 11ac for the Wireless Adapterseems to have done the trick and no more dropouts have occured since I made that change. Just in case it helps anyone else...............


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.