Jump to content

Malwarebytes prevents my computer from sleep! (Windows 10 1909 Latest)


Go to solution Solved by AdvancedSetup,

Recommended Posts

  • 3 months later...

I switched from Win7 pro to Win10 pro at the end of last year. The version 1909 was installed. Since then the computer doesn't go into energy saving mode anymore. The screen gets dark, but the computer continues to run fully.
But in the internet and in various forums I didn't find anything suitable. Also the option Suspend update for 7 days does nothing.
Then I found out that the problem is caused by the Update Orchestrator service (UsoSvc service). As soon as this service is executed, the computer does not go into energy saving mode anymore. The service is always activated again when the computer is switched on.
The reason is probably task scheduling:
- Microsoft
- Windows

- UpdateOrchestrator

- Universal Orchestrator Start

- Conditions

- Power: Reactivate computer to run the Task

This setting cannot be deactivated by me because it is password protected.

Since none of the workarounds described on the Internet work, I use the following procedure:

After computer startup, call services and check if the UsoSvc service is active. If it is, stop it and deactivate the service in any case. Then it works for me without any problems, even if the computer is turned off in the meantime until the next day when the computer is turned on again.

As far as I can tell, the problem has nothing to do with malware bytes.

Link to post
Share on other sites

  • Staff

Hey guys, I just asked a member of the Product team for a status update on this issue.  I'll post back if I hear any news unless a member of the staff posts here ahead of me.

Thank you for sharing your experience, sysopa; while this is confirmed to be an issue with Malwarebytes according to the staff member above, it is definitely true that an issue can have more than one possible cause and I've chased down many bugs that seemed to have a known/common cause, yet actually fixing the issue ended up requiring something completely different, unrelated to the cause(s)/fixe(s) reported by others around the net.

Link to post
Share on other sites

  • Staff

Hey guys, I just heard back with confirmation that they hope to have the fix for this issue in one of the upcoming releases, though they didn't have an exact ETA.

Please monitor this thread for a response from a staff member once this issue has been resolved.

Thank you for your continued patience while this issue is being worked on.

Link to post
Share on other sites

  • 4 months later...
10 minutes ago, Firefox said:

There have been several new versions since you last posted about this issue, although not mentioned in the fixes, its possible that the latest version may no longer have the issue.

Have you tried installing the latest version and tested?

Thanks for your reply.

I would rather wait until there is some positive confirmation that it is fixed before I update - either by MWB themselves or other users.

It's such a pain having to do hard shut downs when the computer won't sleep. 

Link to post
Share on other sites

  • Root Admin
  • Solution

Hello @dim33@steamer

A fix for this issue was officially added in July 2020 on CU12, we are currently on CU21 as of today. Please try installing the latest version of Malwarebytes and restart the computer after the install and let us know if you're still experiencing any issues with going to sleep now.

Thank you

 

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.