Jump to content
biomembrain

Malwarebytes prevents my computer from sleep! (Windows 10 1909 Latest)

Recommended Posts

In the last couple of updates of Malwarebytes, I have been having problems with my computer going to sleep. It doesn't go to sleep, so I have to turn it off with the power button.

Going to sleep often works the first time, then if I put my computer to sleep again, it doesn't go to sleep. Then I figured out that Malwarebytes was messing this up, when I quit it, and then I can put my computer to sleep 10 consecutive times. My sleep mode works when I quit Malwarebytes. I can't believe this happened.

It's really frustrating. This is the root cause of my computer not falling asleep. I hope you guys make sure this never happens again! I lost webpages due to this! This is for real!

 

Share this post


Link to post
Share on other sites

***This is an automated reply***

Hi,

Thanks for posting in the Malwarebytes for Windows Help forum.

 

If you are having technical issues with our Windows product, please do the following: 

Spoiler

If you haven’t already done so, please run the Malwarebytes Support Tool and then attach the logs in your next reply:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  1. Download Malwarebytes Support Tool
  2. Once the file is downloaded, open your Downloads folder/location of the downloaded file
  3. Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  4. Place a checkmark next to Accept License Agreement and click Next
  5. You will be presented with a page stating, "Get Started!"
  6. Click the Advanced tab on the left column

    mbst_get_started.jpg
     
  7. Click the Gather Logs button

    mbst_advanced_gather_logs.jpg
     
  8. A progress bar will appear and the program will proceed with getting logs from your computer

    mbst_getting_logs.jpg
     
  9. Upon completion, a file named mbst-grab-results.zip will be found on your Desktop. Click OK

    mbst_log_saved_desktop.jpg
     
  10. Please attach the file in your next reply. Before submitting your reply, be sure to enable "Notify me of replies" like so:

     notify me.jpeg  

Click "Reveal Hidden Contents" below for details on how to attach a file:
 

Spoiler

To save attachments, please click the link as shown below. You can click and drag the files to this bar or you can click the choose files, then browse to where your files are located, select them and click the Open button.

mb_attach.jpg.220985d559e943927cbe3c078b
 

One of our experts will be able to assist you shortly.

 

If you are having licensing issues, please do the following: 

Spoiler

For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/community/consumer/pages/contact-us to get help

If you need help looking up your license details, please head here: https://support.malwarebytes.com/docs/DOC-1264 

 

Thanks in advance for your patience.

-The Malwarebytes Forum Team

 

Share this post


Link to post
Share on other sites

Hi @biomembrain,

Thanks for the report. We've reproduced this issue and are currently investigating it further.

Could you confirm that if Web Protection is disabled (and left disabled) in Malwarebytes, the issue no longer occurs after the machine has been rebooted at least once.

Also, please feel free to private message me with the logs. This will assist our efforts in finding a fix.

Share this post


Link to post
Share on other sites

Thank you Malwarebytes!

Thank you for all of the Developers that work on Malwarebytes.

You guys are working on super complex software. I admire that, amazing achievements everyday @Malwarebytes.

Share this post


Link to post
Share on other sites

My computer also will not sleep. It hangs and I have to switch it off and restart it. The recent MWB has also broken Qlik Sense Connectors - I've spent all day to understand this.

Not a good week for what is otherwise and excellent product.

Share this post


Link to post
Share on other sites

I also have the issue with my PC randomly not entering sleep properly. Sleep works as intended if I close MBAM before leaving my PC for any time.

I have also experienced Issues with my network connection randomly disappearing even though other PCs/devices have no issue. A reboot is required to fix this.

Share this post


Link to post
Share on other sites

I have both issues also. Started with my wireless device being turned off then my laptop shutting down when trying to enter sleep mode. Disabling had no effect I had to uninstall Malwarebytes, turn on Windows defender and now everything is fine.

Share this post


Link to post
Share on other sites

Hi all,

For issues with network connectivity, please install the latest beta version: https://forums.malwarebytes.com/topic/252170-a-new-malwarebytes-4-beta-is-now-available/?do=findComment&comment=1357781

For issues with sleep/hibernation, we are still investigating this. The known workaround for this issue is to disable Web Protection prior to putting the machine to sleep/hibernate.

Share this post


Link to post
Share on other sites
18 minutes ago, LiquidTension said:

Hi all,

For issues with network connectivity, please install the latest beta version: https://forums.malwarebytes.com/topic/252170-a-new-malwarebytes-4-beta-is-now-available/?do=findComment&comment=1357781

For issues with sleep/hibernation, we are still investigating this. The known workaround for this issue is to disable Web Protection prior to putting the machine to sleep/hibernate.

Yes connectivity issue solved but  disabling did not work.

Share this post


Link to post
Share on other sites

I found the problem on my computer. It is not MWB but Win10 1909 with the latest update, namely the UsoSvc service (Update-Orchestrator-Service). When the service is active, it prevents the system from going into sleep mode. If the service is stopped or deactivated, the energy saving mode works fine.

I only recently switched to Win10, then came the MWB update, so I suspected MWB.

Share this post


Link to post
Share on other sites

I originally assumed the latest Windows update was the culprit. Worked on it for a couple of days till I finally found posts here. I have  had MWB for 8+ years with several computers and no issues. I did not even consider MWB the source of my problems and I know this will be fixed soon. I  have lost no respect for this product. 

Share this post


Link to post
Share on other sites

Over and above my desktop pc the sleep issue is also affecting my Surface Pro 4. Disabling web protection allows them both to sleep.

Share this post


Link to post
Share on other sites

Is there any update about this issue?

For over 2 weeks now I've turned off web protection. This is not ideal and neutralises MBAM as a protection tool.

Share this post


Link to post
Share on other sites

Thank you for your patience. Unfortunately, we do not have an update on the issue at this current time.

If you wish to have Web Protection enabled for the majority of your Windows session, it has been found that leaving Web Protection enabled and only disabling it immediately prior to performing the sleep/hibernation mitigates the issue.

Share this post


Link to post
Share on other sites

Do you guys have a way for us to downgrade back to a 3.xx version of Malwarebytes? I fail to see the benefits of this new version if it's causing this headache, and I assume the malware protection definitions are updated separately from the program itself. Both of my devices are plagued by this issue, and it's very frustrating when I close my laptop lid and immediately go "aaarrrrgg I forgot to turn off real-time protection" and have to hard reboot.

Share this post


Link to post
Share on other sites

You can either revert to an earlier Malwarebytes version 4 component package version (download URL) that does not contain the issue or revert to Malwarebytes version 3.x (download URL).

If you revert to a previous Malwarebytes version, you will need to disable the "Application updates" settings found in Settings -> General. Once we release a fix, you will need to update to the fixed version manually.

Share this post


Link to post
Share on other sites

Could you advise please which is the most recent version of Malwarebytes that does not exhibit this problem?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.