Jump to content

Cannot remove allow list entry


Recommended Posts

The browser guard user guide shows how to remove an entry from browser guard.  You highlight the entry and click on the trash button.  However,  there is no such trash button.

Malwarebytes Browser Guard version
2.1.8

The user guide also says you can remove all by clicking on the kebab icon at the top of the list.  There is no such icon there.

Link to post

Greetings,

You should see the trash can icon appear on the right side once you hover your mouse over the entry as shown below:

trash.png.bbaebed9240f5a852da332be14d416f2.png

If you do not see it, it may be due to your screen resolution or an issue with the UI.  I do know that recently it was reported that the icons on the right side appear cut off when a scrollbar is visible on the right side (which appears when there are a large number of entries) so it may not be completely visible.

Link to post

Thank you.  See the attached image of my allow list.  The length of the first entry is so long, the trash icon is not accessible.  It is too far to the right, and there is no left/right scroll bar.  The other entries are affected by the first one.  No trash icon exists.  Also, the column header of the allow list has no trash icon to remove all.

I cannot enlarge the entire box itself.  I probably can and will remove the entire extension and start over.  The design of the allow list should be upgraded to solve this problem.

Malwarebytes Browser Guard Allow List.png

Link to post

i think that manually adding a "long" URL to the whitelist caused a problem, the "long" URL for downloading the "glance" file.

i had the same problem after manually adding a long URL to the whitelist, where i couldn't remove it from the whitelist.

i resolved the problem by uninstalling the MBG extension and then reinstalling it.

 

Link to post

Yes, the longer length of the entry appears to be the cause of the issue.  They will need to truncate such entries, implement a scrollbar, or make some other tweaks to how the UI functions to prevent this issue in the future.

Link to post

If you reinstall it your allow list should now be empty so that you can add only the addresses you wish to keep there that way you can avoid missing out on its protection while awaiting the new version.

Link to post

I have just encountered the same issue. 

I tried to download the Amazon Kindle reader for PC and Browser Guard blocked the download as suspicious - so ticked the box to over-ride and it added the whole download URL string including the filename - http…amazonaws.com/kindleforpc/55076/kindleforpc-installer-1.26.55076.exe

As noted the GUI doesn't cope with such a long entry and you can no longer see either of the two delete options (Remove All or the Trashcan icon) 

Link to post
16 minutes ago, DougCuk said:

http…amazonaws.com/kindleforpc/55076/kindleforpc-installer-1.26.55076.exe

@gonzo can you review this for whitelisting.

Link to post
5 hours ago, DougCuk said:

I have just encountered the same issue. 

I tried to download the Amazon Kindle reader for PC and Browser Guard blocked the download as suspicious - so ticked the box to over-ride and it added the whole download URL string including the filename - http…amazonaws.com/kindleforpc/55076/kindleforpc-installer-1.26.55076.exe

As noted the GUI doesn't cope with such a long entry and you can no longer see either of the two delete options (Remove All or the Trashcan icon) 

To avoid this issue in the future in scenarios like this where you just need to access a one-time download, if you click the link to continue to the site without checking the box it won't be added to your allow list but you will be able to access the website/download that was blocked immediately.  Of course another option would be to temporarily disable Malwarebytes Browser Guard for the current webpage using the switches available in its menu when you click the icon.

In fact, I just checked, and even when a site is in the allow list you can use the switches available in the main menu to remove it from the allow list without having to view the allow list tab; just use the controls shown below and make sure they are all set to on for the site you wish to remove from the allow list (you'll have to be viewing the allowed site at the time/in the current browser tab):

Options.png.c11a5ac8ddae4075190beceef13156e9.png

Edited by exile360
Link to post

I had to resort to uninstall and reinstall to regain the Allow List editing icons. 
Unfortunately this particular case doesn't allow you to use the sliders to reverse the Allow List addition. This is because the entry is the actual download link - which doesn't display a web-page, it just triggers the download. Also for this download you can't complete the download without ticking the box to add to Allow List.

Unless you tick the box to add the Allow List entry you get stuck in a loop - with two repeating warnings - the first one for the full download link itself - and if you override that you get the second warning for the domain url (s3.amazonaws.com). The only way out is to tick the box to add to the Allow List. One plus is that if you tick the box on the second warning (domain url) then the entry in the Allow List is a normal length and the editing icons display as normal.

You can test this by using the PC & Mac Download button on this page  https://www.amazon.co.uk/kindle-dbs/fd/kcp

The s3.amazonaws.com  domain needs white-listing. 

Browser Guard.PNG

Browser Guard_Download.PNG

Link to post
  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.