Jump to content
TopTierIT

{Confirmed} Malwarebytes not compatible with Processor SQ1 ARM Chipset

Recommended Posts

I recently purchased a Surface Pro X 16GB Ram and 512GB SSD with the Microsoft SQ1 Processor and ARM Chipset. I was installing Malwarebytes Endpoint Protection Enterprise and through the course of updates I would need to reboot my computer as required. In this first instance I just changed the computer name. This is when, upon reboot, I would get the "Performing Automatic Repair"  and "Diagnosing your PC" windows followed by the blue Automatic Repair menu stating to Restart and Advanced Options. 

Clicking restart cycled back through and all Advanced Options did not work, even booting to safe mode or continue to Windows 10. These options would inevitably result in a Windows logo on the screen and that was it.

Had to do a factory reset after the first attempt. After this reset, not knowing the issue, I started again, this time changing computer name first, as this was the last thing I did previously. Booted fine. So I installed all of my software at that point and left Office 365 installing while I went to bed. This morning I got up and it was back at the Automatic Repair menu with the same 2 options. I was fed up. I called Microsoft support to file a exchange (just got this) but they were closed. 

Long story short, I came back in the house and did a third factory reset. While setting up the computer for the first time again, I changed the computer name first, rebooted, and then installed all updates needed up to the latest 1909 Windows 10 build. I installed one software component and then created a restore point and rebooted. All is well. Downloaded Malwarebytes Endpoint Protection from Oneview and was installing it when I got connected to a Microsoft support agent. I explained what I had done and what it was doing and that I have tried everything I knew as I have been in IT for over 30 years. 

As we were talking, I realized I didn't have Windows 10 Pro, so I went to the online store and bought it. I clicked install and then it rebooted. Guess what? Yep, same Automatic Repair menu. BUT this time I had the Microsoft Rep on the phone. Of course he tried to do what I had already done and I explained to him that it was either Malwarebytes or coincidentally the Win 10 Pro conversion. Now mind you, I hadn't rebooted after the Malwarebytes install.

Longer story short, he grabbed a Surface Pro X and duplicated the issue, twice. He factory reset after the first one and installed the consumer version of MBAM again with same results.

He stated that it is up to Malwarebytes to create an ARM version. Or at least to save headaches, add a warning on install if an ARM chipset is used to abort or stop the installation.

Just my 2 cents and 3 hours on a support call.

Share this post


Link to post
Share on other sites

Greetings,

Thank you for reporting this issue.  I am sorry that you experienced so much trouble.  I will be sure to report your feedback to the Product team for consideration and hopefully ARM detection will be added to the installer stub to prevent this kind of issue in the future.

If there is anything else we might assist you with please let us know.

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.