Jump to content
CW58

MWB scan hangs but timer advances

Recommended Posts

I was sent here from https://   forums.malwarebytes.com/topic/254035-mwb-scan-hangs after they could not figure out the problem and thought you'd be interested.

I am experienced with computers and do not believe I have a malware problem but it is curious MWB scan hangs during the file scan phase although the timer advances.

You can see various things have been tried, cleanups done, etc. but there is still a problem with the scan.

Anyone care to try to figure this out?

 

Share this post


Link to post
Share on other sites

***This is an automated reply***

Hi,

Thanks for posting in the Malwarebytes for Windows Help forum.

 

If you are having technical issues with our Windows product, please do the following: 

Spoiler

If you haven’t already done so, please run the Malwarebytes Support Tool and then attach the logs in your next reply:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  1. Download Malwarebytes Support Tool
  2. Once the file is downloaded, open your Downloads folder/location of the downloaded file
  3. Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  4. Place a checkmark next to Accept License Agreement and click Next
  5. You will be presented with a page stating, "Get Started!"
  6. Click the Advanced tab on the left column

    mbst_get_started.jpg
     
  7. Click the Gather Logs button

    mbst_advanced_gather_logs.jpg
     
  8. A progress bar will appear and the program will proceed with getting logs from your computer

    mbst_getting_logs.jpg
     
  9. Upon completion, a file named mbst-grab-results.zip will be found on your Desktop. Click OK

    mbst_log_saved_desktop.jpg
     
  10. Please attach the file in your next reply. Before submitting your reply, be sure to enable "Notify me of replies" like so:

     notify me.jpeg  

Click "Reveal Hidden Contents" below for details on how to attach a file:
 

Spoiler

To save attachments, please click the link as shown below. You can click and drag the files to this bar or you can click the choose files, then browse to where your files are located, select them and click the Open button.

mb_attach.jpg.220985d559e943927cbe3c078b
 

One of our experts will be able to assist you shortly.

 

If you are having licensing issues, please do the following: 

Spoiler

For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/community/consumer/pages/contact-us to get help

If you need help looking up your license details, please head here: https://support.malwarebytes.com/docs/DOC-1264 

 

Thanks in advance for your patience.

-The Malwarebytes Forum Team

 

Share this post


Link to post
Share on other sites
9 minutes ago, CW58 said:

Here are the logs from a fresh run of the program.

Please update MB. Then restart and try again. Also are you running a regular or a custom scan?

 

MB Manual Update.png

Share this post


Link to post
Share on other sites

The regular Big Blue Button scan on the main screen of MWB free.

Initiated Update. It hung (ran way too long). Killed it and rebooted. Did update. Completed in seconds.

Ran scan.  AGAIN stuck on Scanning the file system this time on item 219,360.  It's been on that number for several minutes. Cancelled it. 

 

 

Share this post


Link to post
Share on other sites
1 hour ago, CW58 said:

Ran scan.  AGAIN stuck on Scanning the file system this time on item 219,360.  It's been on that number for several minutes. Cancelled it. 

Lets ask @AdvancedSetup to look it over.

Share this post


Link to post
Share on other sites

Sorry. I'm not sure what you mean. Should *I* click the @AS link and start a new thread there?

Share this post


Link to post
Share on other sites
1 hour ago, CW58 said:

Sorry. I'm not sure what you mean. Should *I* click the @AS link and start a new thread there?

No, Me posting like that told that member to see this topic.

Share this post


Link to post
Share on other sites

Hello @CW58

Sorry to hear you're having issues with the scanning. Let's try doing a Repair and see if that helps or not. We are tracking a few users with what appears to be a similar issue but we need to confirm some items first.

https://support.malwarebytes.com/docs/DOC-2395

Give that a try and let me know if it corrects the issue or not.

Thanks

 

Share this post


Link to post
Share on other sites
On 12/4/2019 at 3:01 PM, AdvancedSetup said:

Sorry to hear you're having issues with the scanning. Let's try doing a Repair and see if that helps or not. We are tracking a few users with what appears to be a similar issue but we need to confirm some items first.

https://support.malwarebytes.com/docs/DOC-2395

Give that a try and let me know if it corrects the issue or not.

-------------

Ran repair. Rebooted. Ran scan. Stuck again on scanning file system.

 

 

MWB stuck 12_09_2019 19_33_13.jpg

Share this post


Link to post
Share on other sites

I'm sorry @CW58 but I don't currently have an answer for this issue. I know that our QA department is reviewing it but so far there is no concrete information telling us what is causing this.

Temporarily you can revert back to the 3.8.3 version until our team is able to find a resolution for this.

Constant upgrade notifications in Malwarebytes for Windows v3
https://support.malwarebytes.com/docs/DOC-2465

Turn off upgrade notifications in Malwarebytes for Windows v3
https://support.malwarebytes.com/docs/DOC-2142

https://downloads.malwarebytes.com/file/mb3-windows-legacy

 

Share this post


Link to post
Share on other sites

Hello @CW58

From you logs it is confirmed that scans gets stuck towards the end , but the reason is still not very clear.

A memory dump will be help file to give us more clues.

1. Run a threat scan (Big blue button)

2. When the scan gets stuck go to task manager and generate a dump for the Malwarebytes App.

image.png.00222775df6eee2e2b460ca8a3c8c418.png

 

We can dig into this further from the memory dump.

Share this post


Link to post
Share on other sites
19 minutes ago, nikhils said:

Hello @CW58

From you logs it is confirmed that scans gets stuck towards the end , but the reason is still not very clear.

A memory dump will be help file to give us more clues.

1. Run a threat scan (Big blue button)

2. When the scan gets stuck go to task manager and generate a dump for the Malwarebytes App.

We can dig into this further from the memory dump.

I was just about to uninstall MWB 4 and be done with it but I'm curious so here is the mbam.dmp file.

https://we.tl/t-hJJnbNYak7

Share this post


Link to post
Share on other sites

Hi @CW58

We have released a new CU2 beta update that does address several issues. Can you please temporarily disable all other security software. If you have Malwarebytes 3.x installed please uninstall it and reboot.

Then download and install Malwarebytes 4 and set it to download beta versions. Then check for updates, it should update, then reboot the computer and try a scan and let me know if that corrects the issue or not.

image.png

 

After the update you should have the following or newer updates.

 

image.png

 

Thank you

 

 

Share this post


Link to post
Share on other sites

I was going to try but the Beta option is for Premium only. Grayed out in the free version. Sorry.

Share this post


Link to post
Share on other sites

Thanks @CW58

I've relayed this to our team. Also waiting to hear back from others if this fixes the issue for them or not. If so then we'll have to see about getting a download link for the new beta.

Please stay tuned

 

Share this post


Link to post
Share on other sites

Hello @CW58

The dump file we generated is actually only for the mbam.exe. We actually need a memory dump for mbamservice.exe

I am going to send you a Private message with detailed instructions on how to get the dumps.

Thank you for helping us with the issue.

Share this post


Link to post
Share on other sites
On 1/17/2020 at 5:18 PM, AdvancedSetup said:

Hello @CW58

I'm following up to see if version 4 of Malwarebytes is working well for you now or not.

 

Ah yes. Hi. I've not touched it since you told me a fix was in the works. I was waiting.

I just ran a scan while connected to the internet and it did update and scan and complete normally with no problems found so it seems to  be working for me.

FYI, I'm still using the DLL you sent but it didn't work before when it was updated but now it does.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.