Jump to content
naufy995

Proxy settings keep reverting back

Recommended Posts

Hi everyone,

I hope this post finds you well.

I currently have an issue in my Windows 10 PC where my proxy settings keep changing to 127.0.0.1:8080. Every time I change it, it reverts back. I have to manually enter regedit and change the settings there in order to turn it off. Even then, it reverts back every time I restart my computer. 

This is a problem because with the proxy on I cannot use Google Chrome (Picture 1). There have also been other suspicious findings like the proxy settings being greyed out (Picture 2) and every time I turn "Off" proxy settings under Windows proxy settings it revert back to "On" when i reopen the settings page (Picture 3). 

I have run Malwarebytes multiple times to no avail. 

Logs attached. 

Any help would be appreciated.

Thank you.

1172776419_Picture1.PNG.b967ff33461da9dda67e032373e1b622.PNG

Picture 2.PNG

Picture 3.PNG

Addition.txt FRST.txt MalwarebytesScan.txt

Share this post


Link to post
Share on other sites

Hello, Welcome to Malwarebytes.
I'm nasdaq and will be helping you.

If you can please print this topic it will make it easier for you to follow the instructions and complete all of the necessary steps in the order listed.
===

Please download the attached Fixlist.txt file to  the same folder where the Farbar tool is running from.
The location is listed in the 3rd line of the FRST.txt log you have submitted.

Run FRST and click Fix only once and wait.

The Computer will restart when the fix is completed.

It will create a log (Fixlog.txt) please post it to your reply.
===

Please post the Fixlog.txt and let me know what problem persists.

fixlist.txt

Share this post


Link to post
Share on other sites

Hi nasdaq,

Thank you for your prompt reply. 

I have carried out your suggestions. Fixlog.txt attached.

Unfortunately after the restart, as I start Google Chrome, the same problem persists. Proxy is still turned on to 127.0.0.1:8080 and I have to manually change settings in regedit in order to turn it off. 

Any further suggestions would be welcome. 

Thank you. 

 

Fixlog.txt

Share this post


Link to post
Share on other sites

Hi,

If the problem persists and Chrome is Synced with other Devices check this out.

https://forums.malwarebytes.com/topic/214325-chrome-secure-preferences-detection-always-comes-back/

Execute the suggested fix.

Restart the computer normally.
===========

If the problem persists.

Your copy of Chrome may have been compromised

Remove and re-install Chrome. Follow these instructions.


step1.gif Remove Chrome from your Computer and reinstall a fresh copy later.

step2.gifIf you remove the syncing of your account you must remove it before you save your bookmarks etc...
Delete Your Google Chrome Browser Sync Data if you sync with other devices. <- Important ...
https://forums.malwarebytes.com/topic/214325-chrome-secure-preferences-detection-always-comes-back/

step3.gif Before you remove Chrome Export your Bookmarks
Chrome will export your bookmarks as a HTML file, which you can then import into another browser.
How To: http://ccm.net/faq/31791-how-to-backup-your-google-chrome-bookmarks

step4.gif Before you remove Chrome Export your Passwords
How to export your saved passwords from Chrome
https://www.google.com/search?q=chrome+export+password&oq=chrome+export+password&aqs=chrome..69i57j69i60l2.7991j0j7&sourceid=chrome&ie=UTF-8

step5.gif Clear your Chrome cache and cookies
https://support.google.com/chromebook/answer/183083?hl=en

step6.gif Remove Chrome using the the instructions on this page.
https://support.google.com/chrome/answer/95319?hl=en

step7.gif Re-install Chrome and the Bookmarks.
<<<>>

Keep me posted.

 

Share this post


Link to post
Share on other sites

Hi nasdaq,

Thank you once again for the prompt reply.

I have carried out your instructions carefully and meticulously. 

During the process, Malwarebytes and Adwcleaner detected no threats (so far so good). 

However, the problem remains. Upon restart, when launching Microsoft Edge browser (in order to re-download Google Chrome), this page shows up (Picture 1), which means the proxy settings have reverted back again. Once again, I have to go into Registry Editor and change my proxy settings.

Any further advice would be appreciated. Sorry for the inconvenience. 

Thank you.

428456419_Picture4.thumb.PNG.47e385471fb064c176adf2d0cedb045f.PNG

Share this post


Link to post
Share on other sites

Hi,

I have tried that, but every time I remove the proxy it comes back on again. For example:

1. I turn proxy settings off

2. I close the window

3. When I go to proxy settings again, I find that the proxy settings are back on again. (i.e. I cannot turn it off through the methods described by you)

And no, it is not synced to other devices. 

Share this post


Link to post
Share on other sites

Hi,

Do you click OK before closing the Window?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.