Jump to content

Malwarebytes cannot contact license activation servers

Recommended Posts


I was using MB 3.83 Premium on Windows 10 Pro 64-bit for several months now. A few days ago I saw that it has reverted to the Free version. Surprised I opened Malwarebytes and tried to activate my license. But Malwarebytes displays the error message:


Unable to contact update server. Please check your Internet connection.

But my internet connection is fully working. I don't have any problem with it.

I then installed the newest version 4.04 but after the PC rebooted I got the same result. MBAM is unable to contact the update server.

When I look at the process mbam.exe using Sysinternals Process Explorer I can see in the task properties that mbam.exe doesn't even try to access the network.

I have then looked at the log file C:\ProgramData\Malwarebytes\MBAMService\logs\MBAMSERVICE.LOG and there I find several lines with:


11/12/19    " 13:22:46.998"    4141078    2bd0    12d0    WARNING    HttpConnection    mb::common::net::HttpConnection::LogExceptionDetails    "httpconnection.cpp"    1736    "Exception details: text=DNS error: Non recoverable DNS error while resolving: telemetry.malwarebytes.com"
11/12/19    " 13:22:46.998"    4141078    2bd0    12d0    WARNING    TelemCtrlImpl    TelemetryControllerImpl::SendTelemetryRecord    "telemetrycontrollerimplhelper.cpp"    2048    "Problem sending JSON data to DSE stream [errors] - server returned: -9"
11/12/19    " 13:22:47.353"    4141421    2bd0    14e4    WARNING    HttpConnection    mb::common::net::HttpConnection::SendRequest    "httpconnection.cpp"    393    "Network error."
11/12/19    " 13:22:47.353"    4141421    2bd0    14e4    WARNING    HttpConnection    mb::common::net::HttpConnection::LogExceptionDetails    "httpconnection.cpp"    1736    "Exception details: text=DNS error: Non recoverable DNS error while resolving: blitz.mb-cosmos.com"
11/12/19    " 13:22:47.353"    4141421    2bd0    14e4    ERROR    CloudCtrlImpl    CloudControllerImplHelper::GetAuthenticatedURLForBytesTotalUpload    "cloudcontrollerimplhelper.cpp"    5439    "Error code -9 returned in POST to Cosmos"
11/12/19    " 13:22:47.460"    4141531    2bd0    12d0    WARNING    HttpConnection    mb::common::net::HttpConnection::SendRequest    "httpconnection.cpp"    393    "Network error."
11/12/19    " 13:22:47.460"    4141531    2bd0    12d0    WARNING    HttpConnection    mb::common::net::HttpConnection::LogExceptionDetails    "httpconnection.cpp"    1736    "Exception details: text=DNS error: Non recoverable DNS error while resolving: telemetry.malwarebytes.com"
11/12/19    " 13:22:47.460"    4141531    2bd0    12d0    WARNING    TelemCtrlImpl    TelemetryControllerImpl::SendTelemetryRecord    "telemetrycontrollerimplhelper.cpp"    2048    "Problem sending JSON data to DSE stream [errors] - server returned: -9"
11/12/19    " 13:22:48.350"    4142421    2bd0    14e4    WARNING    HttpConnection    mb::common::net::HttpConnection::SendRequest    "httpconnection.cpp"    393    "Network error."
11/12/19    " 13:22:48.350"    4142421    2bd0    14e4    WARNING    HttpConnection    mb::common::net::HttpConnection::LogExceptionDetails    "httpconnection.cpp"    1736    "Exception details: text=DNS error: Non recoverable DNS error while resolving: blitz.mb-cosmos.com"
11/12/19    " 13:22:48.350"    4142421    2bd0    14e4    ERROR    CloudCtrlImpl    CloudControllerImplHelper::GetAuthenticatedURLForBytesTotalUpload    "cloudcontrollerimplhelper.cpp"    5439    "Error code -9 returned in POST to Cosmos"

Looks like a DNS proplem. But my PC is able to resolve all the mentioned names without any problem.

What problem does Malwarebytes have?

I have ProxyCap (version 5.36) installed. And when I look at the process mbamservice.exe using Process Monitor I found that it tries to access the file pcapwsp.dll which is part of ProxyCap. Is there again some compatibility problem between ProxyCap and Malwarebytes? I thought that was solved with version 3.83. And I have another PC where both ProxyCap and Malwarebytes are installed and both are working.
I have attached the logs gathered with MB support tool.
Maybe you can find the cause of the problem.




Link to post
Share on other sites

  • Staff

***This is an automated reply***


Thanks for posting in the Malwarebytes for Windows Help forum.


If you are having technical issues with our Windows product, please do the following: 


If you haven’t already done so, please run the Malwarebytes Support Tool and then attach the logs in your next reply:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  1. Download Malwarebytes Support Tool
  2. Once the file is downloaded, open your Downloads folder/location of the downloaded file
  3. Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  4. Place a checkmark next to Accept License Agreement and click Next
  5. You will be presented with a page stating, "Get Started!"
  6. Click the Advanced tab on the left column

  7. Click the Gather Logs button

  8. A progress bar will appear and the program will proceed with getting logs from your computer

  9. Upon completion, a file named mbst-grab-results.zip will be found on your Desktop. Click OK

  10. Please attach the file in your next reply. Before submitting your reply, be sure to enable "Notify me of replies" like so:

     notify me.jpeg  

Click "Reveal Hidden Contents" below for details on how to attach a file:


To save attachments, please click the link as shown below. You can click and drag the files to this bar or you can click the choose files, then browse to where your files are located, select them and click the Open button.


One of our experts will be able to assist you shortly.


If you are having licensing issues, please do the following: 


For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/community/consumer/pages/contact-us to get help

If you need help looking up your license details, please head here: https://support.malwarebytes.com/docs/DOC-1264 


Thanks in advance for your patience.

-The Malwarebytes Forum Team


Link to post
Share on other sites


I noticed that AdGuard appears to be installed and wondered if perhaps it wasn't blocking Malwarebytes somehow.  Please try temporarily disabling AdGuard or making an exception in it for Malwarebytes' processes to see if that makes any difference.  As far as ProxyCap is concerned, I'm not aware of any issues however that doesn't mean that such issues don't exist; it could simply be that it isn't used too commonly and so issues with it have not yet been reported.  If troubleshooting AdGuard doesn't help then it's worth a try to see if disabling ProxyCap makes any difference.

If it still doesn't work then please try a clean install to see if that makes any difference:

  1. Run the Malwarebytes Support Tool
  2. Accept the EULA and click Advanced tab on the left (not Start Repair)
  3. Click the Clean button, and allow it to restart your system and then reinstall Malwarebytes, either by allowing the tool to do so when it offers to on restart, or by downloading and installing the latest version from here

Please let us know how it goes and if you are able to determine what the cause of the issue is.


Link to post
Share on other sites


I have now disabled AdGuard and ProxyCap. But there is no change; MBAMService is still not able to resolve names.

Then I used your MB-Support tool to clean Malwarebyte and then reinstall the latest version. This solved the problem. MBAM is now Premium.

Before I did this I browsed through all the MBAMSERVICE.LOG.bkx files to find out when this problem first appeared. It appeared first on 21.8.2019 right after I installed Windows 10 1903 upgrade. I have no idea why the Windows 10 update did break DNS resolution only for MBAMService. I never had any problem with DNS resolution in any other application which is installed.

I only wonder why MBAM did not tell me that there is a problem. I still would run MBAM Free if I had not checked manually.

Anyway thanks for your support.

Link to post
Share on other sites

Yes, that is strange.  Perhaps the update messed with the default firewall rules/configuration somehow, resulting in broken connectivity for Malwarebytes.

With regards to Malwarebytes notifying you, I'm not sure.  It is generally supposed to display an error message explicitly stating that it was unable to contact the license server for license checkins and that it was unable to reach the update servers for update checks.  I'll be sure to report this incident to the Product team so that they may investigate and hopefully improve the default behavior in the future.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.