Jump to content

MBAM 4 doesn't work on a Surface Pro 4


Recommended Posts

  • Replies 69
  • Created
  • Last Reply

Top Posters In This Topic

8 hours ago, AdvancedSetup said:

We're hoping to have an update within the next couple of weeks that you'll be able to try

 

In the meantime, MB4 removal (in order to downgrade to MB3) failed. Now MB4 is still in my computer, completely useless and non removable anymore!

I have no words anymore...

Capt111ure.png

Link to post
Share on other sites

  • Staff

Please try uninstalling Malwarebytes in Safe Mode.  If that still fails, please try using the Malwarebytes Support Tool to perform a clean uninstall:

  1. Download and run the Malwarebytes Support Tool
  2. Accept the EULA and click Advanced tab on the left (not Start Repair)
  3. Click the Clean button, and allow it to restart your system and then reinstall Malwarebytes, either by allowing the tool to do so when it offers to on restart, or by downloading and installing the latest version from here or you can install Malwarebytes 3 if you wish.

If that still fails you can try the same clean process with the Support Tool in Safe Mode to see if that resolves the issue.

Edited by exile360
Link to post
Share on other sites

7 hours ago, exile360 said:

Please try uninstalling Malwarebytes in Safe Mode.  If that still fails, please try using the Malwarebytes Support Tool to perform a clean uninstall:

  1. Download and run the Malwarebytes Support Tool
  2. Accept the EULA and click Advanced tab on the left (not Start Repair)
  3. Click the Clean button, and allow it to restart your system and then reinstall Malwarebytes, either by allowing the tool to do so when it offers to on restart, or by downloading and installing the latest version from here or you can install Malwarebytes 3 if you wish.

If that still fails you can try the same clean process with the Support Tool in Safe Mode to see if that resolves the issue.

Would be nicer of you sending me a link to the official MB3 executable.

Link to post
Share on other sites

  • Staff
5 hours ago, Jimmaki said:

Would be nicer of you sending me a link to the official MB3 executable.

I haven't got one unfortunately.  The only one I know of is the 'legacy' version for Windows XP and Windows Vista which is badly out of date as it is many versions behind.  I am not sure where they have the download for the most recent 3.x build, however I do seem to recall a member of the staff posting it somewhere, though I was unable to locate it.

Link to post
Share on other sites

7 minutes ago, exile360 said:

though I was unable to locate it.

Use the support tool  to uninstall and after the restart click NO when it asks to install the current version.

The current KB articles will help you to set version 3.x from updating to 4.x for now

Constant upgrade notifications in Malwarebytes for Windows v3
https://support.malwarebytes.com/docs/DOC-2465

Turn off upgrade notifications in Malwarebytes for Windows v3
https://support.malwarebytes.com/docs/DOC-2142

MB3.x download link
mb3-setup-consumer-3.8.3.2965-1.0.629-1.0.13137

This will install 3.8.3

Link to post
Share on other sites

6 hours ago, Porthos said:

Use the support tool  to uninstall and after the restart click NO when it asks to install the current version.

The current KB articles will help you to set version 3.x from updating to 4.x for now

Constant upgrade notifications in Malwarebytes for Windows v3
https://support.malwarebytes.com/docs/DOC-2465

Turn off upgrade notifications in Malwarebytes for Windows v3
https://support.malwarebytes.com/docs/DOC-2142

MB3.x download link
mb3-setup-consumer-3.8.3.2965-1.0.629-1.0.13137

This will install 3.8.3

I think it's a better idea to cancel my subscription, request a refund and repurchase MB4 when it's gonna be ready for use.

Don't know how long is gonna take you to fix it but in the meantime, doesn't worth to spend my subscription for something I don't have.

Hope you understand

Link to post
Share on other sites

On 1/8/2020 at 12:56 AM, Porthos said:

I understand as well. Did you have any issues before Version 4?

I posted the link for Version 3.

Nope! None! Never!
It used to work as expected and I was very satisfied.
I never had this particular machine infected as I'm pretty aware of dangerous products on the web.
I'm very happy with winDef and I needed some extra protection, just in case.

Link to post
Share on other sites

On 1/8/2020 at 12:45 AM, AdvancedSetup said:

No problem, we fully understand and appreciate your efforts.

Thank you

 

Well, I decided to be patient and give it one more month and see how it goes.
I have a question for you though. Is this issue present in all Surface Pro 4 machines or is it only in my computer?

Link to post
Share on other sites

16 hours ago, Jimmaki said:

I have a question for you though. Is this issue present in all Surface Pro 4 machines or is it only in my computer?

I have it installed on at least 20 Surface Pro 4 computer and have no issues using MB4.  The second AV I have installed along side MB4 is Symantec Endpoint Protection. I have not read your entire thread or looked at your log files, I was just simply answering your question is all.

Link to post
Share on other sites

  • Root Admin

I know that we were unable to locate the initial issue on your system @Jimmaki but we now have multiple users on our Helpdesk that were having issues with the previous builds say the latest version is now working for them.

I would recommend you grab the offline installer if you're not currently running MB4 anymore. Record your license information then uninstall MB3 and reboot. Then install  MB4 and check for updates first. Then activate after you get the latest updates.

https://downloads.malwarebytes.com/file/mb4_offline

Thanks

 

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    No registered users viewing this page.


Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.