Jump to content
Jimmaki

MBAM 4 doesn't work on a Surface Pro 4

Recommended Posts

MBAM 4 just installed on a Surface Pro 4 machine and it takes longer than 15 mins searching for updates.

Do I have to completely wipe it from the system and reinstall it?

Share this post


Link to post
Share on other sites

***This is an automated reply***

Hi,

Thanks for posting in the Malwarebytes for Windows Help forum.

 

If you are having technical issues with our Windows product, please do the following: 

Spoiler

If you haven’t already done so, please run the Malwarebytes Support Tool and then attach the logs in your next reply:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  1. Download Malwarebytes Support Tool
  2. Once the file is downloaded, open your Downloads folder/location of the downloaded file
  3. Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  4. Place a checkmark next to Accept License Agreement and click Next
  5. You will be presented with a page stating, "Get Started!"
  6. Click the Advanced tab on the left column

    mbst_get_started.jpg
     
  7. Click the Gather Logs button

    mbst_advanced_gather_logs.jpg
     
  8. A progress bar will appear and the program will proceed with getting logs from your computer

    mbst_getting_logs.jpg
     
  9. Upon completion, a file named mbst-grab-results.zip will be found on your Desktop. Click OK

    mbst_log_saved_desktop.jpg
     
  10. Please attach the file in your next reply. Before submitting your reply, be sure to enable "Notify me of replies" like so:

     notify me.jpeg  

Click "Reveal Hidden Contents" below for details on how to attach a file:
 

Spoiler

To save attachments, please click the link as shown below. You can click and drag the files to this bar or you can click the choose files, then browse to where your files are located, select them and click the Open button.

mb_attach.jpg.220985d559e943927cbe3c078b
 

One of our experts will be able to assist you shortly.

 

If you are having licensing issues, please do the following: 

Spoiler

For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/community/consumer/pages/contact-us to get help

If you need help looking up your license details, please head here: https://support.malwarebytes.com/docs/DOC-1264 

 

Thanks in advance for your patience.

-The Malwarebytes Forum Team

 

Share this post


Link to post
Share on other sites

HI @Jimmaki,

Could you restart the machine and check if the issue persists.

If it does, please carry out the "technical issue" instructions the post #2 and attach the generated report.

Thank you!

Share this post


Link to post
Share on other sites
55 minutes ago, LiquidTension said:

To clarify, the issue is now resolved? Was it the action of restarting that resolved it?

The automated reply solution made the application functional again however, the application is far from considered as useful.

 

1. All scans after 45 mins still run...

2. The application appears to be heavy and consumes a lot of my CPU.

3. Ever since I upgraded to MBAM4 my PC feels glitchy and slow.

 

I seriously think of moving back to MBAM3.

Share this post


Link to post
Share on other sites

Hi @Jimmaki,

Thanks for the logs. There's not enough data there to determine the cause of this. We'll need to collect some additional data.

  • Does this consistently occur with every scan?
  • What type of scan are you running? Is this a scheduled or manual scan?


Please start with the following:

  • Open Malwarebytes.
  • Click Settings.
  • Turn the Event log data setting on.


Afterwards, please do the following. This will help us obtain a memory dump captured when Malwarebytes is in the hung state.

  • Please download run_procdump.bat using the link below.
    https://malwarebytes.box.com/s/e127cj2ppb2lq6njf67li2gls3kbfz24
  • Open your Downloads folder.
  • Double-click CX41PDv.png run_procdump.bat. Click Yes if prompted by AVOiBNU.jpg User Account Control.
  • Note: If you are prompted by Windows SmartScreen, click More info followed by Run anyway.
  • A blue window will appear.
  • When prompted to reboot, type Y into the window and press Enter on your keyboard.
  • After your computer has rebooted, please do the following:
    • Reproduce the scan hanging on checking for updates.
  • Once done, open your Downloads folder and double-click the run_procdump.bat file once more.
  • Upon completion, a file named HSPwQfy.png memorydump.zip will be saved to your Desktop. Please attach the file in your next reply.
  • Note: If the file is too large, you will be provided instructions to upload the file to a file hosting website (wetransfer.com).


Finally, please rerun log gathering with the Malwarebytes Support Tool and attach the generated mbst-grab-results.zip:
https://support.malwarebytes.com/docs/DOC-2396

Share this post


Link to post
Share on other sites

Hey @LiquidTension

  • Does this consistently occur with every scan? YES
  • What type of scan are you running? Is this a scheduled or manual scan? ANY
  • Double-click CX41PDv.png run_procdump.bat. Click Yes if prompted by AVOiBNU.jpg User Account Control.
  • When prompted to reboot, type Y into the window and press Enter on your keyboard. NEVER HAPPENED
    • Reproduce the scan hanging on checking for updates. NEVER ENDS (see screenShot attached)
  • Upon completion, a file named HSPwQfy.png memorydump.zip will be saved to your Desktop. NEVER HAPPENED
  • Finally, please rerun log gathering with the Malwarebytes Support Tool and attach the generated mbst-grab-results. SUPPORT  TOOL DOESN'T WORK (unless is run after a reboot...)

 

 

Annotation 2019-11-12 083404.png

procdump-log.txt

Share this post


Link to post
Share on other sites

Hi everyone

I'm still struggling with a pointless purchase and a PC... 

I have created a topic and after so many days I'm still struggling to use a once upon a time very healthy machine.

Please, advise next action because I'm thinking of:

  • performing an aggressive cleanup (MBAM4 not uninstallable???) or
  • reverting back to MBAM3 (is this gonna work?) or
  • even ask for a refund...

Whatever the final decision will be, I hope I'm gonna bring my system back in its once upon a time healthy state.

P/s: I've noticed that my installation is a 32-bit whilst my machine is (obviously) on 64-bit.

I created this topic because I have a feeling you ignore me

Share this post


Link to post
Share on other sites

Hello,

Sorry for the delay. The issue you're experiencing isn't currently reproducible and nothing is standing out in the logs provided so far.

When you attempted to generate the memory dump by running the batch file, was Malwarebytes already in the hung state? Note that the batch files needs to be run when Malwarebytes is fully functional and not hanging. It will then prompt you to reboot. After the reboot is when you must reproduce the hang and then run the batch file a second time.

To help determine the cause of the hang, we ultimately need the memory dump and fresh logs from Malwarebytes Support Tool. If you encounter the issue again with generating, let me know and I'll provide some alternative steps in private.

-----

Could you try performing a clean boot: https://support.microsoft.com/en-gb/help/929135/how-to-perform-a-clean-boot-in-windows
When configuring it, ensure Malwarebytes Service is left checked/enabled. Afterwards, confirm if the scan still hangs during the update check. This will help determine if the issue is environmental or not.

Share this post


Link to post
Share on other sites

Hello @Jimmaki

The following steps may help with the slow or hanging update process. If the actual scan is taking over an hour then the modifications below probably will not help with that but we can try.

Can you please temporarily change your DNS server to the Google Public DNS settings? Please make sure you have a valid, new System Restore Point before making any changes. If you've not done so already you should also have a full backup of your system just in case something were to go wrong either while dealing with software configs, malware threats, or even hardware failures.
https://developers.google.com/speed/public-dns

 

 

Are you doing Java programming? (looking at the logs it looks like you probably are or are at least using it heavily) You have an old, compromised version of the code on the system.. If you're not doing Java program that requires an older version I would highly recommend that you uninstall all Java. If you can do without Java that would be best, if not then make sure you're using the latest version at all times. Again, if you need this version for work then do not uninstall it, but research it first as old code can help make it easier to infect your system.

Java SE Development Kit 8 Update 131 (64-bit) (HKLM\...\{64A3A4F4-B792-11D6-A78A-00B0D0180131}) (Version: 8.0.1310.11 - Oracle Corporation)
Java SE Development Kit 8 Update 131 (HKLM-x32\...\{32A3A4F4-B792-11D6-A78A-00B0D0180131}) (Version: 8.0.1310.11 - Oracle Corporation)

 

Nothing wrong with this as long as you're aware of it and have set it up on purpose. If you're not aware or did not set it up then you may want to look at disabling it.

2018-07-04 16:46 - 2019-11-12 09:03 - 000000437 _____ C:\WINDOWS\system32\drivers\etc\hosts.ics
172.18.73.97 JSp4.mshome.net # 2024 11 6 9 22 3 59 915

 

You're also stopping quite a bit of programs with Task Manager. Personally I would recommend that if you're not using something consider uninstalling it or looking at using AutoRuns as a startup manager.  That way your Task Manager / MSCONFIG can be used for Diagnostics as intended. As it is now it cannot easily be used for Diagnostics.

You also have an incredible amount of firewall DNS Server Forward rules. This potentially could be either an issue or the issue causing Malwarebytes to have issues checking for updates. Did you set these up yourself on purpose?

As you can see from the logs, even Microsoft Windows Defender is having trouble updating its rules as well.

Date: 2019-11-11 06:40:52.387
Description:
Windows Defender Antivirus has encountered an error trying to update security intelligence.
New security intelligence Version:
Previous security intelligence Version: 1.305.1810.0
Update Source: Microsoft Update Server
Security intelligence Type: AntiVirus
Update Type: Full
Current Engine Version:
Previous Engine Version: 1.1.16500.1
Error code: 0x8024402c
Error description: An unexpected problem occurred while checking for updates. For information on installing or troubleshooting updates, see Help and Support.

 

 

 

From an elevated admin command prompt, I would also like to have you run the following. One line at a time followed by the Enter key. Even if it does not help correct the issue it will help ensure your operating system files and structure are valid. Please post back the results of each line.

sfc /scannow


 

DISM.exe /Online /Cleanup-image /Restorehealth


This command will say it cannot lock the drive. Press the Y key and the Enter key. Then reboot the system to allow the disk check to run.

ECHO Y|CHKDSK C: /F

 

Please give the above steps a try and let us know the results

Thank you

Ron

 

 

 

Share this post


Link to post
Share on other sites
All Java Dev Kits have been removed along with a problematic Visual Studio 2017 installation.

sfc /scannow

Windows Resource Protection found corrupt files and successfully repaired them.
For online repairs, details are included in the CBS log file located at
windir\Logs\CBS\CBS.log. For example C:\Windows\Logs\CBS\CBS.log. For offline
repairs, details are included in the log file provided by the /OFFLOGFILE flag.

DISM.exe /Online /Cleanup-image /Restorehealth

Deployment Image Servicing and Management tool Version: 10.0.18362.1

Image Version: 10.0.18362.476

[==========================100.0%==========================] The restore operation completed successfully.
The operation completed successfully.

ECHO Y|CHKDSK C: /F

 

Check ran successfully
Edited by AdvancedSetup
corrected font issue

Share this post


Link to post
Share on other sites

Hey @AdvancedSetup

I've noticed that MB4 takes over protection from WinDefender so, instead of having both (WinDefender and MB4) available, I have only the latter.

By disabling MB4 everything works perfect. 

I have a lot of appreciation for both apps so please, provide me with a solution.

Share this post


Link to post
Share on other sites
4 hours ago, Jimmaki said:

I have a lot of appreciation for both apps so please, provide me with a solution.

Toggle the following off.

 

 

Sec center off.png

Edited by Porthos

Share this post


Link to post
Share on other sites

There was a known issue with Windows Security Center at some point. I don't know for sure if it's related to what you're seeing but check for updates again and see what version of Malwarebytes you're on.

image.png

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.