Jump to content
Xebeche

Well, Since You Asked...

Recommended Posts

Received an email from Malwarebytes today. It started:

Enjoying Malwarebytes Browser Guard?

We wanted to check in and see how you're enjoying Malwarebytes Browser Guard. Since you started using it, Malwarebytes Browser Guard has been working hard to protect you from unwanted and unsafe content like clickbait ads and tech support scams. Not to mention, those faster web page load times (4x faster).

The short answer is definitely "yes," but...

  • Page load times seem noticeably slower, not faster. This doesn't bother me much since BG is processing the page before rendering it, and I'm fine with that (just surprised you said pages would load faster in your email). I guess, maybe the pages would load faster vs. having no protection at all, but it's definitely slower than it was with AdBlock installed. No big deal, though.
  • AdBlock has this cool feature where you can just disable it and white-list a site with a single click, then click the same element again to refresh the page. BG seems to take several clicks to do the same thing, and it's much less intuitive.
  • I wish the "Get Full Protection" button was smart enough to go away if I already had Malwarebytes Premium. I do have it, by the way. Or, if it can't do that intelligently, I wish there was a setting to remove it.
  • You invited me with your question, "Enjoying Malwarebytes Browser Guard" to respond, and also get support with, "If you have any questions, or you need a little help, visit Malwarebytes Support." But I can't ask questions or leave feedback without logging in. And my regular Malwarebytes account login didn't work, so I had to make a new account for support. This is just sloppy. If you want my feedback, give me an easy process to leave it. If you don't, then don't ask for it.

But, again, I'm generally happy with it. If y'all fixed or improved the few issues above, I think it'd be absolutely terrific. As it is, I still like it a lot. Thanks very much for making it available.

Share this post


Link to post
42 minutes ago, Xebeche said:

But I can't ask questions or leave feedback without logging in. And my regular Malwarebytes account login didn't work, so I had to make a new account for support. This is just sloppy. If you want my feedback, give me an easy process to leave it. If you don't, then don't ask for it.

Unfortunately, The forum software is run by a separate company. (Invision) and can not be connected to the product portal.

Share this post


Link to post

Thank you for the feedback.  I will make certain to pass it on to the Product team for their consideration.

What Porthos said above regarding the forums is accurate; the forums software is a completely separate system/database so it cannot be tied to your My.Malwarebytes.com account (and it's actually more secure to keep such things separate anyway, in case any individual system is ever breached in any way it won't compromise your other accounts/services so my preference is always for companies to keep such things totally separate even when they are all owned and operated by a single entity just for better security though I may be in the minority on that; I've just seen too many massive data breaches, especially in recent years, to trust multiple accounts/services to a single logon; the same reason I don't use password managers or ever login to third party services using the likes of Google or Facebook and instead opt to create a unique logon with a unique password for every one, but again, that may be just me).

Share this post


Link to post

Thank you Porthos and exile360. I appreciate the explanations and the time you both took to explain it.

I just wonder, if Malwarebytes wasn't able to provide an easy way to answer the question they posed, why they posed it at all.

Share this post


Link to post

@Xebeche In the long run, Having a forum account gives you access to support for all Malwarebytes products. (except licensing issues)

We even have free malware removal assistance here if you ever have an issue you can't fix on your own.  We are a great community and is full of not only knowledgeable members and advisors but staff members as well.

Share this post


Link to post

Actually was able to confirm that page load times have slowed today. I've sent a note to the Development Team to let them know. Not sure what's causing it as it was not happening before.

 

Share this post


Link to post
13 hours ago, Xebeche said:

Thank you Porthos and exile360. I appreciate the explanations and the time you both took to explain it.

I just wonder, if Malwarebytes wasn't able to provide an easy way to answer the question they posed, why they posed it at all.

@Xebeche You raise an excellent point and we will work to provide a more seamless experience going forward. 

Share this post


Link to post

Works just fine for me ! running Windows 7 (SP1) x64  current chrome version September 18, 2019
77.0.3865.90 for Windows    

Share this post


Link to post

Thank you gatortail!

I'm grateful for both of your your replies. And, to add to my original post, I'd say the more I use Malwarebytes Browser Guard, the more I like it.

Thanks again, and thanks for the extension!

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.