Jump to content

Recommended Posts

I had to go back to windows 10 version 1803 since almost 2 days or so (first time this is happened to me), install Malwarebytes version 4 beta , and when I want to exit out of MB it goes to crash !

so the whole software is crashed on the exit !

We’re sorry.but the Malwarebytes service stopped working. The program will now restart.


Edited by Gt-truth
Link to post
Share on other sites

10 hours ago, tepitts said:

I'm currently running Win 10 Pro Build 18980.1 with no issues. Can you run a registry scan / repair? Perhaps uninstall then reinstall Malwarebytes? Or perhaps you've already been down that road.

the win 10 OS is was reinstalled a fresh since more 2 days from now . mostly 3 days as of now .but what is the registry scan / repair you referring to ?

also are you using Windows Insider Preview ? (for me I’ve never been using a test version of Microsoft windows OS)

I’m only using a supported windows 10 OS (version 1803 - home edition) for my device !

Edited by Gt-truth
Link to post
Share on other sites

Hello @tepitts:

2 hours ago, tepitts said:

There are utilities that will scan and, if necessary, repair your registry.


One of the most common complaints we see on our forums, and from our users, concerns a particular category of program called “Registry Optimizers” or “Registry Cleaners” or “Registry Defragmenters”. For this post, we will just refer to them as registry cleaners.

Malwarebytes official stance on such products are summed up rather nicely in the Malwarebytes Labs Blog: Registry Cleaners: Digital Snake Oil

Hence, similar products would be rightly regarded as a PUP and would be flagged and quarantined by the Malwarebytes for Windows product.

Thank you for your understanding.


Edited by 1PW
Link to post
Share on other sites

Hi @Gt-truth,

Thanks for the report.

  • Is this issue consistently reproducible? Has it happened more than once?
  • How are you exiting out of Malwarebytes? Are you right-clicking the tray app and clicking Quit Malwarebytes?
  • What are you doing with Malwarebytes prior to the issue occurring?
  • If you reboot the machine (Start button -> Power -> Restart), does the issue still occur?

Please run the Malwarebytes Support Tool and provide the generated file: https://support.malwarebytes.com/docs/DOC-2396
In addition, please provide the following event logs:

  • Press the Windows Key + R on your keyboard at the same time. Type eventvwr.msc and click OK.
  • Expand Windows Logs.
  • Right-click Application and click Save All Events As.... Name the file application and click OK.
  • Repeat for Security and System.
  • Navigate to the location of the files. Highlight the three files, right-click one and click Send to followed by Compressed (zipped) folder.
  • Name the Zip file EventLogs.zip and attach the file in your next reply.


If the issue is consistently reproducible, please do the following:

  • Please download enable_crash_dumps.bat using the link below.
  • Open your Downloads folder.
  • Double-click CX41PDv.png enable_crash_dumps.bat to run the file.
  • Note: If you are prompted by Windows SmartScreen, click More info followed by Run anyway.
  • A blue Command Prompt window will appear. Upon completion, press any key to exit.
  • Reproduce the issue.
  • Wait at least 1 minute. Press the Windows Key NfsK8XE.png + R on your keyboard at the same time.
  • Copy %localappdata%\CrashDumps and paste into the Run box. Click OK.
  • A folder will open. Inside you should see a DMP file.
  • Right-click the file and click Send to followed by Compressed (Zipped) folder. Move the zip file to your Desktop.
  • Attach the zip file to a forum post.
Edited by LiquidTension
Link to post
Share on other sites

hi @LiquidTension and your welcome . here a screenshot .

yes I think this issue is reproducible and it happened one time only .

exit/quit out of MB by right-click on its icon in the tray app/startup area .

I was doing nothing with Malwarebytes software prior this issue when it occurring  .

I do not know whether if this issue is still occur or not but I could to give another try . 



I’m going to send those files when I have to done running all above :)




Link to post
Share on other sites

Thanks for sending those files. Unfortunately, you appear to have clean uninstalled Malwarebytes with the Support Tool before gathering logs so there's not much data to go on.

From your screenshot, we can see a scan was being performed. To confirm, you tried to quit out of Malwarebytes as the scan was in progress?
Was this a manual or scheduled scan? Can you remember the scan configuration?


If you intend on reinstalling the Malwarebytes version 4 beta, please see if the crash occurs again. Make sure you've enabled creation of user mode crash dumps using the enable_crash_dumps.bat first.

If the issue occurs again, please let us know and provide the contents of the %localappdata%\CrashDumps folder.

Edited by LiquidTension
Link to post
Share on other sites

hello @LiquidTension

yes in fact I had to do a clean uninstalled by using MB support tool/and to do a full clean by using Revo uninstaller /and then I run the disk cleaner that built-in windows / also I use TFC and ATF to cleaning unnecessary files and which is almost to be (4 GB) to be cleaned .

I was unaware of this at that time when "Malwarebytes have preformed an scan in the background" and I haven’t open the MB at that time but all I’ve to doing it to Quit of MB and that because I was on a gaming session (an online game) and yes this is almost was an scheduled scan (default scan configuration)

also the mb-support tool is not responding while it in use and it taking a bit time to back to normal  / and same problem with Malwarebytesv3/Malwarebytesv4

and I just now to download of enable_crash_dumps.bat and run it ! and I’m going right now to re-install Malwabytes version 4 beta . :) let me know if there anything should I do in next time

thanks :)



Link to post
Share on other sites

an update on this issue : the whole Malwarebytes version 4 beta is still to be crashed on some points and this crashing is still occurring even though I had to do uninstall it and reinstall it .

also there no folder called "CrashDumps" in the path mentioned above on my windows version 1803 home edition even though I have to download and to use the bat.file above

Link to post
Share on other sites

Is this only occurring when you use the "Quit Malwarebytes" option during a scan? What if a scan isn't in progress?
Please try to be as clear as possible when describing the scenario(s) that result in the issue.

Please do the following:

  • Open Malwarebytes.
  • Click Settings.
  • Turn the Event Log Data setting on.

MgeHyNE.png Generate MBAMService Memory Dump

  • Please download run_procdump.bat using the link below.
  • Open your Downloads folder.
  • Double-click CX41PDv.png run_procdump.bat. Click Yes if prompted by AVOiBNU.jpg User Account Control.
  • Note: If you are prompted by Windows SmartScreen, click More info followed by Run anyway.
  • A blue window will appear.
  • When prompted to reboot, type Y into the window and press Enter on your keyboard.
  • After your computer has rebooted, please do the following:
    • Reproduce the crash. Do not click OK when the error message appears.
  • Once done, open your Downloads folder and double-click the run_procdump.bat file once more.
  • Upon completion, a file named HSPwQfy.png memorydump.zip will be saved to your Desktop. Please attach the file in your next reply.
  • Note: If the file is too large, you will be provided instructions to upload the file to a file hosting website (wetransfer.com).
Link to post
Share on other sites

after this issue is occurs for the second time , then yes I’ve noticed that happen when an scheduled scan was in progress and thus when I try to quit out of Malwarebytes here.

also , I just powered on the device and the Malwarebytes isn’t running in the tray app/startup area so what is the problem here ?

aside note : sometime MB app can be closed without any problem so what I have to do is just to "quit Malwarebytes"  and then when I relaunch it then an auto scheduled scan will Immediately be launched (I think wrong scheduled scan is performed by the MB software) so this also happened every time I close out of MB and to launch it once again . I hope this will really help .

others users had the same problems as well https://www.google.com/search?q=We’re+sorry.but+the+Malwarebytes+service+stopped+working.+The+program+will+now+restart.+site:forums.malwarebytes.com&safe=strict&client=firefox-b-d&sxsrf=ACYBGNRdQVkv45F_IDIL-NREg8OQW-zBrw:1568843466555&sa=X&ved=2ahUKEwjf06CsrdvkAhXNyIUKHZMzDA4QrQIoBDAAegQIAhAN&biw=1366&bih=654



Edited by Gt-truth
Link to post
Share on other sites

It sounds like perhaps the service isn't starting properly after system boot.  That's the component that launches the tray and executes scheduled scans.  I'd suggest disabling fast startup if you haven't done so already as it's known to cause problems with Malwarebytes and other applications sometimes.  Instructions on doing so can be found here as well as here.

Link to post
Share on other sites

@exile360 thanks , fast startup have been disabled and do one more system restarts and upon the windows started to desktop I still see that Malwarebytes won’t running there :(

@LiquidTension I had to enable "Event log data" in the Malwarebytes setting and then I do an a system reboot and after back on my desktop MB is not running as it should be in the tray app area ? and double-clicking on the Malwarebytes icon on the desktop make no sense because of "Unable to connect to the Server" error message is now appeared !

even the procdump.bat powershell  windows goes red with errors and it not prompted me to a system reboot ! and it most likely the cause of Unable to connect to the Server is the using of procdump.bat powershell script !

btw : it says that I’m using Malwarebytes version 3 but untrue . I’m using Malwarebytes version 4 beta .



Edited by Gt-truth
Link to post
Share on other sites

  • 4 weeks later...

just an update on this issue : the ProcDump v1.3 can not deal with the Malwarebytes  version 4 beta and nor able to stopping MBAMService service while the program is opened and running with an error message is pop-out

I’m not sure whether if the ProcDump v1.3 it will works with the Malwarebytes version 3 or not and thus because I Never seen / haven't gotten  this error by using the ver3 .

I am right now stuck and not able to find out a way to make ProcDump v1.3 to continued processing its things in order to Generate a Memory Dump file .



procdump-log.txt procdump-log.zip

Link to post
Share on other sites

  • 2 weeks later...

here’s s few dumps files within the zip file that are created via windows task manager .

Edit : cannot be upload it to the forum because files are too big . how can to go with since uploading such files will take almost 5 hours .



Edited by Gt-truth
Link to post
Share on other sites

  • 5 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.