Jump to content
Marc_Foreman

Websites slower when extension enabled, even with all settings to OFF

Recommended Posts

Hi - this is a note for the devs. I'm experiencing a general slowdown in Chrome when loading up web pages when the Malwarebytes Browser Guard Extension is enabled. Even when turning off all per-website settings to whitelist my chosen page, the extension being active still extends the loading time for my homepage from under 1 second to around 15 seconds.

The site I'm testing with is https://www.bbc.co.uk

I find it odd that it's the active extension itself rather than the actual site-checking / blocking that's causing the slowdown. Once disabled, the problem immediately goes away, so hopefully that's a clue?

 

Please let me know if I can assist in any way by running beta / logging versions to provide additional info.

FYI My system is Windows 10 1803, running Malwarebytes Premium paired with Windows Defender.

Best,
 

Marc

Share this post


Link to post

Hello @Marc_Foreman

What version of Google Chrome are you using?

image.png

Using just Malwarebytes Browser Guard or with uBlock Origin I am unable to duplicate your issue.

image.png

Our program blocks 6 sites and uBlock Origin blocks more as well and neither one slows the site from loading. It loads in under a second for me.

Considering how much content is on the page they've done a great job at managing loading speed

Perhaps cleaning Google Chrome may help?

Thanks

Ron

 

Share this post


Link to post

Thanks Ron - I'm on the latest Google version 

Google Chrome is up to date
Version 77.0.3865.75 (Official Build) (64-bit)
 
I don't have sync turned on, and rarely stay logged in to my google account on the browser.
 
There is some geo-locking going on though, as my issue is with bbc.co.uk (took 5 seconds to appear today instead of the usual 15 with the Malwarebytes extension enabled). However, I can't get to bbc.com to compare. You guys have the opposite issue, where you can't get to bbc.co.uk.
 
I'll keep an eye on the situation and if I find another website that displays the same behaviour I'll update this message - hopefully we'll both be able to connect to it.
 
Best,
 
Marc
 

Share this post


Link to post

No, no lock on my end. I can get to both sites without an issue.

Google sync is just one small portion of that article. Cleaning up the junk that builds up in Google Chrome is also part of it. I'm not a big fan of Google Chrome so only use it when I have to but I've also cleaned a lot of junk build up from it after only a few days use.

Personally I'd recommend using Firefox myself but I do know there are some sites that only support Chrome (various reasons for that but being forced to use one specific browser goes against the open nature of the Web)

I would recommend using another browser if for nothing else, to test and verify if they too have the same issue.

 

Share this post


Link to post
11 minutes ago, AdvancedSetup said:

Personally I'd recommend using Firefox myself but I do know there are some sites that only support Chrome (various reasons for that but being forced to use one specific browser goes against the open nature of the Web)

I personally use Firefox. But at least using Chrome is better than IE or Edge. :rolleyes:

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.