Jump to content
ssnoke

Confirmation to change Web Protection very slow

Recommended Posts

Attempting to change the Web Protection option from ON to OFF resulted in a long delay before the confirmation window was displayed.  This is not true with the options for Malware Protection, Ransomware Protection, or Exploit Protection.  I tried this several times to confirm this behavior.  One time I had moved on to checking other options on another window and had totally forgotten about asking to change the Web Protection option when the confirmation popup was finally displayed.  Should a user be allowed to navigate away from a window after requesting a change that requires confirmation? 

Share this post


Link to post

Greetings,

Thank you for reporting this issue.  It is normal for it to take longer to disable/enable Web Protection as it has to unload/reload the entire Web Protection database and driver out of/into the network stack which can take time, even on fast systems.

I'd personally rather it allow the user to navigate away just in case there were ever an issue that caused the program to lockup during this process for some reason (such as a conflict or program corruption) so that the user is still able to access the rest of their system.  Whenever a protection component is disabled you should receive a User Account Control prompt which comes from Windows itself so it should still show up even if you navigate away from Malwarebytes and it works the same way when disabling any component of protection from the Malwarebytes tray context menu located in the notification area near the system clock.

Share this post


Link to post

Hi @ssnoke,

Just to confirm, are you referring to a User Account Control (UAC) prompt?

image.png.ba06d67c26ff6293f156e29ed733bf82.png

When a Real-Time Protection module prompt is clicked, the time it takes for this to be displayed should be consistent for all Real-Time Protection modules (with one potential exception mentioned below). The actual time it takes for the prompt to appear is dependent on various system/environment factors, but there shouldn't be any particular differences between Web Protection and the others. The reason being - when the toggle is clicked, the disabling of the module and any associated actions are not performed until after the UAC prompt is confirmed.

How much of a difference are you seeing with Web Protection when compared to the others?

When you've tested, are you disabling Web Protection first in each Malwarebytes session? Please try the following:

  • Reboot the computer.
  • Open Malwarebytes.
  • Do not disable Web Protection. Instead, disable one of the other protection modules such as Malware Protection.
  • After accepting the UAC prompt, disable Web Protection.

What are the results? Is the time it takes for the UAC prompt to appear after disabling Malware Protection still quick? What about Web Protection?

-----

In regards to the actual disabling of the protection module - we're aware of an issue with the Web Protection driver taking significantly longer to uninstall when compared with Web Protection in Malwarebytes version 3. However, this appears to be unrelated to what you're reporting here as your issue involves a delay prior to the actual disabling of the module commencing.
 

Quote

Should a user be allowed to navigate away from a window after requesting a change that requires confirmation? 

Yes, this is intended behaviour. We don't want to block/lock the Malwarebytes UI to wait on something (the UAC prompt) that is ultimately out of our control.

Share this post


Link to post

Yes, the image you sent is the UAC prompt that I am referencing.

This morning, I performed the following steps per your instructions:

  1. Shut down and then rebooted laptop.
  2. Set timer, clicked to disable Malware Protection and started timer.  In under two seconds, the UAC prompt displayed. 
  3. Reset timer, clicked to disable Web Protection and started timer.   This time, the UAC prompt was displayed in under two seconds.  
  4. I repeated this exercise, leaving some protections disabled and then clicking to disable Web Protection, and other times, disabling and then re-enabling other prompts and then disabling Web Protection.  In no instance was there ever a noticeable difference in the display timing of the UAC prompt.  
  5. Yesterday, I was able to review and play with the settings in all four Advanced Setting options before the UAC prompt for Web Protection was ever displayed.   I considered that delay to be too long, and perhaps confusing for a user if he had had the time to disable multiple settings as I did.  

Share this post


Link to post

Thanks for the file.

If you're able to reproduce the behaviour again (significant difference in the time it takes for the UAC prompt to appear when disabling one protection modules vs another), please enable debug logging using the steps below and let us know.

  • Open Malwarebytes
  • Click Settings
  • Turn the Event Log Data setting on.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.