Jump to content

Allow list: the Done button does nothing


grahamperrin

Recommended Posts

image.thumb.png.4b3d389a274ead3b809b960d57066ece.png

Above: Malwarebytes Browser Guard 2.0.2 added to Waterfox Classic 56.2.14 on FreeBSD-CURRENT.

The behaviour is reproducible with Firefox Quantum 69.0.

Gut feeling: if users are making do without a working Done button, then simply remove the appearance of a button. Keep the GUI free from clutter.

Link to post

It is 'greyed out' because you have not entered any allow (exception) to be added yet.

It is selectable once you have added a URL or IP, and selected which protection(s) to disable, then the button becomes blue and clicking it adds the exception to your allow list.

For example:

image.thumb.png.854c1205cbe1364f6f545e5ee557b7d7.png

Edited by nukecad
Link to post

Possibly, but even 'Add' may be confusing for some who might think you had to click it before entering anything to add?

Maybe not showing the button at all until something had been entered in those fields could be the way to go, but that would depend on just what the programming allows.

Link to post

Thanks,

> Maybe not showing the button at all until something had been entered in those fields

+1

I think, the primary problem with the Done button is the false assumption that the GUI is solely for addition.

In truth, the UI is also used to review and sometimes remove allowances.

Also, to my eye, the paler of the two blues is not pale enough to signify 'greying out' i.e. non-applicability.

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.