Jump to content
exile360

Exclusions don't function

Recommended Posts

I tried excluding 2 sites and even after closing and reopening my browser the sites are still blocked/redirected to the browser extension's block page (Web Protection is disabled so that cannot be the cause).

Is anyone else seeing this behavior?

Share this post


Link to post
3 hours ago, exile360 said:

I tried excluding 2 sites and even after closing and reopening my browser the sites are still blocked/redirected to the browser extension's block page (Web Protection is disabled so that cannot be the cause).

Is anyone else seeing this behavior?

What sites are blocked ?

 

Share this post


Link to post

The first was openload.co and the second was entervideo.net.

Share this post


Link to post

It initially blocked it for me @exile360 but once I added the exclusions I didn't have to restart the browser. Just a refresh and the site opened.

image.png

Share this post


Link to post

Though both of those sites have multiple Trojan and Ad Server blocks on them and it's not recommended to exclude them.

 

Share this post


Link to post

Right, the entire purpose was to test exclusion functionality so I found a streaming site where I knew I could reliably reproduce blocks by the browser extension and that's when I discovered that exclusions weren't working.

Share this post


Link to post

I just tested again; both exclusions still remain in my allow list yet I still get blocks:

blocked.png.bbcf89e6e3962f573903c39ab82f2455.png

Share this post


Link to post
Posted (edited)

Is this section working? @exile360

 

2019-08-28_16h03_16.png

Edited by Porthos

Share this post


Link to post
Posted (edited)

Nope, that doesn't work and neither does the 'I want to continue to this site anyway' link.  I had to add the exclusions manually to get them into my allow list.

Edited by exile360

Share this post


Link to post

Please show a screen shot of your actual Allow entries in the lower box as shown in my screen shot above. I confirmed that it is working for me. Getting it set was a bit slow but it works.

 

Share this post


Link to post
Posted (edited)

Yep, you're not allowing the Ad/Trackers, Scams, PUPs only Malware

 

We are currently blocking the site for 3 different categories. Though 2 of them probably fall under just Malware for BG

 

image.png

Edited by AdvancedSetup
updated information

Share this post


Link to post

Right, and as you can see by the first image I posted, it is being blocked for malware (Trojan) activity, meaning a simple malware exclusion should have sufficed.  Additionally, as mentioned, the controls in the actual block page to continue to the site anyway and checkbox to exclude the site do not function.

Share this post


Link to post

The site is also blocked for Ad Server so I can probably play with each option. Though let me check and see if the "allow" works or not for single session.

 

Share this post


Link to post

I see, but then why does it always show that the site is blocked for malware/Trojan, even when the malware exclusion is present?  Is that just the default whenever a site is blocked for multiple reasons; i.e. go with the more severe reason no matter what?  If so, I get it sort of, but for cases like this where the user might try to exclude the site, the block page/redirect needs to reflect the actual reason for the block at that point (i.e. show that it was blocked for advertising/being an ad server rather than continuing to show the Trojan/malware block page).

Share this post


Link to post

We don't specify every single object that is blocked. I'll try to do some testing tonight and let you know. As I see it so far, it's working as expected except possibly the "allow this session" from the blocked web page.

 

Share this post


Link to post

Wow, very fast. Once I clicked the check box to never block again it immediately went to the site. It added this entry on it's own (which matches your screenshot)

 

image.png

 

I closed the browser. Relaunched, went to the site openload.co and no block.

So, not sure what's going on for your system. I would try removing the extension again. Reboot the computer. Then go back to the Google Chrome store and re-add the Malwarebytes Browser Guard extension again and test again.

I cannot duplicate your issue on my system.

 

Share this post


Link to post

Yeah, I don't expect it to specify every reason for every block when there may be multiple reasons, but once excluded from one type of blocking it definitely shouldn't show the site as being blocked for that very reason afterward because that doesn't make any sense and that's my only point as far as that goes.

For everything else, I couldn't get the option to exclude the site permanently or during the current session to work in the block page and the only way I could get it to show up at all in my allow list was to add it there manually.

Share this post


Link to post

OK, I just did all that and the issue persists.  Maybe it's a problem with Iron.  I click the checkbox to exclude the site and while the check appears in the box, nothing else happens.  I click the link to continue to the site anyway and the block page appears to reload quickly, but only loads the same block page again so nothing changes; I still can't reach the site.

I'll try excluding it completely and see what happens.

Share this post


Link to post

OK, after excluding it from every category so that it shouldn't be blocked for any reason the block still persists.  It must be an issue with Iron not liking the browser extension or vice-versa.

Share this post


Link to post

OK, I figured something out.  The blocked page is an embedded video stream being displayed on a different site.  If I exclude the actual site I am viewing from being blocked for malware then the video loads even though the block itself was showing the source domain for the video as the site being blocked.  This is really weird behavior in my opinion.

If you want to test and verify all this behavior yourself, here is a site where you can test it (no pornography; it's a Disney video):

http://sockshare.net/watch/XvjJ3Pve-buzz-lightyear-of-star-command-season-1.html

Share this post


Link to post
Posted (edited)

Just fire up Google Chrome (currently only verified version, though in "theory" other chromium based browsers "should" work) and test it out.

sockshare is a different site than the one you asked us to check

 

Edited by AdvancedSetup
updated information

Share this post


Link to post

That sockshare link is in an embedded object in a frame it looks like. I was not able to get it to allow it. But, to be fair we are trying to protect you and this is obviously an illegal site providing illegal content so though we don't try to be the police for content we also won't go out of our way to work on allowing illegal content access.

I'll report it, but again I would not expect them to fix it for this specific site.

 

Share this post


Link to post

Right, I just used that as a simple example because it was easy to replicate it.  Embedding content is a very common practice so when the blocker shows a specific site as being blocked, provides the option to create a temporary or permanent exclusion, but requires a different site to be whitelisted it seems to me that it is not working as intended, or at least not as would be considered intuitive by the user.

Share this post


Link to post

By the way, excluding embedded content this way used to work with previous builds of the extension, so whatever is causing this has to be a change in the final build.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.