Jump to content
grahamperrin

Scam protection versus CROWDLAAERS

Recommended Posts

Steps:

  1. visit https://crowdlaaers.org/
  2. disable malware/scams for the site
  3. disable ads/clickbait for the site
  4. in the Search field of the CROWDLAAERS page, type  (or paste) http://jonudell.net/udell/2003-10-23-apples-knowledge-navigator-revisited.html
  5. click the Search button.

Expected:

  • data relating to an annotation.

Actual result:

  • no response to the click.

Workaround

  1. open Malware Browser Extension preferences (for the extension, not for the site)
  2. disable scam protection
  3. reload the bugged page.

Bug first observed with version 1.0.44 of the extension added to Waterfox Classic 56.2.12 on FreeBSD-CURRENT.

Reproducible with Firefox.

grahamperrin@momh167-gjp4-8570p:~ % date ; uname -v
Tue 23 Jul 2019 00:11:12 BST
FreeBSD 13.0-CURRENT r350027 GENERIC 
grahamperrin@momh167-gjp4-8570p:~ % pkg query '%o %v %R' firefox waterfox
www/firefox 68.0.1,1 FreeBSD
www/waterfox 56.2.12 poudriere
grahamperrin@momh167-gjp4-8570p:~ % 

Side note – reproducibility

From the outset I suspected an issue with an extension, but this bug was very difficult to track down because when using a methodical approach (e.g. legacy Extension Conflict Troubleshooter with Waterfox Classic) the issue was often not reproducible when restarting the browser with session restoration enabled, with Malwarebytes Browser Extension enabled, with scam protection enabled.

Unpredictability of this nature is, I suspect, a symptom of:

If I understand correctly: when an extension is bugged in this way, the extension is not (or not entirely) functional. So for me: on the occasions when scam protection should have been functional, truly it was not.

Comparable

Scam protection versus DTube

Share this post


Link to post

I have opened a bug to investigate above. 

Share this post


Link to post

Fix confirmed, thanks.

Side note: as far as I can tell there is now, coincidentally, an issue with CROWDLAAERS – bugging (at least) Microsoft Edge and Waterfox Classic – but the site does behave as expected with Malwarebytes Browser Extension and Firefox 68.0.1.

Share this post


Link to post

With Malwarebytes Browser Guard 2.0.2 added to Firefox 69.0.2 (20190831233220) on FreeBSD-CURRENT:

  • I can no longer  reproduce the issue

– the page works as expected with scam protection enabled both (a) generally and (b) for the site.

image.thumb.png.5e81dfb626d427cfd848393727ad957f.png

The site's behaviour with some other browsers (including recently built Waterfox Classic 56.2.14) remains bugged, but this seems to be unrelated to the extension:

937181648_2019-09-07030555.thumb.png.986cac927b9a640b423694bcdae901d6.png

I'm happy to treat this issue (this topic) as resolved.

Thanks

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.