Jump to content

Problems loading a website

Recommended Posts

I would like to report this feedback @treed
Having installed Malwarebytes for iOS Beta (latest version available) with all the protections enabled regarding web browsing and adblocker, this happens to me:

Only with the site spider-mac (an Italian mac information site very valid because with few non-invasive advertisements and very useful articles) this is constantly loaded incorrectly by not displaying the latest articles even by reloading it; moreover, the data relating to the date and time of publication of the articles are not updated (even if the web cache and Safari cookies have not been eliminated).

The same site on Mac using ka-block! it is loaded wrong especially if I deleted the cookies but by clicking on the reload arrow of the site this is updated correctly; in case the cleaning of Safari is not carried out, it is mostly loaded correctly.

It only happens to me with that site among those I visit most frequently.

Thank you in advance for the possible solution of the problem

Link to post
Share on other sites

  • Staff

I'm not sure that I understand the problem. I took a look at the site on my iPhone, both with and without content blockers, and saw no differences other than the presence/absence of ads on the page. Can you describe more specifically what you're seeing on the page that is wrong?

Link to post
Share on other sites

on mac where I don't have malwarebytes but ka-block!, as ad-blocker,  is more up to date.  Certain articles released this afternoon on Safari for macOS will perhaps appear tomorrow on Safari for iOS

My systems are MacBook Pro mid 2012 with Mojave 10.14.5 word Malwarebytes Premium (last versione) and iPhone SE with iOS 12.3.1 and Malwarebytes iOS Beta 1.3.3

It only happens to me with that site

Currently on iOS I see "Who are the people who will replace Jony Ive" like it was 18 minutes ago (which dates back to a few hours ago on macOS)

For me now it's 5:40 pm 




Link to post
Share on other sites

  • Staff

We haven't been able to duplicate this here... everyone on the iOS team tried it, and we're all seeing the same articles on both Safari for macOS and Safari for iOS, with both the ad blocking and web protection enabled on iOS.

Can you try disabling both the ad blocking and web protection features in the Malwarebytes app, then disable those in the Settings app as well? Then tap the "Protection updates" banner on the Dashboard in the Malwarebytes app to force a database update. Finally, turn those features back on, first in Settings and then in the Malwarebytes app.

The suggestion for separate whitelisting for ad blocking and web protection is a good one, thanks!

Link to post
Share on other sites

I have done everything you told me, with the addition of a forced iPhone switch-off in between.
Unfortunately I haven't solved anything.
The only way to solve it is to completely disable the ad-blocker everywhere with all the resulting problems.
I must say that even on macOS if I have the ad-blocker inserted (ka-block!) some problem that site (and only that) gives it to me.
The webmaster tells me that it works properly without the use of ad-blockers, but not all sites are like that one that uses a few non-invasive advertisements.
Rather than being without an ad-blocker I prefer that site a little less functional, being the only one.
I hope you will soon implement the whitelist mentioned above.

Thanks for your interest
Greetings and good work to all

Link to post
Share on other sites

@treed If can help you, I can add that the same site also gives me problems on macOS with Firefox and the Malwarebytes extension, whether the ads / clickbait filter is active for everything or whether it is disabled only for that specific site.

With the same date and time of the screenshots (see arrows above), one less post appears on Firefox and the publication time is dramatically different (see arrows below); and now the difference is of a single article.
Also on iOS as here many times it relates to several articles.

I attach the two screenshots (the zoom was obviously adjusted manually to allow a complete view).

In firefox the site is whitelisting
In Safari I use ka-Block!




Link to post
Share on other sites

This issue might be due to browser caching in Firefox.  If you haven't already, please try clearing the cache/history for Firefox and reloading the page to see if that makes any difference as it may be loading older/outdated cached content to try and speed up page loading times for sites you've already visited (a feature built into most modern browsers, including Firefox).

Link to post
Share on other sites

I clean my cookies, browser cache and DNS cache regularly. The problem that always arises with the Malwarebytes extension for Firefox on macOS and Malwarebytes for iOS, arises in Safari for macOS just when I do these cleanings and not when I leave everything as is.

The problem is therefore also another because on Firefox for iOS, and therefore without your extension, the problem does not exist. In fact, I just use this one on the iPhone to see the site correctly

and in any case it only happens with that site. It has no problems on Windows where there is web protection in Malwarebytes if I don't use the extension.

Edited by MAXBAR1
added explanation on Windows
Link to post
Share on other sites

Fixed the problem on iOS (so to speak), deactivating the ad-blocker of Malwarebytes and leaving only the web protection active and using also on iOS ka-block! as an ad-block similar to macOS.

I wrote this solution hoping that it will make you understand what's the problem.
Thank you

Link to post
Share on other sites

  • 3 months later...

@treed  I report the problem again.

If I delete the cookies and the browser cache (Safari) I am obliged to disable the MWB ad blocker, reload the site and this point I can reactivate the MWB ad blocker and it does not give me any more problems until I clean up the data of Safari.

With ka-block! on macOS and on iOS the only thing I have to do is reload the site when I delete the Safari data but I never have to disable the ad-blocker. I only use the other three MWB protections.

It happens only with the website Spider-Mac which from today has only advertising of the Apple circuit. Despite this the problem remains.

With any other site and any ad-blocks I use, nothing wrong happens.

This site must be reloaded after each cleaning but with MWB ad-block the process is more cumbersome. It also happens with your extensions on other browsers.

I can't understand why. Surely the site in question has some problems but despite the elimination of almost all the advertisements and the change of servers nothing has been solved.

The problem always turns out to be, in the cases in which it occurs, the failure to load the last articles and the wrong date on the articles displayed.

It doesn't just happen to me or at least I wasn't the only one that happened. I don't know what the situation of others is now.

Thanks for the attention

Have a good day


Edited by MAXBAR1
Added explanations
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.