Jump to content

Recommended Posts

I have an old Windows XP Home Edition (Service Pack 3) that is now unable to perform System Restore on ANY restore point. This computer uses a dial-up connection to connect to the internet and normally has a speed of 44.0 - 45.2 kbps, but now only connects at 24.6 kbps.
 
Here's a list of events and the dates they occurred on. Sorry for the length of this post.
 
February 21st:
- Updated Avast Virus Definitions in the early afternoon. I turned off the computer after updating.
 
- Turned on the computer in the evening, and the dial-up connection window appeared on start-up, prompting me to connect to the internet. This doesn't normally happen.
 
 
February 23rd:
- Ever since the 21st, every single time I turned on the computer, the connection window would pop-up on its own.
 
- I checked the Avast Antivirus settings, but I already had it set to manual updates instead of automatic, so that couldn't be it.
 
- I haven't installed anything new, so I don't know what was prompting the computer to connect on its own.
 
 
February 24th:
- I used System Restore to roll-back the settings to the February 15th restore point.
 
- The problem was resolved! The computer stopped trying to connect to the internet on start-up.
 
 
April 21st:
- Completed a Full System Scan with Avast.
 
- When connecting to the internet later in the day, I could only get a speed of 24.6 kbps.
 
- I tried disconnecting and redialing for my usual speed of 45.2 kbps, but I keep getting 24.6 kbps.
 
 
April 24th:
- I'm still only getting 24.6 kbps.
 
- Checked the phone line, it's working normally (no background noise), and everything is plugged in securely.
 
- I assumed something in the settings must have changed, so I tried to use System Restore again.
 
- When the computer restarted after using System Restore, I got this message "System Restore did not complete successfully. No changes were made to your computer."
 
- I tried again using other Restore Points, but it fails no matter what date I choose.
 
- I restarted the computer in Safe Mode, and still all Restore Points fail.
 
- I try to sign-in to my Google Account to email someone for advice, and I get this message 
 
"The browser you're using doesn't support JavaScript, or has JavaScript turned off. To keep your Google Account secure, try signing in on a browser that has JavaScript"
 
- JavaScript is already enabled. I tested it with another Google account and was able to sign-in without any problem. It is only this account that isn't working.
 
 
So to sum it all up, these are the 3 problems:
 
1) Internet Connection speed is now consistently slower at 24.6 kbps instead of 45.2 kbps.
2) System Restore fails no matter which Restore Point I choose (even on Safe Mode).
3) Google doesn't detect JavaScript when I try signing-in with my account.
 
Any help you can provide would be appreciated,
 
- T-Ruth

Share this post


Link to post
Share on other sites

Wow man, this sucks! Sorry to hear that this is happening to you. I work as the IT guy for my church and we have a community center that had this exact same thing happen and it was determined to be a virus. From what I recall it disables JavaScript to bypass security checks. Because those security checks aren't happening it can wreak havoc on your browser and connection in general. As Sys Restore is tied to the OS, any issues with the OS are going to subsequently affect Sys Restore's ability to function. This is one of the pitfalls of Sys Restore, it's only effective if there's no problems!

What we ended up doing is restoring from a disk image, implementing a better firewall, and replacing Sys Restore with Rollback Rx Home. It's free but works much better than Sys Restore. If you don't have a disk image it might be best to back up what data you can and re-install the OS.

Share this post


Link to post
Share on other sites

Sorry for the late reply, thing's have been really busy lately.

I hadn't considered the possibility that my Windows XP has been infected. I've been running full system scans regularly with my Avast Antivirus and it hasn't been able to detect any threats. I've also avoided opening email attachments and only ever visit a few websites like Gmail and Reddit.

Note:  I am still able to sign-in to other websites normally, and presumably those websites use JavaScript too. For example, I was still able to visit Reddit last night. The only website giving me problems right now is Gmail.

Some questions:

  1. What sort of virus was it that infected the community center and how was it detected?
  2. Besides disabling JavaScript, what else does the virus do to the computer?
  3. Is it possible to clean out this infection without having to re-install the OS?
  4. Stupid question, but is re-installing the OS the same thing as doing a factory reset of the computer?
  5. Unfortunately, I don't have a disk image, but I have made copies of all my important documents on a portable hard drive. If I need to do a complete re-install, are there any instructions I can follow? I've never done this before and I don't want to screw up anything.

 

Thanks,

- T-Ruth

Share this post


Link to post
Share on other sites

You are assuming malware and more specifically a sub-type of malware, a virus.

As you have noted, it is an old system.  Thus an OS corruption is more likely the culprit.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.