Jump to content

"Unable to contact license server" after 3.7.1 upgrade

Recommended Posts

Hi there,

After ignoring updates for a month, I updated to 3.7.1 today, and now I get the error "Unable to contact license server".  The mbamservice.exe was going into a constant crash loop that was chewing up HDD and CPU with the Windows Error Reporting, but since disabling the 4 real-time protection options, this has stopped.  I am however unable to reenable the 4 real-time protections.  Opening the "Account Details" tab triggers the "unable to contact lisense server" error again.

I've tried pinging and connecting to keystone.mwbsys.com and sirius.mwbsys.com and they both resolve to IP's however only keystone returns with an OK in the browser, sirius refuses to connect.

Attached is the mb-check results 


Link to post
Share on other sites

  • Staff

***This is an automated reply***


Thanks for posting in the Malwarebytes 3 Help forum.


If you are having technical issues with our Windows product, please do the following: 


If you haven’t already done so, please run the Malwarebytes Support Tool and then attach the logs in your next reply:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  1. Download Malwarebytes Support Tool
  2. Once the file is downloaded, open your Downloads folder/location of the downloaded file
  3. Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  4. Place a checkmark next to Accept License Agreement and click Next
  5. You will be presented with a page stating, "Get Started!"
  6. Click the Advanced tab
    Repair menu_arrows.png
  7. Click the Gather Logs button
  8. A progress bar will appear and the program will proceed with getting logs from your computer
    Advanced Gather Logs_arrows.png
  9. Upon completion, click a file named mbst-grab-results.zip will be saved to your Desktop. Click OK
    Advanced Gather Logs completed_arrows.png
  10. Please attach the file in your next reply. Before submitting your reply, be sure to enable "Notify me of replies" like so:
     notify me.jpeg  

Click "Reveal Hidden Contents" below for details on how to attach a file:


To save attachments, please click the link as shown below. You can click and drag the files to this bar or you can click the choose files, then browse to where your files are located, select them and click the Open button.


One of our experts will be able to assist you shortly.


If you are having licensing issues, please do the following: 


For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/community/consumer/pages/contact-us to get help

If you need help looking up your license details, please head here: https://support.malwarebytes.com/docs/DOC-1264 


Thanks in advance for your patience.

-The Malwarebytes Forum Team

Link to post
Share on other sites

Ran the support tool, did a repair, still no luck.  Just gathering the logs now

The windows crash event viewer thingee shows

Faulting application name: mbamservice.exe, version:, time stamp: 0x5c508d96
Faulting module name: MwacLib.dll, version:, time stamp: 0x5c4b9e72
Exception code: 0xc0000005
Fault offset: 0x000000000000d95c
Faulting process ID: 0x380
Faulting application start time: 0x01d4cccd50dcfdc1
Faulting application path: C:\Program Files\Malwarebytes\Anti-Malware\mbamservice.exe
Report ID: 95b53e09-94e2-4f34-9636-80dc9db00890
Faulting package full name: 
Faulting package-relative application ID: 


Link to post
Share on other sites

I've used both Proxifier and Malwarebytes for years, how come this version is the first that's experiencing this incompatibility?

I still use Proxifier to help with work I do for Pidgin, so removing it would be a serious impediment.  Are there any other workarounds, such as copying a winsock dll into the Malwarebytes folder for it to use instead?

Link to post
Share on other sites

Hi @eion,

Malwarebytes version 3.7 introduced a new type of driver file - Early Launch Anti-Malware (ELAM) - to meet Microsoft's AM-PPL requirements for interfacing with the Windows Security Center.

We are investigating the incompatibility with certain third-party Winsock DLLs.

In the meantime, the options available are to either uninstall the third-party program or revert to the previous version of Malwarebytes (3.6.1).
A link to the installer can be found here: https://malwarebytes.box.com/s/plo5hdm39who0lwld7j1y5e55rum8z33

Edited by LiquidTension
Link to post
Share on other sites

  • 5 weeks later...

I would also appreciate an update when a solution is found.

After noticing MWB has not actually been running for the last couple of months, and being unable to open it, I reinstalled and spent many hours trying to find a solution for why I couldn't activate the licence, before finally stumbling across this post. I run a VPN (Astrill) which I suppose may be causing the conflict, because MWB 3.6.1 works fine.

Uninstalling my VPN is not an option for me, because of the country in which I live. I would appreciate it if you would release a proper fix for this problem soon.

Link to post
Share on other sites

It may be worthwhile to seek out a VPN that doesn't use the deprecated Winsock/LSP filtering method and instead uses the current standard WFP method if possible.  That said, you might also check with your VPN provider to see if they offer an option to use WFP instead of LSP as I discovered at least one software vendor who does.

More info on the deprecation of LSP/Winsock can be found here, here as well as here.  In fact, I'm confused as to how these programs are using Winsock/LSP DLL injection in Windows 8+ since, at least based on my reading, every OS newer than 7 is supposed to be incompatible with it/require that developers use WFP instead.  Perhaps there is no hard block on it though as I thought there was.  I may have to dig deeper to find out what the truth is.

In my opinion, one of the biggest problems with LSPs is that they inject their DLLs into other programs' processes to control traffic rather than simply hooking directly into the network stack and handling things on a machine level (the way that WFP does) as DLL injection can cause all sorts of problems with stability, compatibility and especially security (since, if DLL injections are allowed into what is supposed to be a secure process, its memory and activities can be modified by the third party DLL thus compromising the application's process).  This is also incidentally why Microsoft, Google and Mozilla are all getting away from allowing DLL injection into their browsers' processes which I suspect will break compatibility with this and any other VPN/web filtering software that uses LSP/Winsock rather than WFP once they roll out versions of their browsers that include enforcement for these policies.  In fact, at least as I understand it based on my research, Modern/Metro apps in the Windows Store on Windows 8/8.1/10 already block such injection since it violates the secure sandbox of that interface, which was one of the main points of implementing it (aside from cross-platform compatibility with mobile devices, of course).

Either way, hopefully this issue will be addressed soon so that Malwarebytes is no longer affected by this issue.  Hopefully there is a solution which allows the problem to be fixed while still retaining their newly implemented Early Launch Antimalware (ELAM) driver/functionality as that's a big feature for Windows 10 for security applications like Malwarebytes.

Link to post
Share on other sites

  • 1 month later...

Nothing yet unfortunately, but based on what I've been hearing from Support it is likely that this issue should be addressed in the next release of Malwarebytes assuming the Developers have been able to find a solution.  That said, I don't know when the next version of Malwarebytes is set to be released so I would suggest keeping an eye on this area of the forums as they always announce the new releases in a pinned topic at the top of this area.

Link to post
Share on other sites

  • 4 weeks later...


This issue should be resolved by the new beta build of Malwarebytes, version 3.8.  You can learn more about it here.

If you decide you wish to give the beta a try then please open Malwarebytes and navigate to Settings>Application and scroll to the bottom of the tab where it shows the option to enable beta updates and select the option to do so and click Yes at the confirmation prompt then scroll back to the top of the same tab and click on the Install Application Updates button and allow it to download and install the new build, allowing it to restart your system if prompted to do so once the installation completes, making sure that you save anything you were working on before you do.

If you do try the beta, please let us know if it resolved the issue you were experiencing or not.


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.