Jump to content
cgh

MEEClientService not starting up automatically

Recommended Posts

Hi,

We have noticed that a few new PCs we have rolled out doesn't show as online on the Malwarebytes Managed Console. I noticed that on these PCs, MEEClientService isn't starting up when I look in Services.msc. When I click "Start", then they show up as "online" in the MBAM console. When I reboot the new PCs, the service isn't running anymore until I manually start them again. I have tried reinstalling the Malwarebytes client on the new PCs but it doesn't fix the issue. These new PCs are Windows 10 Pro 1809. 

Is there a fix for this? 

meeclientservice.PNG

Share this post


Link to post
Share on other sites

I apologize, I meant they are Windows 10 1803.

Share this post


Link to post
Share on other sites

Sorry about this issue, if the service is able to start manually without any errors or issues we can run the following:

@echo off
REM Sets service to start automatically, with a delayed start
sc config MEEClientService start= delayed-auto
REM Sets service restart option to 15 minutes, failure count reset to 2 minutes
sc failure MEEClientService actions= restart/900000 reset= 120

This script will change the service settings to help them stay on more reliably, just run this on the machine or can be deployed through GPO or 3rd party deployment tool.

Let us know if we still have any issues with those settings in place?

Many Thanks,

Edited by djacobson
Box link requested to be removed.

Share this post


Link to post
Share on other sites

To follow up on Kevin's post, MBMC 1.9 now has the ability to set these service restart properties within the policy. Win 10, especially with Fast Boot enabled, has trouble waiting for the service to start before moving on.

 

Capture.JPG.7201a1c4f347c82dee92803f7f5d671a.JPG

Share this post


Link to post
Share on other sites

Would disabling Fast Boot from within the BIOS resolve this issue?

Share this post


Link to post
Share on other sites

We'd rather have you use the service properties than to disable a Windows service, however, you can give it a try and/or mix and match with the policy service property options and see if it helps your Win 10's. It's not the bios Fast Boot option, apologies, it is the Window's Fast-Startup option in the Power Options, Control Panel. Disabling it was the old workaround, editing the service properties was the resolution and the service options becoming available within policy was the final fix.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.