Jump to content
Tby

No internet after running malwarebytes

Recommended Posts

Hi, im running osx 10.11.2 and am now getting a "no internet" message after running malwarebytes and removing all of the malware files found.  Ive read the other threads on this site that seem to relate to a similar problem, and attempted some of the fixes there, but no luck.  Would really appreciate some help!  Thanks v much 

Share this post


Link to post
Share on other sites

First off, you really need to be running 10.11.6 with Security Update 2018-004 El Capitan which fixes hundreds of bugs and dozens of security issues with what you are still using. Honestly, there isn't any real way to troubleshoot a system that is so far out of date. The current version of Malwarebytes assumes that you are running an up to date OS.

Secondly, I need to know exactly what those fixes you attempted were so I don't repeat them here.

Lastly, where are you seeing the "no internet" message? Malwarebytes, your browser, your e-mail, all of the above?

Share this post


Link to post
Share on other sites

Hi Alvarnell, thanks for your reply!

Re, OS -- I hadn't realized I was so out of date.  I usually update as soon as/whenever prompted.  I'll be happy to update when get my internet restored.

Re, Messages -- The "no internet" message is displaying in the browser for both Safari and Chrome.  For Safari it reads: "Safari Can't Open the Page [WEBADDRESS] because the server unexpectedly dropped the connection.  This sometimes occurs when the server is busy.  Wait for a few minutes, and then try again".  For Chrome it reads: "No Internet.  There is something wrong with the proxy server, or the address is incorrect.  Try: * Containing the system Admin. * Checking the proxy address.  ERR_PROXY_CONNECTION_FAILED."  However, the wifi connection icon in the taskbar is showing my network, and network preferences is showing that I am connected to that network.

Re, fixes, I've tried three: (1) For Chrome, I have gone "Menu"--> "Settings" --> "Advanced" --> "Restore settings to their original defaults", (2) For Safari, I have cleared history, (3) for the OS, I have gone "System Preferences"-->"Network"--> "Advanced"-->"Proxies", and then cleared all proxies listed in the "Bypass proxy settings for these Hosts & Domains" (there were 4 or 5 addresses in here).  In case any of these required a re-start to effect, I have restarted several times.

Look forward to your reply, thanks again

Share this post


Link to post
Share on other sites

Thanks for the details.

Run through all the suggestions in the pinned article at the top of this forum. Many users have had success by running though each of the suggested steps.

 

Share this post


Link to post
Share on other sites

Ok thanks -- I've worked through each of the suggestions there but no change.  I.e., Safari is still showing the same message, and Chrome (now deleted from all folders and subfolders listed in the link, and reinstalled) likewise still saying "No internet".  What next?

Share this post


Link to post
Share on other sites

I don't think I got a clear answer to my earlier question. Do all your other apps still have Internet access (e.g. Mail, Mac App Store)? 

What happens when you log into a different account (if you are only user create an additional for testing purpose)?

What happens when you log in with Safe Mode enabled (hold Shift-key down at reboot)?

Since you are able to post here (on some other device?), I’m guessing it's not a router problem?

Share this post


Link to post
Share on other sites

Sorry -- can confirm that apps are not able to connect (App Store: "Cannot Connect to the Ap Store"; Pandora App: "You computer is having trouble connecting to the network", etc)

I have a "guest" user account -- the internet/browser connection works fine when logged in there: can surf the web, app store loads, etc.

Logging in using safe mode is also good -- the internet/browser connection works fine in safe mode: can surf the web, app store loads, etc.

And yeah, have multiple other devices (phone, laptop) accessing same network successfully, plus (per above) guest account and safe mode both can access same network, so I'm also guessing it's not a router problem. 

We're making progress?

 

Share this post


Link to post
Share on other sites

Most likely, some adware or malware that was installed made changes to proxy settings. Open System Preferences, then click the Network icon. Next, click the Advanced button. Finally, click the Proxies tab, and remove any proxies set there.

Share this post


Link to post
Share on other sites

So the fact that all apps Internet connection apps are affected tells us we've been looking in the wrong place for the problem (browsers). Since your guest account is working we know the problem is limited to your user environment. And since Safe Mode operation is OK, it means that something which normally loads when you log into your account is causing this, it helps narrow things down a bit, but still leaves that root cause to be somewhat of a mystery.

I know you said you have already removed 4 or 5 proxies already. Can you check again to see if they are all deleted and all the protocols to configure are unchecked?

 

Share this post


Link to post
Share on other sites

I dont know which of the above fixes did it, but after restarting today (after starting in safe yesterday mode) everything seems to be back to normal in my usual profile.  I.e., all signs of malware gone, but internet connection is 100% functional too.  Thanks v much for your help..! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.