Jump to content

RichEdit issue


Recommended Posts

I have been using Cute FTP for years, and now out of nowhere I am getting the following error message when I try to launch the program...

System error - RichEdit initialization failed.  Please make sure that the latest RichEdit libraries are present.

Google searches are no help.  No two sites suggest the same solution, and there seems to be no simple straight forward solution.  Any ideas or help would be greatly appreciated.

I am running Windows 10 Professional.  My computer is a laptop purchased about six months ago.  This is the first time I have tried it since about August, I believe, and it worked fine then.

Link to post
Share on other sites


Given the fact that the libraries being mentioned are components of the OS itself, it's possible that your Windows installation has been damaged or corrupted somehow, either in the registry or the filesystem or both.

You may try uninstalling/reinstalling your FTP program, however this is very unlikely to correct the issue given the nature of the error, but it couldn't hurt to try that if you haven't already.

If it is files that are missing then executing sfc /scannow from an administrative command prompt (making sure you have your Windows 10 installation media handy in case it is requested for replacing any missing files discovered by the scan) may correct the problem, however if the issue is with the registry then locating the exact issue could be virtually impossible as there is no easy way to check for and correct such issues (any so-called "registry repair" type utilities only scan for orphaned keys/entries leftover from software which has been removed from the system, not a single one of them contains any sort of comprehensive database of actual Windows system keys/registry structures to verify your registry hives against to perform any sort of true repairs) so a repair installation of Windows might be the only way to fix it.  You can find instructions on using System File Checker (SFC) in this Microsoft support article.

Also, if you have any System Restore points from any time before the issue started, that could be used to restore the system to an earlier date when the program was working and might rectify the problem, however any software/updates/drivers etc. installed since that time would likely need to be reinstalled (though your personal files should not be affected).

You could also try uninstalling your FTP program then creating a new user account in Windows, then reinstalling the FTP software from that new user account after restarting your system and it may work, especially if the issue is being caused by your current user account's registry hives or local data storage folders/files.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.