Jump to content

Malwarebytes Premium Web protection not turning at start up


Recommended Posts

I have been noticing that lately that recently my copy of MBAM has not been able to turn on web protection at start up. a look at the event viewer shows that mbamtray.exe failed to start with a 0xc000005 error with faulting module Qt5core.dll.

 

I can restart the mbam service to get everything working again, but then an event in the event viewer appears that says "Session "MBAMSwissArmy" failed to start with the following error: 0xC0000035" 

 

I am unable to determine what the second error means, I know the 0xc0000005 is basically a access denied error. but I don't know why mbam is being denied access to it's own files. I have the mbam support tool, and it asked me to restart after hitting the repair button. but I have yet to determine if the issue is fixed yet.

Link to post
Share on other sites

***This is an automated reply***

Hi,

Thanks for posting in the Malwarebytes 3 Help forum.

 

If you are having technical issues with our Windows product, please do the following: 

Spoiler

If you haven’t already done so, please run the Malwarebytes Support Tool and then attach the logs in your next reply:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  1. Download Malwarebytes Support Tool
  2. Once the file is downloaded, open your Downloads folder/location of the downloaded file
  3. Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  4. Place a checkmark next to Accept License Agreement and click Next
  5. You will be presented with a page stating, "Get Started!"
  6. Click the Advanced tab
    Repair menu_arrows.png
     
  7. Click the Gather Logs button
    Advanced_arrows.png
     
  8. A progress bar will appear and the program will proceed with getting logs from your computer
    Advanced Gather Logs_arrows.png
     
  9. Upon completion, click a file named mbst-grab-results.zip will be saved to your Desktop. Click OK
    Advanced Gather Logs completed_arrows.png
     
  10. Please attach the file in your next reply. Before submitting your reply, be sure to enable "Notify me of replies" like so:
     notify me.jpeg  

Click "Reveal Hidden Contents" below for details on how to attach a file:
 

Spoiler

To save attachments, please click the link as shown below. You can click and drag the files to this bar or you can click the choose files, then browse to where your files are located, select them and click the Open button.

mb_attach.jpg.220985d559e943927cbe3c078b
 

One of our experts will be able to assist you shortly.

 

If you are having licensing issues, please do the following: 

Spoiler

For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/community/consumer/pages/contact-us to get help

If you need help looking up your license details, please head here: https://support.malwarebytes.com/docs/DOC-1264 

 

Thanks in advance for your patience.

-The Malwarebytes Forum Team

Link to post
Share on other sites

umm... the link you gave was for v4.0 of eset AV, I am using Eset Smart Security Premium 12. so the options are different.

 

I have an option to exclude processes, and an option to exclude files and directories. which one should I choose?

 

Link to post
Share on other sites
17 hours ago, cybot said:

I have an option to exclude processes, and an option to exclude files and directories. which one should I choose?

I would start with Processes, but you may have to do both

Link to post
Share on other sites

problem seems to have been solved. but the events in the event viewer seem to be a separate issue. I updated my copy of MBAM on my surface pro, and as soon as it updated, the error I noted above, the 0xc000005 and the 0xC0000035 errors started showing up on that device too. It would appear that the mbamtray/qt5core.dll  and the mbamswissarmy errors are in the current version MBAM. the errors appear to be nonfatal, so everything should be alright.

 

My PC is Windows 7 Ultimate SP1 x64

the Surface Pro is running (of course) Windows 10 Pro (1809)

 

looking around the forum, others are seeing this error as well

Link to post
Share on other sites

tried to go back to thelast version of mbam (3.3.1) that was on the surface  since it did not cause any errors,  but as soon as it started to update the definitions, the exploit protection turned off and the event viewer said the anti exploit service could not start because it was not a valid win32 application. I don't know if this is because of an error in the update files, or because I was using an old version of mbam.

Link to post
Share on other sites

 

between now and when I last posted, I performed a reset operation on the surface pro. I did choose to keep personal files, but all installed apps got removed. there weren't very many apps to begin with installed, so it wasn't a problem. when I went to reinstall mbam (latest version), I thought I would have to go and track down my license info, but much to my surprise, mbam was already activated with my license info. when I looked at the event viewer, there were still messages about mbam, but they were only informational, no errors, or warnings about mbam were present. If this is the solution to those 0xc00000005 and 0xc00000035 errors, this poses a problem for me and many other windows 7 OEM users, as normally we don't have the OS installation files for doing a repair or even a clean install. in my case, my only options seems to be do a factory restore, or upgrade to windows 8 Pro or windows 10 Pro (I have valid licenses for both). for now I will use what repair options I have available to see if I can get anywhere, mainly chkdsk, sfc, and dism.

Link to post
Share on other sites

If something like this happens again it shouldn't be necessary to reinstall Windows or anything else that drastic.  A clean install of Malwarebytes itself should correct it.  The following instructions may be used if you come across this issue again (and of course for anyone else reading this topic who may have similar issues):

  1. Download and run the Malwarebytes Support Tool
  2. Accept the EULA and click Advanced tab on the left (not Start Repair)
  3. Click the Clean button, and allow it to restart your system and then reinstall Malwarebytes, either by allowing the tool to do so when it offers to on restart, or by downloading and installing the latest version from here

Also, with regards to Windows, you should be able to get a copy of the installation media from here and I'd recommend reading the FAQ located here.  If you are unable to download the installation media that way, I'd suggest contacting the system vendor/manufacturer as they should provide you with installation media (assuming your system does not have a Windows recovery partition already on the drive of your system).

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.