Jump to content

Google chrome certificate question.


Recommended Posts



I ordered free software from quadspinner and got a mail with the download links.

It’s not working in google chrome 69.0.3497.100

On whatever link I click in the mail it takes ages to open and when it does I get a window that asks : “Select a certificate to identify yourself” I always cancel because the certificates showed are personal certificates to communicate only with Official sites and are linked to our identity card.

The result is an error on the page : this site cannot be reached,and that’s it. 

I can visit all the other sites of quadspinner but NOT the ones with https://.

I tried to find the solution but could not find anything usable.

I opened the mail in internet explorer and get the same request to identify myself, I just click cancel and I was able to download everything I needed.


Perhaps someone knows a solution, if not there is still the workaround : internet explorer.


Thanks in advance.


Link to post
Share on other sites

  • 2 weeks later...

Since no one found the solution so far, I'm pleased to say that it solved itself.

Another more frequent error in google chrome : ERR_SSL_VERSION_INTERFERENCE made  me search disable TLS 1.3 in chrome://flags/ was the solution and it appeared that the problem above was solved by the same settings.

If this is the safest option I don't know but it works. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.