Jump to content
BreadmanYan

Win7 computer keeps waking up right after I put in on sleep

Recommended Posts

I clicked on sleep instead of shutting it down, and in a few moments/not very long after, it starts back up again. I disabled the wake timer, tried checking for any software, and disabled Realtek PCIe GBE Family Controller. Does anyone know why?

Share this post


Link to post
Share on other sites

There are other things to take a PC out of sleep such as Wake on USB, Wake on LAN ( albeit you indicated you disabled the Ethernet controller ).  These are "wake on Events" type settings in the BIOS.

Share this post


Link to post
Share on other sites

I have not used it.  I have used software to send a "Magic Packet" to a PC to release it from sleep under Wake on LAN.

However I presume the removal and or insertion of a USB device may release it from sleep.

In theory, a faulty USB device that is failing to Plug 'n Play correctly may play havoc with Wake on USB.

 

Share this post


Link to post
Share on other sites

I suggest you go into the system BIOS and disable any/all "Wake ON.." functions alongside the Wake Timer.

 

Share this post


Link to post
Share on other sites

Yes.  The BIOS is a series of Basic Input/Output System routines.  The BIOS is a set of software routines ( stored in ROM ) that sit in between any given Operating System and the hardware.  Every computer goes through a Power On Self Test ( POST ) where the BIOS "tests" the system and sets parameters. The system owner/user is given a short opportunity to access this software during the POST process  by hitting a Hot Key.  This can be the "F2" or "Esc" key or other ( depending on the system ).  At which point one can enter the BIOS software and make changes, correction or set parameters.  The settings are held in a scratch pad of RAM called the CMOS whose contents are kept "live" by a CMOS battery.

It is within the BIOS settings that "Wake On..." functions can be disabled.  Something is causing the system to be released from sleep.  We want to eliminate the possibilities.

Share this post


Link to post
Share on other sites

It could also be some third party software with a scheduled task or even the graphics adapter driver preventing the device from remaining in a sleep state.  Updating your graphics drivers may help if that's the cause and checking Task Scheduler might also reveal what's going on.

You can find drivers for common graphics hardware at the links below:

Intel Integrated Graphics drivers
NVIDIA graphics drivers
ATI/AMD graphics drivers

You may also find the following article to be of help:

How to Prevent Your Computer From Waking Up Accidentally

Share this post


Link to post
Share on other sites

That's a good thought Samuel - Dank je.

Note that for a Scheduled Task to take a computer out of sleep to perform said task, the task must be specifically enabled to do so.  Therefore that is what should be looked for under the Conditions tab.

Image.jpg.23b343291a6e62693a93fb7c8209c59b.jpg

Another possibility is to check the Advanced Power Settings under the Power Options Control Panel applet under;  Sleep --> Allow Wake Timers.

Share this post


Link to post
Share on other sites

I've updated the drivers, and so far it hasn't done any accidental awakenings. Don't know if it might surprise me later on, but for what it is, nothing's off.

Share this post


Link to post
Share on other sites

That's great news :)

I hope that it remains fixed.  I had a sneaking suspicion it might be the drivers as I've seen similar problems with sleep states in the past ever since the Windows Vista launch (when WDDM video driver model was first launched, which is still in use today in all modern Windows versions and the associated graphics drivers for devices that are compatible with it; don't get me wrong, it has some great advantages like easier driver removal/upgrade, but some of the bugs/issues that often plague them, especially older drivers, can be a real pain).

Anyway, yes, please let us know if the issue returns and if there is anything else we might assist you with.

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.