Jump to content

Cannot remove "Fastsearch" chrome hijacker


Recommended Posts

Hey everyone,

This is the first time I've had to inquire about malware in a long time.

My Chrome browser (on Mac High Sierra) gets hijacked by an entity called "Fastsearch" which opens whenever I open a new tab or window.

I've ran updated Malware Bytes to no avail as it doesn't find anything. I've deleted chrome's application support files and reinstalled Chrome but the issue persists. I'm starting to think it's another application or something else that is actively installing this malicious extension to new iterations of Chrome when installed.

 

If anyone could give me any insight into this I would massively appreciate it as it's starting to really bother me.

Thanks so much for reading!

Link to post
Share on other sites

  • Root Admin

I don't own a Mac to verify how to clean, but we do this type of cleaning often on Windows. Basically it boils down to settings in Chrome that if you delete the sync and change settings as shown in the article posted below (this was written for Windows, not Mac) it may help you.

Again, this article was written to address Google Chrome, on Windows, but may possibly help on Mac.

 

Thank you

Ron

 

 

Link to post
Share on other sites

UPDATE:

After nuking chrome again, it appears that Fastsearch is no more! I must've missed something the first time around. This time I also ended any and all Google processes running in the background.

Steps:

1. Close chrome and force quit chromium and chrome/google processes in Activity Monitor.
2. Completely Erase all of these files and folders (thanks treed for this info):

/Applications/Chrome.app
/Library/Application Support/Google/
/Library/Google/
~/Library/Application Support/Google/
~/Library/Google/
~/Library/Preferences/com.google.Chrome.plist

3. Restart computer.

4. Download and reinstall fresh Chrome.

5. Profit. RIP Fastsearch.

 

Hope this helps, guys. I'm going to add this to my original post. Thanks for all your suggestions.

 

 



 

Link to post
Share on other sites

On 9/27/2018 at 4:02 PM, Aesthetica said:

UPDATE:

After nuking chrome again, it appears that Fastsearch is no more! I must've missed something the first time around. This time I also ended any and all Google processes running in the background.

Steps:

1. Close chrome and force quit chromium and chrome/google processes in Activity Monitor.
2. Completely Erase all of these files and folders (thanks treed for this info):


/Applications/Chrome.app
/Library/Application Support/Google/
/Library/Google/
~/Library/Application Support/Google/
~/Library/Google/
~/Library/Preferences/com.google.Chrome.plist

3. Restart computer.

4. Download and reinstall fresh Chrome.

5. Profit. RIP Fastsearch.

 

Hope this helps, guys. I'm going to add this to my original post. Thanks for all your suggestions.

 

 



 

I too had tried "everything" -- including following every step to the letter nuking Chrome and trying Malware, Norton, DetectX, CleanMyMac, et. al.   

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.