Jump to content
bart1946

In version 3.6.1 MBAMservice keeps starting and stopping

Recommended Posts

Malwarebytes version 3.5.1 worked flawless but after updating to 3.6.1 the service MBAMservice does not stay on. It starts and stops and starts again and stops again without end. I cannot discover which service or program keeps interrupting MBAMservice. What can I do to rectify the situation? For the time being I did fall back to version 3.5.1.

Share this post


Link to post
Share on other sites

***This is an automated reply***

Hi,

Thanks for posting in the Malwarebytes 3 Help forum.

 

If you are having technical issues with our Windows product, please do the following: 

Spoiler

If you haven’t already done so, please run the Malwarebytes Support Tool and then attach the logs in your next reply:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  • Download Malwarebytes Support Tool
  • Once the file is downloaded, open your Downloads folder/location of the downloaded file
  • Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  • Place a checkmark next to Accept License Agreement and click Next
  • You will be presented with a page stating, "Welcome to the Malwarebytes Support Tool!"
  • Click the Advanced Options link

    welcome mbst.png
     
  • Click the Gather Logs button

    gatherlogs.png
     
  • A progress bar will appear and the program will proceed to gather troubleshooting information from your computer
  • Upon completion, click OK
  • A file named mbst-grab-results.zip will be saved to your Desktop
  • Please attach the file in your next reply. Before submitting your reply, be sure to enable "Notify me of replies" like so:

     notify me.jpeg  


    Click "Reveal Hidden Contents" below for details on how to attach a file:
     
    Spoiler

    To save attachments, please click the link as shown below. You can click and drag the files to this bar or you can click the choose files, then browse to where your files are located, select them and click the Open button.

    mb_attach.jpg.220985d559e943927cbe3c078b
     

One of our experts will be able to assist you shortly.

 

If you are having licensing issues, please do the following: 

Spoiler

For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/community/consumer/pages/contact-us to get help

If you need help looking up your license details, please head here: https://support.malwarebytes.com/docs/DOC-1264 

 

Thanks in advance for your patience.

-The Malwarebytes Forum Team

Share this post


Link to post
Share on other sites

Thanks, it looks like mbamservice is actually crashing non-stop, so let's get a crash dump please. Please do the following:

  1. Download and extract procdump.zip
  2. Right click 4 - mbamservice_crash.bat and choose Run as Administrator
  3. Once the black window opens up, simply wait for Malwarebytes to crash again (it should be happening pretty consistently)
  4. The black window should go away on it's own
  5. Once the window goes away, look in the folder from step 1 and you should see a new file that ends with .dmp
  6. Right click on the .dmp file and choose Send to -> Compressed (Zipped) folder
  7. This will create a new zip file
  8. Use wetransfer.com to generate upload the file, and near the bottom click the three little dots to upload the file and generate a download link
  9. Share the link here so I can download the memory dump and look at it

Thanks!

Share this post


Link to post
Share on other sites

Thanks for the dump @bart1946. If possible, can you please try the following:

  1. Download and extract CheckTime.zip
  2. Double click on CheckTime.exe
  3. Take a screenshot of the results
  4. Paste the results here

Also, your original logs seem to be missing some information. Can you please download and run the following:

  1. Download FRST from https://downloads.malwarebytes.com/file/frst64
  2. Run FRST64.exe and accept the EULA
  3. Check the box for Additions and then click Scan
  4. This should create two text documents on your desktop, one named FRST.txt and one named Additions.txt. Please attach both of these in your reply.
Edited by dcollins

Share this post


Link to post
Share on other sites

Thanks for that info, and sorry for the delay, this is definitely a strange one. Can you try temporarily disabling both Sandboxie and HitmanPro to see if that makes any difference?

Share this post


Link to post
Share on other sites

The MBAMservice stays on in Safe Mode. So no starting and stopping all the time. But still the message "Unable to connect the service" comes up.

screen.jpg

Share this post


Link to post
Share on other sites

I notice you did Safe Mode with Networking, how does normal Safe Mode respond?

Once you've tested normal safe mode, can you reboot back to normal mode and then gather a new set of logs using the Support Tool like you did before?

Share this post


Link to post
Share on other sites

Can you perform the steps in Post #5 again (the one where you grab the memory dump)? I would like to see if the crash is happening at the same point everytime. Thanks

Share this post


Link to post
Share on other sites

I'm not sure if it alerts him when you put his name in bold like that as the forum software might not recognize it as the alert command.

@dcollins please continue to assist this user when you can.

Also, just in case he is away like on vacation or something I will also alert another member of his team to take a look:

@nikhils if dcollins is unavailable, could you please take a look?

Thanks

Share this post


Link to post
Share on other sites
On 9/30/2018 at 3:00 AM, bart1946 said:

Is there any news yet? There must be more people with this issue. I have it on both my machines !!!

That makes me think there could a third party software that's conflicting with MWB on both your systems.  My guess is at some point you're going to be asked to perform a clean boot.

About 2-3 years ago I had to perform a clean boot to find out what was causing malwarebytes to crash on my PC and eventually found out the culprit was Dell's backup and Recovery software.

Best of luck.  I hope this problem gets solved for you. 

Share this post


Link to post
Share on other sites

 

@dcollins

Because Malwarebytes kept signaling there was an upgrade to install I did at last upgrade (again) to version 3.6.1. I was hoping against hope that the issue I had earlier was resolved. But when I saw after upgrading that the problems with MBAMservice were not gone I restored the system restore point I made just before upgrading. Curious is that now the tray icon shows program version 3.6.1 which should read 3.5.1 but also the updates are out of date. I don't know if this is typical for the error Malwarebytes shows on my computers or that this behaviour with the system restore point happens on any other system also. But I thought I should mention it here.

Because the above mentioned situation was not save I did re-install version 3.5.1. again.  I am really hoping you can help with my issue.

 

Share this post


Link to post
Share on other sites

It's typical for Malwarebytes to have issues following a System Restore because not all of its configuration files and executables get restored by default by Windows which results in a sort of hybrid/corrupt installation, so you did the right thing in reinstalling afterwards.

Share this post


Link to post
Share on other sites

I apologize for the delay, I was on vacation and unfortunately this thread got lost in the shuffle. Our developers have identified the root cause, but there is no workaround currently available. For now, please continue using 3.5.1 as you are and once a new version is available, we can reach out to let you know.

Share this post


Link to post
Share on other sites

Thank you. I hope the new version comes soon. I keep getting pop-ups from Malwarebytes wishing me to upgrade.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.