Jump to content
nukecad

Editor Bug? Weblinks not parsing.

Recommended Posts

Posted (edited)

I just made this post and neither of the 2 web addresses resolved into links, I had to go back and manually use the editor button to force them to display as links.

https://forums.malwarebytes.com/topic/235072-help-i-have-no-computer-screen/?tab=comments#comment-1263385

Edit.
That one resolved OK, strange why the others didn't.

Edited by nukecad

Share this post


Link to post
Share on other sites

Hi @nukecad,

I've tested pasting your URLs and others in the above thread and did not have any issues in the URLs automatically becoming hyperlinks.

The only time the URL did not becoming hyperlinked is when "https://" was excluded. Do you recall if when your originally pasted the URL in your thread if you included the "https://" portion in front of your URL?

Thanks,
Cecile

Share this post


Link to post
Share on other sites

Yes the https was there. Like I say it's odd, and may be one of those intermittent things that can never be tracked down.

I have had it before, but I'm not sure if it was here or Piriform which also uses Invision?

Share this post


Link to post
Share on other sites
Posted (edited)

It's just done this again in this post:

https://forums.malwarebytes.com/topic/213575-windows-10-security-centre-issue-prevents-saving-and-deleting/?tab=comments#comment-1266699

You can see I have two MS addresses there, neither of them parsed to links at first.

I edited the post and manually linked them, which gave a second odd situation.

Attempting to put parentheses around the second link, the closing bracket was always being made part of the link.
I got around that one by entering onto another line, adding the closing bracket, and then backspacing it to the previous line.

Does seem like a glitch in the way the editor is handling link parsing now and again.

Edited by nukecad

Share this post


Link to post
Share on other sites

If you try adding a new line below each link does it help?  Like maybe pressing Enter or Shift+Enter (eliminates the double-spacing) after each URL.  I know that sometimes this is necessary for me, or at least it has been in the past when posting raw URLs.

And of course, using the URL= function should also work, for example:

[url=<insert address here>]<insert address here>[/url]

Share this post


Link to post
Share on other sites

Cheers exile,

yes I do know BB code and a few tricks to get links showing as I want , I'm really just pointing out that the forum editor does not always act as expected.

PS. Did you know that the double line spacing in the post editor is configurable?
Another forum I visit has just changed over to IPB and initially theirs was also ading a paragraph space for Enter, so you needed shift+enter for single linespace.
After a poll of members the admin there changed the setting to only give single linespace with enter.
(This setting also acts retrospectively on 'legacy' posts).

I suppose it depend on the user which they prefer.
Writers, journalists, etc. tend to prefer the double paragraph space when they hit enter.
Coders tend to prefer a single linespace for an enter.

Share this post


Link to post
Share on other sites

It's still doing it, and now it seems that the post edit button has gone so I can't go back and correct it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.