Jump to content

Notification Window font size is suddenly huge

Recommended Posts

Hello everyone,

I apologize if this has been asked before. I tried searching for it, but I couldn't find anything that was dealing with the same issue.

I'm hoping my problem is caused by some simple setting that I just need to change, and that someone can just direct me to wherever that setting is. I've been using MBAM for years without any real issues but, starting just this morning, the notification window somehow became way too big. And I can't seem to figure out how to change it back. 


As you can see from the screenshot, it's taking up almost a quarter of screen. And it's font size doesn't match my system font size, which is the font size seen on the taskbar.

(Up until this morning, the font for MBAM notifications was the same size).


In trying to troubleshoot this, I did find one other post where someone mentioned that their system scaling and DPI settings were causing the MBAM application window to be too big or too small, but I'm not sure that's the same issue that I'm having because my MBAM app is still using the same font size as my system.


Like the example in the first screenshot, It's just the notification window that is too big.

I'm not sure if the cause is something I changed, or some kind of recent update, or something else altogether.

I realize that it's not a major issue, it's just kind of a mild annoyance. Regardless, I would be grateful for any advice that anyone has.

Is this something that other people have encountered? If so, how did you go about fixing it?


Link to post
Share on other sites

  • Staff

***This is an automated reply***


Thanks for posting in the Malwarebytes 3 Help forum.


If you are having technical issues with our Windows product, please do the following: 


If you haven’t already done so, please run the Malwarebytes Support Tool and then attach the logs in your next reply:

NOTE: The tools and the information obtained is safe and not harmful to your privacy or your computer, please allow the programs to run if blocked by your system.

  • Download Malwarebytes Support Tool
  • Once the file is downloaded, open your Downloads folder/location of the downloaded file
  • Double-click mb-support-X.X.X.XXXX.exe to run the program
    • You may be prompted by User Account Control (UAC) to allow changes to be made to your computer. Click Yes to consent.
  • Place a checkmark next to Accept License Agreement and click Next
  • You will be presented with a page stating, "Welcome to the Malwarebytes Support Tool!"
  • Click the Advanced Options link

    welcome mbst.png
  • Click the Gather Logs button

  • A progress bar will appear and the program will proceed to gather troubleshooting information from your computer
  • Upon completion, click OK
  • A file named mbst-grab-results.zip will be saved to your Desktop
  • Please attach the file in your next reply. Before submitting your reply, be sure to enable "Notify me of replies" like so:

     notify me.jpeg  

    Click "Reveal Hidden Contents" below for details on how to attach a file:

    To save attachments, please click the link as shown below. You can click and drag the files to this bar or you can click the choose files, then browse to where your files are located, select them and click the Open button.


One of our experts will be able to assist you shortly.


If you are having licensing issues, please do the following: 


For any of these issues:

  • Renewals
  • Refunds (including double billing)
  • Cancellations
  • Update Billing Info
  • Multiple Transactions
  • Consumer Purchases
  • Transaction Receipt

Please contact our support team at https://support.malwarebytes.com/community/consumer/pages/contact-us to get help

If you need help looking up your license details, please head here: https://support.malwarebytes.com/docs/DOC-1264 


Thanks in advance for your patience.

-The Malwarebytes Forum Team

Link to post
Share on other sites


I took a look at your logs and while this may not be related, it would be a good idea not to have explorer.exe set to run as admin:

C:\Windows\explorer.exe                                      [~ RUNASADMIN]

To change this, go to C:\Windows and find explorer.exe then right-click on it and select Properties then go to the Compatibility tab and uncheck the box next to Run this program as an administrator under Privilege level and click Apply then OK.

As for the issue with your Malwarebytes notifications, the only thing I saw in your logs that might be causing it would be the Custom Scaling setting under your display settings which you should be able to access by right-clicking your desktop background and choosing Screen resolution then clicking on Make text and other items larger or smaller and changing it to 100% (from its current 125%) and if not fixed after that, then perhaps adjusting the DPI setting which should be accessible in the same window via a link on the left side that says Set custom text size (DPI), clicking it, then changing the setting in the window that opens to 100% (from its current 120%).

Alternatively, if changing those settings makes text too small to read then you can change them back and instead open C:\Program Files\Malwarebytes\Anti-Malware and locate the file called mbamtray.exe (or just mbamtray) and right-click on it and select Properties, then click on the Compatibility tab and under the Settings section check the box next to Disable display scaling on high DPI settings and then click Apply then OK.

Once the change is made, restart your system and test to see if notifications and other text display acceptably now.

Please let us know how it goes.


Link to post
Share on other sites

Thank you for your suggestions. 

You mentioned that having explorer.exe set to run "as administrator" might be an unrelated issue.

I specifically changed explorer to run as an administrator as a workaround for the flaw in Windows 10 that sometimes doesn't allow drag-and-drop to work between explorer and an application when one has administrator rights and the other doesn't. I realize that it has the potential to cause other problems as well as potentially make my system less secure. But, to me, the hassle that it fixes is worth the possibility of those other issues. So, unless you think that it is actually contributing to this particular problem, I'd rather not have to change that one back.


As for the DPI settings. I followed your instructions to set custom DPI settings for mbamtray.exe. Even after restarting my computer the notification size is still too large. (I also experimented with applying those settings to the other .exe files that are related to MBAM, and then restarting. But, no luck).


Do you happen to know if this issue is related to a recent update or something like that? Am I the only person that is experiencing this problem? The only reason I ask is because It worked flawlessly up until a few days ago; and I haven't installed anything or changed any settings (in MBAM or my system) during that time.

If this is something caused by an update, and something that the MBAM team is aware of, then I'm happy to wait until they release a patch. 

If not, and if I'm the only one who is having this issue, then I guess the next thing for me to try is to completely remove and reinstall MBAM. And see if that takes care of it.

Unless you have any other suggestions that you think might resolve it?

Link to post
Share on other sites

The trouble with running explorer as admin is that it passes its permissions on to every process launched by it.  This means that every time you run a program by clicking a shortcut or double-clicking an executable, it automatically runs with administrative privileges.  This includes your internet browsers and other web facing apps.  There are two major issues with that.  First, the vast majority of software has been designed to function with User Account Control (UAC) active since Windows Vista, meaning it was designed generally not to run with administrative privileges, so compatibility issues and anomalous behavior may occur.  Second, which you already touched on, is the massive security hole it creates, not only for explorer.exe itself, but every program you run through it, including the example I gave of your web browser(s) meaning in a very real way you're reducing your security level to that of Windows XP, meaning these modern threats that were designed to attack systems protected by UAC which would normally install with lowest/local user privileges to avoid UAC prompts as a firewall will now be fully active as administrative processes giving them free reign over all files, folders, processes and registry hives on your system, including those which would normally be shielded by UAC and would normally be used as a means of both protecting the system by isolating the malware to less privileged locations as well as providing tools and functions a user could utilize to actually stop and remove such threats.  I would strongly advise against keeping it this way, and if the drag and drop issue is really that important, instead use an alternate shell expressly for those particular cases where you need to do so which you configure to run as admin such as the portable version of UltraExplorer or some other alternative shell program which you can run whenever you need to do such a thing (besides, in an admin account with UAC active Windows typically just gives you an extra prompt to get through via UAC, it shouldn't generally block you from dragging and dropping files to/from privileged locations save for a select few which are deliberately set to have DENY permissions for security reasons).

As for Malwarebytes, I'm really not sure but so far I've seen no other reports of this issue that I can recall, so it is possible that this or some other setting in your system is affecting it.  I doubt a clean install would fix it, though the recently released beta might.  You can install the beta by opening Malwarebytes and going to Settings>Application and scrolling down the tab to the Beta Application Updates section and enabling the option there, then scrolling back up near the top and clicking the Install Application Updates button which should initiate the download and installation of the beta.  Once it completes (which you can verify by looking at Settings>About and verifying that the Component package version: field shows 1.0.418 rather than 1.0.391), reboot the system and see if the issue is resolved.

Link to post
Share on other sites

Great, I'm glad to hear it :)

Nope, as long as it's working you're all set.  They usually just leave threads as they are for the sake of others who might come along, but don't generally mark them differently once resolved (though they do occasionally mark the best solution/answer, but not always).

If there's anything else you need just let us know.


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.