Jump to content
iAmPhilo

No Network Access but Internet works fine?

Recommended Posts

Hi

I've been looking everywhere for a fix and try resetting the internet, router, modem etc to no avail.

Basically my internet has the triangle yellow exclamation mark saying there's no internet access but it is working as I'm typing on my PC with it

The trouble is some apps won't work as it says I have no internet access, it would be much appreciated if someone can help me!

Also I have tried the all in one network access program etc and it didn't work

Share this post


Link to post
Share on other sites

Do you mean an icon in the System tray is indicating you don't have Internet Access but in fact if you load a Browser and go to Google, you can get to Google anyway ?

 

Share this post


Link to post
Share on other sites
Posted (edited)
13 minutes ago, David H. Lipman said:

Do you mean an icon in the System tray is indicating you don't have Internet Access but in fact if you load a Browser and go to Google, you can get to Google anyway ?

 

Yeah sorry, the system tray says no internet access but I have internet access as you mention.

I have tried updating the driver but still the same problem, I can' t remember if it started when I installed Malwarebytes, could be wrong

Edited by iAmPhilo

Share this post


Link to post
Share on other sites

There is no "driver" to update.  If it was a network Interface problem that does have a Hardware Driver, you would not have Internet access at all.  It is a Logic Error in the OS where it comes to a faux conclusion and thus displays the erroneous information. Proven to be erroneous by actual Internet Access.

I have seen this with Windows 7 all too often.  Is this Windows 7 ?

Have you Logged Off and then Logged On or Rebooted ?

Share this post


Link to post
Share on other sites

Well when I mean driver, Intel LAN Driver which I downloaded through asus website for my motherboard.

I am using Windows 10 and fully up to date 

Share this post


Link to post
Share on other sites

Yes.  Either the driver is installed and works or it doesn't.  If you accessed the Internet then the LAN Driver was a wrong route.

Have you Logged Off and then Logged On or Rebooted ?

What is the Make and Model of the Network Interface ?  ( ex:  Intel Gigibit Ethernet model ####### )

How is the PC connected to the Local Area Network ? ( Ex: Ethernet cable to Router with the Router LAN port at 1,000 Mb/s )

Share this post


Link to post
Share on other sites
Posted (edited)

Yeah I have restarted, turned pc off etc and still the same problem, still says no internet access but I can access

Intel I211 Gigabit Network I think is the model, I got it from Device Manager

Connected with Ethernet cable to Router (asus)

Well I am using Superhub 3 (Virgin Media) in Modem mode connected to my Asus RT AC87U which is then connected to my pc by ethernet

(I have restarted both modem/router and turned them off for 30 second before turning back on to see if it works, still same problem)

 

Edited by iAmPhilo

Share this post


Link to post
Share on other sites
Posted (edited)

I don't know why Win10 is making the erroneous declaration.

Instead of Turning-off and On the router and PC.  There is something else to try.  Intel Ethernet Interface software provides a capability to change the way the device connects to a network.  There is 1Gb/s, 100Mb/s Half Duplex & 100Mb/s Full Duplex and 10Mb/s Half Duplex &10Mb/s Full Duplex

We can change this from the POV of the PC's Network Interface and we can change this from the POV of the Router.

Follow the directions up to Step #3 in the following

https://idoc.vsb.cz/xwiki/bin/view/tuonet/sit-nastaveni/tcp-ip/tcp-ip-win10/?language=en

However instead choose "Configure" under where it shows Intel(R) Centrino...

4en.png

 

 

 

 

You will get a dialogue such as the below.  Then Choose "Link Speed".

The objective is to change this which will force the way the PC connects to the  Switched Ethernet Port on the Router.  If it is at 1.Gbps as in the below graphic, change the "Link and duplex"  to 100Mbs Full Duplex.  That should disconnect the PC from the network and renegotiate a connection with Ethernet switch on the Router.  Then see HOW THE PC reacts with the Windows 10 system Tray Connection Icon.

Configure.jpg.e29d194bc3f4a25be5e3de3c052f36ed.jpg

 

** Conversely, we can do this from the POV of the Router by looking a what LAN Port on the Router the PC is connected to and change the Router software to change the Link Speed at that Port.  The preference is for the POV of the PC so the Windows OS can react "more" to the changes.

 

 

Edited by David H. Lipman

Share this post


Link to post
Share on other sites
On 7/4/2018 at 1:14 AM, David H. Lipman said:

I don't know why Win10 is making the erroneous declaration.

Instead of Turning-off and On the router and PC.  There is something else to try.  Intel Ethernet Interface software provides a capability to change the way the device connects to a network.  There is 1Gb/s, 100Mb/s Half Duplex & 100Mb/s Full Duplex and 10Mb/s Half Duplex &10Mb/s Full Duplex

We can change this from the POV of the PC's Network Interface and we can change this from the POV of the Router.

Follow the directions up to Step #3 in the following

https://idoc.vsb.cz/xwiki/bin/view/tuonet/sit-nastaveni/tcp-ip/tcp-ip-win10/?language=en

However instead choose "Configure" under where it shows Intel(R) Centrino...

4en.png

 

 

 

 

You will get a dialogue such as the below.  Then Choose "Link Speed".

The objective is to change this which will force the way the PC connects to the  Switched Ethernet Port on the Router.  If it is at 1.Gbps as in the below graphic, change the "Link and duplex"  to 100Mbs Full Duplex.  That should disconnect the PC from the network and renegotiate a connection with Ethernet switch on the Router.  Then see HOW THE PC reacts with the Windows 10 system Tray Connection Icon.

Configure.jpg.e29d194bc3f4a25be5e3de3c052f36ed.jpg

 

** Conversely, we can do this from the POV of the Router by looking a what LAN Port on the Router the PC is connected to and change the Router software to change the Link Speed at that Port.  The preference is for the POV of the PC so the Windows OS can react "more" to the changes.

 

Thanks David, I just tried above and it still the same problem :(, I really have ran out of ideas than to do a clean install or maybe just live with it.

 

Share this post


Link to post
Share on other sites
Posted (edited)

OK.

Another idea...

Open a Command Prompt ( CMD.EXE ) with Administrative Privileges and enter

netsh   int   reset

When it is completed, reboot the PC

Reference:

https://www.howtogeek.com/194041/how-to-open-the-command-prompt-as-administrator-in-windows-8 or 10/

https://www.thewindowsclub.com/how-to-run-command-prompt-as-an-administrator

Edited by David H. Lipman

Share this post


Link to post
Share on other sites

I see this all to often on my Win10 1803 box all the time.... I have learned to just ignore and eventually on another reboot it fixes itself...

Share this post


Link to post
Share on other sites

Well I connected to my home pc to see netsh int reset  would work, (although I had done that previously) but now the icon shows correctly... LOL

Share this post


Link to post
Share on other sites
1 hour ago, David H. Lipman said:

Interestingly enough, the system checks communication with...

http://www.msftconnecttest.com/connecttest.txt

Which simply returns "Microsoft Connect Test"

IFF it reads that, it considers the PC to have an Internet Connection.

Didn't work

What work was when I turned my PC off, modem and router off for 30second and turn everything on, it finally works

But after a reboot, triangle again. Seem to be happening on 1803 which might be true as previously I never had this problem on the 17xx version

Share this post


Link to post
Share on other sites

Can you access http://www.msftconnecttest.com/connecttest.txt ?

NOTE:  I have had systems that could access the above but the icon still shows "No Internet Access" when it truly was.

Here's an experiment...

Create another Win10 account.

Logon to that secondary account.

Same icon issue ?

Share this post


Link to post
Share on other sites
18 hours ago, iAmPhilo said:

What work was when I turned my PC off, modem and router off for 30second and turn everything on, it finally works

this has worked on my computer as well... it all seems to point to a bug in Windows of some sort..

Share this post


Link to post
Share on other sites
On 7/7/2018 at 12:59 AM, David H. Lipman said:

Can you access http://www.msftconnecttest.com/connecttest.txt ?

NOTE:  I have had systems that could access the above but the icon still shows "No Internet Access" when it truly was.

Here's an experiment...

Create another Win10 account.

Logon to that secondary account.

Same icon issue ?

Same issue unfortunately, might have to just live with it or do a clean install

Share this post


Link to post
Share on other sites

                                Dunno.gif.aa4fb2b83018a142afb85656461152a7.gif

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.