Jump to content

browser extension beta 1.0.24 fails to re-enable protection when expected


grahamperrin

Recommended Posts

Steps:

  1. observe a pup-related block
  2. temporarily continue to the site
  3. re-enable protection against malware/scams – throw the switch, from left to right

Expected:

  • protection

Actual result:

  • automated unprotected reload of the page that should be blocked
  • the GUI of Malwarebytes Browser Extension suggests that blocking is effective when truly, it is not
  • click the toolbar button for the extension
  • again, click the button
  • the GUI shows that the user's throw to the right (step 3) was somehow silently lost – no protection
  • wait a while – do not click the button – refrain from all activity
  • reload the page
  • observe the pup-related block.

Screen recording to follow, I chose to wait more than two minutes to work around the issue.

I have no idea how long is required, but for sanity:

  • there should be no waiting period; and/or
  • there must be no unprotected automated reload.

2018-06-23 04:22:09 frame.png

2018-06-23 04:25:01 frame.png

2018-06-23 04:25:0a frame, blocking.png

2018-06-23 04:25:0b frame, blocked.png

Edited by IPS Temp Admin
Content in lieu of placeholder text. Four frames from the screen recording.
Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    • No registered users viewing this page.
Back to top
×
×
  • Create New...

Important Information

This site uses cookies - We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.